1. fuchs's Avatar
    It is a pain to unlock phone and go to alarm setting to turn off alarm at 5 am...there must be an easier way??
    01-28-19 12:18 PM
  2. Bla1ze's Avatar
    I have never had to unlock my device to shut off the alarm. Just swipe right on the main screen when it goes off.
    Crusader03 likes this.
    01-28-19 12:52 PM
  3. Crusader03's Avatar
    Yup ^^this^^ that's how we do it. I also have my volume as a snooze. Works as expected.
    01-28-19 01:00 PM
  4. fuchs's Avatar
    Thanx, I have tried the swipe and set the volume controls to do it....but it just keeps ringing! ....until i unlock and turn it off in clock settings...??
    01-28-19 02:20 PM
  5. Bla1ze's Avatar
    Thanx, I have tried the swipe and set the volume controls to do it....but it just keeps ringing! ....until i unlock and turn it off in clock settings...??
    Not really sure what to tell you. If you're using the built-in clock app, it should just work. There's not even any settings for it really aside from the volume control buttons. The swiping left/right is a standard function that just works.
    Crusader03 likes this.
    01-28-19 02:29 PM
  6. Crusader03's Avatar
    Perhaps a hard reboot might clear any bugs in the app or phone. Other than that, could be an issue with your hardware. Should just work out of the box.
    01-28-19 03:46 PM
  7. tahna_los's Avatar
    Same here. Must Log in to phone to disable alarm. Already set up volume keys to snooze but it does not seem to be working.
    02-08-19 06:14 AM
  8. babugaru1's Avatar
    It is a pain to unlock phone and go to alarm setting to turn off alarm at 5 am...there must be an easier way??
    Same here
    02-08-19 11:35 AM
  9. tahna_los's Avatar
    OK. I think I have it figured out. Someone else stated that the alarm needed to be disabled and reenabled. That is try to "delete" except disable the alarm and reenaable it from the settings. I will let you know the real test tomorrow.
    02-09-19 11:06 AM
  10. Dino84's Avatar
    I am using AMdroid.
    Best alrm app. You can customize the alarm screen the way you like, snooze button size, close button, press durations and whatnot. You can also make it so it deactivates do-not-disturb mode when it goes off.

    Overall a great app that I use with all my phones.
    02-11-19 12:38 AM
  11. zlatko23's Avatar
    I don't know if everyone having trouble had already checked this - there are two clock applications on Key2 - BB one and Google one. Their icon, interface and widget are nearly identical. Google one is blue icon, BB - with grey. If you use Google clock app for alarm - you will not be able to stop the alarm using the volume buttons. I was having this issue and was really pissed off until I found what is going on.
    hamilgs likes this.
    02-11-19 02:14 AM
  12. MickaelM's Avatar
    Did you try to clear the clock application data ?
    02-11-19 03:39 AM
  13. kobnyc's Avatar
    It is a pain to unlock phone and go to alarm setting to turn off alarm at 5 am...there must be an easier way??
    I never have to do this. I just swipe on the screen, either 'snooze' or 'dismiss' when it goes off.
    02-11-19 10:05 AM
  14. fuchs's Avatar
    Thank you for all the tips....I ended up calling BB support.....and after some research he was able to take me through many technical steps to resolve the issue....he said that this issue was occuring in many Key2's out of the box.
    02-11-19 12:02 PM
  15. Chris_R's Avatar
    Thank you for all the tips....I ended up calling BB support.....and after some research he was able to take me through many technical steps to resolve the issue....he said that this issue was occuring in many Key2's out of the box.
    And what was the actual solution to it? The steps involved?
    02-13-19 08:18 AM
  16. jc_kime's Avatar
    Dear friend, I faced the same problem as you guys did. Eventually, I figure out that the notifications setting is the factor that disabled "swipe left for snooze vs swipe right for off" function.

    Give it a try then.

    Settings>Apps and notifications>Clock (default app on Key2 with black color)>App notification>turn on all options.

    You will see the little clock close the network indicator and battery indicator. And when the set alarm almost ring then you will see there is notification when you swipe down the from the top of the screen. Leave it there and don't touch nor dismiss it.

    Let me know if the problem solved. It worked for me guys. Hopefully it will work for y'all.
    06-18-19 11:11 PM
  17. erose75's Avatar
    I was having this problem. Read through all the posts above. What worked for me was going into settings/apps/clock then go into storage and "clear data". Then I went back into the clock and resetup the alarms and tested with a sleeping screen and it worked. I tested it with the screen locked and it also worked.

    Hope this helps as there were a few different solutions cited in the replies.
    08-26-19 09:46 AM
  18. the_boon's Avatar
    I was having this problem. Read through all the posts above. What worked for me was going into settings/apps/clock then go into storage and "clear data". Then I went back into the clock and resetup the alarms and tested with a sleeping screen and it worked. I tested it with the screen locked and it also worked.

    Hope this helps as there were a few different solutions cited in the replies.
    Maybe clearing the cache would be sufficient?
    08-26-19 10:22 AM
  19. erose75's Avatar
    Possibly but setting the alarms back up is easy enough so I just went the clear data route. If someone else wants to try clearing cache instead of clearing data and report back, that would be helpful.
    Maybe clearing the cache would be sufficient?
    08-26-19 10:26 AM

Similar Threads

  1. Replies: 8
    Last Post: 02-23-19, 10:56 AM
  2. My Keyone not connecting to any WiFi
    By crowning73 in forum BlackBerry KEYone
    Replies: 8
    Last Post: 01-31-19, 04:36 AM
  3. Phone won't turn on, just flashes red?
    By Johnny Li in forum BlackBerry DTEK60
    Replies: 4
    Last Post: 01-28-19, 01:21 PM
  4. A lifetime subscription to VPNSecure is currently 94% off!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 01-28-19, 10:40 AM
  5. Replies: 2
    Last Post: 01-27-19, 04:53 PM
LINK TO POST COPIED TO CLIPBOARD