12-11-19 10:48 AM
31 12
tools
  1. classact's Avatar
    I got a Key2 from GoTalk and put it on a new AT&T wireless postpaid account I just obtained with a new number. I'm getting a weird error message.

    In "Phone > Settings > Calls > Additional settings" it gives me the error message "Network or SIM card error!"

    And yet, after I hit OK it does take me into the module. Once in, the two choices are for Caller ID (whether my outgoing calls show my number), which seems to take and keep the choice I make, and Call Waiting (to beep me when a call comes in when I'm on a call) -- and the default shows it as off and when I turn it on it won't take and is still set to off when I go back in, yet the feature is working properly in spite of that, meaning I do get the call-waiting beep when a second call comes in and I can answer it just fine, with the options then to merge or swap calls.

    I wonder what's up with that? Are others having this same issue? And is all else working okay on AT&T (MMS, etc, etc, even when drilling down into other settings modules)?

    (Note that I created what became a long thread on CB about my prior experience trying to make the Key2 work on Verizon and this same module gave the same error but would not let me in to change Caller ID settings, and when I made calls from my Contacts it would not show me their names while on the call or in log/history. With AT&T showing the names is working fine.)
    12-08-19 01:16 PM
  2. Bob80220's Avatar
    I'm on AT&T with my KEY2 and I show the same.

    Call Waiting and Caller ID work as they should... 👍

    Bob
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-62088.jpg  
    12-08-19 01:43 PM
  3. classact's Avatar
    Yup, same as what I see.

    I've also discovered it doesn't seem to want to receive an MMS (video shows as black). Have you encountered that as well (and resolved it)?
    12-08-19 01:45 PM
  4. Bob80220's Avatar
    MMS works as it should as well... no issues with receiving and viewing videos.

    Bob
    12-08-19 01:47 PM
  5. Bob80220's Avatar
    My Call Waiting defaults to this setting after toggling it on... Call Waiting beeps and shows who's calling... 👍

    Bob
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-62089.jpg  
    12-08-19 01:59 PM
  6. classact's Avatar
    My Call Waiting defaults to this setting after toggling it on... Call Waiting beeps and shows who's calling... ������

    Bob
    Yup. Same here. Odd, but it works.

    Also, it turns out receiving MMS is working fine except when I send from my S9 using the Verizon Message+ app for some reason. I send from my Key1 or from the S9 using the default Messages app and it received MMS fine.

    Thanks, Bob!

    Jay
    12-08-19 02:04 PM
  7. Bob80220's Avatar
    Enjoy your KEY2 on AT&T... I followed your Verizon thread so I'm aware of your frustrating experience. The KEY2 works fine on AT&T as a BYOD despite AT&T not supporting Enhanced Features.

    Bob
    12-08-19 02:16 PM
  8. classact's Avatar
    Enjoy your KEY2 on AT&T... I followed your Verizon thread so I'm aware of your frustrating experience. The KEY2 works fine on AT&T as a BYOD despite AT&T not supporting Enhanced Features.

    Bob
    Thanks, Bob!

    I'm actually going to be returning this Key2 to GoTalk. The fingerprint sensor has been very finicky (while the one on my Key1 as a point of comparison has been perfect). I'll get a new one shortly -- after my next investor or sizable sale comes in. I wanted to test it on AT&T before I send it back.

    By the way, the Key2 is receiving MMS just fine even from the Key1 using Verizon Message+. It's just a problem when sent from the S9 using Verizon Message+, which is especially odd since an MMS sent to the Key1 from the S9 using Verizon Message+ is fine. Oh, well.

    What Enhanced features are not supported on the Key2 on AT&T, please?
    12-08-19 02:24 PM
  9. Bob80220's Avatar
    What Enhanced features are not supported on the Key2 on AT&T, please?
    VoLTE and WiFi calling... 😰

    Bob
    12-08-19 02:29 PM
  10. Jay Rosenthal's Avatar
    I got a Key2 from GoTalk and put it on a new AT&T wireless postpaid account I just obtained with a new number. I'm getting a weird error message.

    In "Phone > Settings > Calls > Additional settings" it gives me the error message "Network or SIM card error!"

    And yet, after I hit OK it does take me into the module. Once in, the two choices are for Caller ID (whether my outgoing calls show my number), which seems to take and keep the choice I make, and Call Waiting (to beep me when a call comes in when I'm on a call) -- and the default shows it as off and when I turn it on it won't take and is still set to off when I go back in, yet the feature is working properly in spite of that, meaning I do get the call-waiting beep when a second call comes in and I can answer it just fine, with the options then to merge or swap calls.

    I wonder what's up with that? Are others having this same issue? And is all else working okay on AT&T (MMS, etc, etc, even when drilling down into other settings modules)?

    (Note that I created what became a long thread on CB about my prior experience trying to make the Key2 work on Verizon and this same module gave the same error but would not let me in to change Caller ID settings, and when I made calls from my Contacts it would not show me their names while on the call or in log/history. With AT&T showing the names is working fine.)
    The same thing occurs with me in settings on ATT, but I've had no problems with the Key2 on their network. Just wish they would allow Wi-Fi calling on the Key2.
    12-08-19 02:46 PM
  11. classact's Avatar
    VoLTE and WiFi calling...

    Bob
    I never had WiFi Calling work on my Key1 on VZW and I never cared.

    Looks like simultaneously using phone and browsing works fine on the Key2 on AT&T without VoLTE. Should I really care about not having VoLTE (other than maybe not having HD voice)?
    12-08-19 02:49 PM
  12. Bob80220's Avatar
    I liked having VoLTE on my AT&T branded PRIV. The call quality was noticeably clearer. But I'm accustomed to not having it on my KEY2 so life goes on.

    Bob
    12-08-19 02:53 PM
  13. Chuck Finley69's Avatar
    You guys may actually have VoLTE on Key2 but I’m not certain. AT&T supports VoLTE on both my AT&T 3/32 Carrier Locked and BE 4/64 Factory Unlocked KEYones. Neither supports WFC so there’s no rhyme or reason. The VoLTE settings are buried within the KEYone Oreo settings. Not sure where Key2 settings are.
    12-08-19 04:37 PM
  14. SteinwayTransitCorp's Avatar
    I got a Key2 from GoTalk and put it on a new AT&T wireless postpaid account I just obtained with a new number. I'm getting a weird error message.

    In "Phone > Settings > Calls > Additional settings" it gives me the error message "Network or SIM card error!"

    And yet, after I hit OK it does take me into the module. Once in, the two choices are for Caller ID (whether my outgoing calls show my number), which seems to take and keep the choice I make, and Call Waiting (to beep me when a call comes in when I'm on a call) -- and the default shows it as off and when I turn it on it won't take and is still set to off when I go back in, yet the feature is working properly in spite of that, meaning I do get the call-waiting beep when a second call comes in and I can answer it just fine, with the options then to merge or swap calls.

    I wonder what's up with that? Are others having this same issue? And is all else working okay on AT&T (MMS, etc, etc, even when drilling down into other settings modules)?

    (Note that I created what became a long thread on CB about my prior experience trying to make the Key2 work on Verizon and this same module gave the same error but would not let me in to change Caller ID settings, and when I made calls from my Contacts it would not show me their names while on the call or in log/history. With AT&T showing the names is working fine.)
    Did you register the Phone or just pop in a SIM. That error points to IMEI miss match.
    12-09-19 06:17 PM
  15. IceCreamPlz's Avatar
    You guys may actually have VoLTE on Key2 but I’m not certain. AT&T supports VoLTE on both my AT&T 3/32 Carrier Locked and BE 4/64 Factory Unlocked KEYones. Neither supports WFC so there’s no rhyme or reason. The VoLTE settings are buried within the KEYone Oreo settings. Not sure where Key2 settings are.
    Chuck is a special case. He started with a carrier device, then went to non carrier device using the same SIM. The IMEI type didn't change and a re-provisioning was never triggered.

    Actually makes me want to borrow his old device in order to enable some of those feature on my line. ; )
    12-09-19 06:22 PM
  16. Chuck Finley69's Avatar
    Chuck is a special case. He started with a carrier device, then went to non carrier device using the same SIM. The IMEI type didn't change and a re-provisioning was never triggered.

    Actually makes me want to borrow his old device in order to enable some of those feature on my line. ; )
    I know but did anyone else check their VoLTE settings on another BE or Key2 anyway?
    12-09-19 09:49 PM
  17. Jay Rosenthal's Avatar
    I liked having VoLTE on my AT&T branded PRIV. The call quality was noticeably clearer. But I'm accustomed to not having it on my KEY2 so life goes on.

    Bob
    I have VoLTE on my Key2 on AT&T and haven't had a problem since activation in August 2018. Did someone tell you it can't work?
    12-09-19 09:53 PM
  18. Bob80220's Avatar
    I have VoLTE on my Key2 on AT&T and haven't had a problem since activation in August 2018. Did someone tell you it can't work?
    I called AT&T when I purchased my KEY2 in October 2018 and was told AT&T didn't support VoLTE on the KEY2.

    Where in the settings are you finding VoLTE is active?

    Bob
    12-09-19 09:56 PM
  19. Jay Rosenthal's Avatar
    I called AT&T when I purchased my KEY2 in October 2018 and was told AT&T didn't support VoLTE on the KEY2.

    Where in the settings are you finding VoLTE is active?

    Bob
    Dial *#*#46368676#*#* and scroll down to "VoLTE provisioned" setting and turn on.
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-72114.jpg  
    Bob80220 likes this.
    12-09-19 10:07 PM
  20. Bob80220's Avatar
    Well I'll be damned... I have VoLTE despite what AT&T says... 🤔 Thanks for that information... 👍

    Bob
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-62213.jpg  
    Jay Rosenthal likes this.
    12-09-19 10:17 PM
  21. Bob80220's Avatar
    My understanding is although my KEY2 is provisioned for VoLTE it still needs to be activated by the carrier to be supported. I'm not showing that to be the case under cellular networks. So it doesn't appear that VoLTE is supported by AT&T on my KEY2.

    Evidently there should be IMS showing, which it doesn't, and when you click it the option to toggle VoLTE on will show. But since that comes from the carrier, as I'm being informed, then I don't have VoLTE active.

    Bob
    Last edited by Bob80220; 12-09-19 at 11:15 PM.
    12-09-19 11:02 PM
  22. Jay Rosenthal's Avatar
    My understanding is although my KEY2 is provisioned for VoLTE it still needs to be activated by the carrier to be supported. I'm not showing that to be the case under cellular networks. So it doesn't appear that VoLTE is supported by AT&T on my KEY2.

    Evidently there should be IMS showing, which it doesn't, and when you click it the option to toggle VoLTE on will show. But since that comes from the carrier, as I'm being informed, then I don't have VoLTE active.

    Bob
    Try going to Settings>Network Settings>Access Point Names and make sure ATT Nxtgenphone is selected.
    12-09-19 11:25 PM
  23. Bob80220's Avatar
    Try going to Settings>Network Settings>Access Point Names and make sure ATT Nxtgenphone is selected.
    It is... are you showing IMS settings?

    Bob
    12-09-19 11:29 PM
  24. Jay Rosenthal's Avatar
    It is... are you showing IMS settings?

    Bob
    Going back to *#*#46368676#*#*, I double checked to make sure LTE was set as voice network type, which it is. Is yours showing different?
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-72116.jpg  
    12-09-19 11:54 PM
  25. Bob80220's Avatar
    It does... but my data shows disconnected and yours shows connected. Why is that I wonder?

    Bob
    Attached Thumbnails KEY2 on AT&T minor error in Phone "additional settings"-62224.jpg  
    Last edited by Bob80220; 12-10-19 at 12:29 AM.
    12-10-19 12:09 AM
31 12

Similar Threads

  1. KEY2 LE Champagne Touch Up Paint
    By robnhl in forum BlackBerry KEY2 LE
    Replies: 2
    Last Post: 12-14-19, 12:36 AM
  2. Apps for phone user interface?
    By Zoeawar in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 12-11-19, 09:16 PM
  3. Twitter isn't work on The Classic anymore?
    By ANTIBERRY in forum BlackBerry Classic
    Replies: 8
    Last Post: 12-10-19, 12:26 PM
  4. Cant send messages (sim 1 - error 111)
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-09-19, 03:46 PM
  5. Replies: 1
    Last Post: 12-09-19, 12:19 PM
LINK TO POST COPIED TO CLIPBOARD