1. faizankhan85's Avatar
    So my key2 finally arrived, everything seems to be working well so far, apart from the Bluetooth connection with the car.

    Everything pairs correctly but after a few minutes the car displays "no service" , and then the audio/physical commands from the car to the phone stop working. However, the music still plays, I still receiving calls but I have to make calls using the telephone. Slightly annoying and beats the whole purpose of it being hands-free. Had no issues with the keyone.

    Anyone else experienced this, if so any suggestions on how I can fix this, bearing in mind I did the whole unpair and pair again.

    Thanks!
    07-03-19 05:12 PM
  2. RonZed10's Avatar
    Hard reset maybe? Did you try that?
    07-04-19 01:21 PM
  3. faizankhan85's Avatar
    Thanks, indeed I did!

    I have also searched on net and cannot find anything to help.

    I can receive calls, and I can make calls through BT if I dial number manually. However, I cannot access contacts or dial number from the car as it says no telephone is connected, and displays no service on the screen.
    07-04-19 01:54 PM
  4. herbersh's Avatar
    Try deleting the connection and re-pairing.
    07-04-19 01:57 PM
  5. faizankhan85's Avatar
    Thanks, that's the first thing I tried... several times to ensure I paired and unpaired from the phone and car but still no luck
    07-04-19 02:17 PM
  6. Platinum_2's Avatar
    try connecting to another car with BT. I suspect your car may be the culprit.
    07-04-19 03:12 PM
  7. gloommerchant's Avatar
    Thanks, that's the first thing I tried... several times to ensure I paired and unpaired from the phone and car but still no luck
    Try going into Bluetooth settings and "forget" the device. Then when you re-pair to your car and you get to the first dialog screen that pops up on your phone asking if you want to sync calls, messages, etc there is a box that is checked in the bottom left corner for "yes" or "ok", I forget exactly what the box says... but un-check that box, then re-check, and THEN hit ok.
    07-04-19 04:00 PM
  8. faizankhan85's Avatar
    Thanks, not a bad shout. However, if that is the case, how come I have new issues with the keyone or iPhone?

    Will try it in another car to be sure.
    07-04-19 04:02 PM
  9. faizankhan85's Avatar
    Try going into Bluetooth settings and "forget" the device. Then when you re-pair to your car and you get to the first dialog screen that pops up on your phone asking if you want to sync calls, messages, etc there is a box that is checked in the bottom left corner for "yes" or "ok", I forget exactly what the box says... but un-check that box, then re-check, and THEN hit ok.
    Thank you. Will try this and see how it goes!
    07-04-19 04:02 PM
  10. faizankhan85's Avatar
    Try going into Bluetooth settings and "forget" the device. Then when you re-pair to your car and you get to the first dialog screen that pops up on your phone asking if you want to sync calls, messages, etc there is a box that is checked in the bottom left corner for "yes" or "ok", I forget exactly what the box says... but un-check that box, then re-check, and THEN hit ok.
    So tried this today and unfortunately still the same issue!
    07-05-19 01:51 PM
  11. the_boon's Avatar
    So tried this today and unfortunately still the same issue!
    Have you had the chance to try connecting it to another car to see if it comes from the phone or the car?
    07-05-19 01:52 PM
  12. gloommerchant's Avatar
    So tried this today and unfortunately still the same issue!
    Are you using a smart watch by chance?
    07-05-19 02:08 PM
  13. faizankhan85's Avatar
    Have you had the chance to try connecting it to another car to see if it comes from the phone or the car?
    Hi, yes just tested it in another car and no issues.
    07-05-19 02:11 PM
  14. faizankhan85's Avatar
    Are you using a smart watch by chance?
    Hi, no I do not wear a smart watch
    07-05-19 02:12 PM
  15. the_boon's Avatar
    Hi, yes just tested it in another car and no issues.
    So its something with the car and not the phone I guess, but not sure how you could fix it
    07-05-19 03:52 PM
  16. faizankhan85's Avatar
    So its something with the car and not the phone I guess, but not sure how you could fix it
    But the keyone still syncs with no issues at all so I'm slightly baffled!
    07-05-19 04:06 PM
  17. Bill46J's Avatar
    Having exact same problem. One wrinkle that should help someone really smart diagnose our issue: When I shut off my phone and as it boots up, I notice the Bluetooth connect fires up nicely and begins to work exactly as it should. "No Serve" does not display and both verbal and direct contact list buttons work as they should. However, immediately upon logging into the phone (either pattern or pin #), the connection is lost. There must be some issue with settings blocking the contact list because all the other Bluetooth features work as you described. I've taken car in and had updates on Bluetooth installed there. AT&T had me do an erase/restore and that didn't help either.
    08-20-19 07:22 PM
  18. Bill46J's Avatar
    I have the same issue. Took car in & installed one Bluetooth update. Visited carrier, did complete erase/restore on phone. No improvement. Finally discovered this scenario which should enlighten someone. When I reboot the phone all features of Bluetooth work perfectly. However, as soon as log in (either pin or pattern), the connection is lost once again. Must be a clue to someone.
    08-20-19 07:31 PM
  19. SuperPapum's Avatar
    Not sure its the solution : In my car, I must disable "Message sync" in the peripheral properties to avoid BT disconnections; only music and phone. I've then lost messages displayed (sms, email) on my car LCD but BT remains connected.
    08-21-19 08:00 AM

Similar Threads

  1. KEY2: Premium price for a buggy device?
    By joergbrandt in forum BlackBerry KEY2
    Replies: 83
    Last Post: Today, 08:39 AM
  2. Replies: 3
    Last Post: Yesterday, 04:34 PM
  3. Modular Upgrades KEY2
    By EricArden in forum BlackBerry KEY2
    Replies: 11
    Last Post: Yesterday, 12:20 PM
  4. Just bought the BlackBerry KEY2 from Rogers
    By Blackberry Leap in forum BlackBerry KEY2
    Replies: 22
    Last Post: Yesterday, 11:47 AM
  5. Buying Key2 @ A1 Bulgaria
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-22-19, 04:12 AM
LINK TO POST COPIED TO CLIPBOARD