1. luvsql's Avatar
    I've checked every setting and cannot find where to disable this (wifi > wifi preferences > open notify is off), nothing in tethering). I was at a stoplight and noticed my phone connected to a bank's wifi at the corner and started getting messages about my email not connecting because of some certificate etc etc.

    I will never connect to a wifi that I do not physically sign up for so how do I turn this off? I had a KeyOne and through setting up the Key2 settings were transferred but not this one.
    hamilgs likes this.
    12-19-18 11:22 AM
  2. Bla1ze's Avatar
    Disable your WiFi when out. If it's on, it's going to try to connect to anything that's open. The other alternative would be to dig through the Google Play Store and try to find an app that would offer better WiFi management. There's plenty, but I've never used them to say which is a good one since I don't use my WiFi when out.
    12-19-18 11:53 AM
  3. Chuck Finley69's Avatar
    I've checked every setting and cannot find where to disable this (wifi > wifi preferences > open notify is off), nothing in tethering). I was at a stoplight and noticed my phone connected to a bank's wifi at the corner and started getting messages about my email not connecting because of some certificate etc etc.

    I will never connect to a wifi that I do not physically sign up for so how do I turn this off? I had a KeyOne and through setting up the Key2 settings were transferred but not this one.
    Settings > Network & Internet > WiFi > Off
    12-19-18 11:59 AM
  4. luvsql's Avatar
    Why do I have to turn off my wifi for it NOT to auto connect to unknown wifis and open wifis that are very unsecure? So I leave the house, turn off wifi, get to work, turn on wifi, leave work, turn off wifi, get home, don't forget, turn on wifi. Oops I forgot a few days and now have a huge data bill. ?

    That cannot be the solution....
    12-19-18 12:02 PM
  5. Bla1ze's Avatar
    Why do I have to turn off my wifi for it NOT to auto connect to unknown wifis and open wifis that are very unsecure?
    The point of WiFi and open networks is to not be secure. If that was the case, they'd all be secure. Your unwillingness to connect to unknown open networks, while understandable and shared by many, is not how it was designed or intended to work.

    The solutions we gave are the available solutions unless as advised, you want to look at alternative apps that will help. Some devices have further control built in, some do not. The KEY2 does not offer any additional options outside for selectively choosing which open networks to ignore. You can choose to forget which WiFi it has previously connected to under your saved networks, which might help a bit.
    12-19-18 12:35 PM
  6. luvsql's Avatar
    What is confusing is that I never had the issue on the Keyone. This is why I thought it could be a carrier thing (switched from Telus to Bell) or an update that did it or disabled the option.
    12-19-18 12:39 PM
  7. Bla1ze's Avatar
    What is confusing is that I never had the issue on the Keyone. This is why I thought it could be a carrier thing (switched from Telus to Bell) or an update that did it or disabled the option.
    I beleive the KEYone under Android 7.1.1 offered additional options to ignore those networks but Android Oreo 8.1 on KEY2 does not. I could be wrong, though, been a while since I looked at the settings on 7.1.1 KEYone.
    12-19-18 12:46 PM
  8. TheBond's Avatar
    Are you sure you don't have a Bank app that automatically sets up connection to their hotspots?
    The phone should never connect to hotspots or open networks that you didn't connect to in the past automatically.
    12-19-18 03:18 PM
  9. fanisk's Avatar
    I don't have this issue, however I would anyway recommend to use a VPN always to connect when using wifi networks which you don't control.
    12-19-18 04:13 PM
  10. Kevin Mullin's Avatar
    go to settings, network and Internet, Wi-Fi, Wi-Fi preferences then toggle open network notification so that it doesn't notify you whenever a public network is available to solve it. Mine were connecting around town too and it's a quick fix. I hope that helps
    12-19-18 10:10 PM

Similar Threads

  1. Solution to USB conection problems between BB10 on windows 10
    By Mostdistortion in forum BlackBerry 10 OS
    Replies: 8
    Last Post: 12-23-18, 08:02 AM
  2. What is the best scanner for the Key2?
    By victoriavictor in forum Ask a Question
    Replies: 2
    Last Post: 12-20-18, 11:47 AM
  3. Transfer Settings From KEY2 To KEY2 LE?
    By jeremyr4 in forum BlackBerry KEY2 LE
    Replies: 2
    Last Post: 12-19-18, 09:21 PM
  4. KEY2 afterboot process
    By RakacKey2 in forum Ask Bla1ze
    Replies: 2
    Last Post: 12-19-18, 05:50 PM
  5. Buying a Blackberry key2
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-19-18, 10:54 AM
LINK TO POST COPIED TO CLIPBOARD