1. mrisad's Avatar
    Hi guys,

    I'm having trouble listening to music via key2 bluetooth and my honda civic 2017 touring. The connection seems to work (the car dashboard shows both calls and audio connected). I can receive calls just fine but there's no audio playback.

    I've tried the following:
    - restarted both ends.
    - unpaired and re-paired after restart.
    - I connect my K2 to my bluetooth headphones and audio comes out just fine.

    This is so strange, it wasn't an issue with my K1 with same car/connection.

    Any ideas?
    Samtantawi likes this.
    07-12-18 03:44 PM
  2. Samtantawi's Avatar
    I have same issue with my new Key2 and Honda Civic 2016
    KeyOne was working fine

    I can use for calls but media no sound come out.!!!

    Help please
    07-14-18 10:45 AM
  3. fjfisher601#AC's Avatar
    I think it has to do with screen lock or sleep mode. If Phone is on and unlocked, it stays connected. As soon as my Key2 goes to sleep, the connection to my car is lost
    07-17-18 08:56 PM
  4. fjfisher601#AC's Avatar
    Well the trusted item isn't working! The theory is that it a Bluetooth device, as a "Trusted Item", would stay connected when the screen lock engages and sleep goes into effect. Frankly, prior phones automatically connected to a paired device whether locked or unlocked. Now it appears the key2 needs be paired and Trusted. Battery Optimization has no effect one or the other, i.e., if Bluetooth is always on, my Phone won't connect to my car useless unlocked. Then, 2 min later, it disconnects as screen saver triggers sleep mode.... unacceptable!!

    ******************************UPDATE**************

    Found the switch to TURN off all Trusted items.... now, with Battery optimization off, the phone connected to my car immediately after the car started- YEAH- but premature.... Bluetooth turns off when the screen goes dark/locks- so its still not staying connected.

    I'm going to erase and reset the phone to see if that fixes the Bluetooth problem not staying connected during "sleep" like all other phones do (including the Keyone)- if that doesn't fix it- I'll replace it as defective- or can Blackberry all together- sad- I love the battery life and keyboard of the Key 2! !
    Last edited by fjfisher601#AC; 07-19-18 at 11:58 AM.
    07-18-18 10:59 PM
  5. NSchuyler's Avatar
    I found that the first car I paired it with automatically disabled the "media" part of the bluetooth connection and treated it only as a headset. I couldn't change it from the phone end, but had to specifically pair it *again* (not unpair re-pair) as a media device.

    Fingers crossed your car may have done the same? The audio pairing was in a different menu in my friend's infiniti. Just FYI.

    Good luck!
    07-19-18 01:27 AM
  6. blueyestm's Avatar
    2015 Scion here, connected it the K2 and didn't have any issues with streaming. All functionalities worked just like the K1.
    07-19-18 05:10 PM
  7. fjfisher601#AC's Avatar
    UPDATE 2 .....

    Trust Agents/ Smart Lock... doesn't work with Bluetooth i.e, once screen lock engages , as a Trusted agent/Device, Bluetooth is supposed to stay on and connected- but it doesn't !

    The FIX: I actually had to do a Factory Reset to clear it- then immediately turned it all off- THEN I used a Keyone backup on Google to reload...now my bluetooth works and stays connected to all devices. When I first got the Key2. I used NFC to transfer form my Key 1 to the new Key 2- I don;t know if that made any difference, but in doing a Factory Reset- that option wasn't available- none the less, Bluetooth is now working properly and I won't be testing to see if Battery Optimization and Trusted Device now works.. After all - it ain't broken now and battery life is awesome...
    07-20-18 04:54 PM
  8. blueyestm's Avatar
    Maybe that's why I didn't have any issues. I never transfer stuff to a new phone, always set it up as new.
    07-20-18 05:21 PM
  9. conbrio29's Avatar
    I'm having the same issues as the OP. Is there any other fix for this besides doing a factory wipe of the device? I really dislike setting up devices, takes forever.
    12-10-18 06:34 PM
  10. conbrio29's Avatar
    POSSIBLE FIX:

    Go under Settings, Security and Location, Trust Agents. Make sure the Google Smart Lock is set to OFF. I noticed that I was having the same issues as people described above, primarily that when my device would go to sleep, the Bluetooth connection would be lost. Now it works!
    Attached Thumbnails Having issues with bluetooth connection to Honda Civic 2017-screenshot_20181210-163844.jpg  
    12-10-18 06:41 PM
  11. conbrio29's Avatar
    And I'm guessing the reason why it worked on my KEYone was that it didn't have that Smart Lock option, I'm guessing.
    12-10-18 06:42 PM
  12. conbrio29's Avatar
    Alright well I spoke too soon because the "fix" that I wrote above isn't fixing the issue. Then I found another setting that was under Google settings about remembering devices, and I thought maybe that toggle would have also done the trick but: nope.
    12-14-18 05:54 PM

Similar Threads

  1. Meeting mode issues on KEY2
    By yybenedb in forum BlackBerry KEY2
    Replies: 2
    Last Post: 01-20-19, 12:38 PM
  2. I'm so bored with smartphone's these days -- My Dilemma
    By cckgz4 in forum General BlackBerry Discussion
    Replies: 33
    Last Post: 09-26-18, 09:42 PM
  3. shortcut to productivity tab??
    By mmmac in forum BlackBerry KEY2
    Replies: 10
    Last Post: 09-07-18, 06:45 PM
  4. Keep your internet browsing encrypted with VPNSecure, now for just $20!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 2
    Last Post: 07-17-18, 06:31 AM
  5. Replies: 1
    Last Post: 07-12-18, 01:04 PM
LINK TO POST COPIED TO CLIPBOARD