1. Erik_1991's Avatar
    Hi CrackBerry Nation,

    Got some issues with the Key2 regarding dual language input. Before, on my PRIV, I could type in Dutch and in English and the phone would recognise both and correct accordingly. Now however, on the Key2, I somehow am not able to do this again. Its either Dutch or English.. Yes I've made the $key my language change key thingy and yeah it works.. Kinda.. Not as smooth as before.

    So my question, how to setup dual language so the Key2 will understand both and set it up so I don't have to switch between languages all the time?

    (When typing in Dutch I use quite a bit of English words either for work related things or just because it's easier) that's why changing all the time is annoying.

    Hopefully someone can shine some light on the matter!

    Thnx in advance!
    08-11-18 03:31 PM
  2. Laramie50's Avatar
    Hi CrackBerry Nation,

    Got some issues with the Key2 regarding dual language input. Before, on my PRIV, I could type in Dutch and in English and the phone would recognise both and correct accordingly. Now however, on the Key2, I somehow am not able to do this again. Its either Dutch or English.. Yes I've made the $key my language change key thingy and yeah it works.. Kinda.. Not as smooth as before.

    So my question, how to setup dual language so the Key2 will understand both and set it up so I don't have to switch between languages all the time?

    (When typing in Dutch I use quite a bit of English words either for work related things or just because it's easier) that's why changing all the time is annoying.

    Hopefully someone can shine some light on the matter!

    Thnx in advance!
    The only way I can be helpful to you is by telling you that's it's possible. I use French and English all the time and there is no need to switch languages on your keyboard. But setting it up was hell and I can't even recall how I did it. I fiddled with the settings under 'languages and input' and ended up doing it right. If nobody's been able to help by tomorrow, I'll see if I can retrace my steps in languages and input.
    08-11-18 05:15 PM
  3. chetmanley's Avatar
    @Erik_1991

    Go to Blackberry Keyboard Settings under Language and Input.

    There you will see Multi-Language Keyboards

    Click +ADD in the top right corner

    Select your primary and secondary language, click SAVE

    It will bring you back to Input Languages (if it doesn't, back up to the main Blackberry Keyboard menu and open the Input Languages menu at the top).

    In there, it defaults to Use System Languages being selected. Deselect this.

    Below you will find your two selected languages in the list, ie English/Dutch. Select this ON.

    Now your keyboard will be in the combined English/Dutch mode with no need to switch between them.
    NoxiousInc, Erik_1991 and Vistaus like this.
    08-11-18 05:22 PM
  4. NoxiousInc's Avatar
    Works flawlessly! (no more switching here ūüėÖ)
    08-12-18 03:23 AM
  5. Erik_1991's Avatar
    Thanks! Works great now
    08-12-18 10:59 AM
  6. Davis Rayler's Avatar
    I don't know how I did it but I did it! it works great now I can type en espa√Īol y en ingl√©s y el tel√©fono autom√°ticamente detecta the language I'm typing in
    Vistaus likes this.
    08-12-18 01:15 PM
  7. easytoread's Avatar
    Hello Sir
    How about language that not include in list?

    Could you please advise about second language?
    How possible to use second language on physical keyboard itself?
    I mean I need to change to Thai language and need to use physical keyboard to type Thai, same as I used BlackBerry Passport.
    Please advise
    Thank you
    02-06-19 02:43 AM
  8. elfabio80's Avatar
    @Erik_1991

    Go to Blackberry Keyboard Settings under Language and Input.

    There you will see Multi-Language Keyboards

    Click +ADD in the top right corner

    Select your primary and secondary language, click SAVE

    It will bring you back to Input Languages (if it doesn't, back up to the main Blackberry Keyboard menu and open the Input Languages menu at the top).

    In there, it defaults to Use System Languages being selected. Deselect this.

    Below you will find your two selected languages in the list, ie English/Dutch. Select this ON.

    Now your keyboard will be in the combined English/Dutch mode with no need to switch between them.
    Does somebody know how can I use three languages at the same time? Is it possible like in BB10?
    03-02-19 04:29 PM
  9. Chris_R's Avatar
    I was able to do this on my wife's Key 1. Am afraid i just can't find how to do this on my Key2.
    03-03-19 10:42 AM
  10. drobbie's Avatar
    I was able to do this on my wife's Key 1. Am afraid i just can't find how to do this on my Key2.
    Settings | System | Languages and input | Add a language
    03-03-19 10:48 AM
  11. Thinkbusiness's Avatar
    I knew the multi language input from BlackBerry OS 10 on my Passport. didn't know about this setting in Android. thanks!

    are there any drawbacks for using this multiple languages setting over the standard 2 language split setting (where you have to switch)
    elfabio80 likes this.
    03-03-19 01:01 PM

Similar Threads

  1. Keytwo dual sim
    By leoip in forum Ask Bla1ze
    Replies: 2
    Last Post: 08-11-18, 10:10 AM
  2. Replies: 1
    Last Post: 08-09-18, 11:39 AM
  3. Dual language support - how can the keyboard suck so much?
    By ChrisLeNeve in forum BlackBerry KEYone
    Replies: 10
    Last Post: 08-09-18, 04:22 AM
  4. Key2's Dual lens - how does it work?
    By ch900027 in forum BlackBerry KEY2
    Replies: 2
    Last Post: 08-08-18, 01:53 AM
  5. KEY2 or KEYone Black Edition? (while wait for KEY2 dual sim)
    By beckzyboi in forum BlackBerry KEY2
    Replies: 5
    Last Post: 08-07-18, 11:22 AM
LINK TO POST COPIED TO CLIPBOARD