Sign up now for Disney+
  1. bugzie's Avatar
    Anyone experienced the key2 not reading their SIM card, where the signal for the cellular network is switching back & forth between being on and off? One moment it shows the phone network on and the it turns off and says no SIM card detected and no network signal is shown smh
    I got sent a new replacement SIM card and inserted in in the phone. Phone read the SIM card for a while, then my phone read the SIM card for a few hours, when my phone died, I turned it back on, only for it to do the same thing and not read the SIM card again. My struggles for the past week smh might have to finally say bye bye to my key2 which I really liked uurgghh I see my solution as just buying a new phone smh
    breakerfall likes this.
    10-02-19 02:24 AM
  2. Chuck Finley69's Avatar
    Anyone experienced the key2 not reading their SIM card, where the signal for the cellular network is switching back & forth between being on and off? One moment it shows the phone network on and the it turns off and says no SIM card detected and no network signal is shown smh
    I got sent a new replacement SIM card and inserted in in the phone. Phone read the SIM card for a while, then my phone read the SIM card for a few hours, when my phone died, I turned it back on, only for it to do the same thing and not read the SIM card again. My struggles for the past week smh might have to finally say bye bye to my key2 which I really liked uurgghh I see my solution as just buying a new phone smh
    Warranty issue?

    Posted via CB10
    10-02-19 07:31 AM
  3. bugzie's Avatar
    Warranty issue?

    Posted via CB10
    Warranty? How would that relate to a warranty issue?
    10-02-19 08:51 AM
  4. Chuck Finley69's Avatar
    Warranty? How would that relate to a warranty issue?
    Sounds like a problem with SIM hardware if you’ve replaced SIM and I was asking if BBMo should cover under warranty.
    10-02-19 09:31 AM
  5. bugzie's Avatar
    Oh I see. Probably not, as I've had the phone a little over a year to date
    10-02-19 10:12 AM
  6. bugzie's Avatar
    Sounds like a problem with SIM hardware if you’ve replaced SIM and I was asking if BBMo should cover under warranty.
    Probably not since I've had the phone a little over year to date.
    10-02-19 10:25 AM
  7. Chuck Finley69's Avatar
    Probably not since I've had the phone a little over year to date.
    I would still contact BBMo support. Perhaps they can determine problem or not as well.

    Posted via CB10
    10-02-19 01:57 PM
  8. ShortyPiercer's Avatar
    I would still contact BBMo support. Perhaps they can determine problem or not as well.

    Posted via CB10
    Mine just started doing this tonight. Its just stuck in a loop. It connects to T-Mobile. Then says "no sim inserted and takes me to the lock screen. I unlock it and it works for 2 seconds then says "no sim insterted" and takes me back to the lock screen. I did a factory reset and tried multiple sim cards and nothing works. I contacted Blackberry but because I bought it on Amazon.com from a 3rd party seller they are telling me that it was a "non authorized seller" and the phone is "not authorized for sale in my region" so they will not warranty it. No other support offered. I pretty much have a $700 paper weight now. I have contacted the seller and am waiting to hear back from them. Just wish there was a way to fix this. I really feel like it's software related. I just updated the phone less than a week ago. If anyone has any suggestions at all I'd be willing to try anything at this point.
    10-02-19 09:31 PM
  9. breakerfall's Avatar
    I'm having a similar issue... I posted over on reddit and someone said he was able to reset via autoloader and it's fine now.

    https://www.reddit.com/r/blackberry/...bouncing_when/

    I'm at least able to get into Cellular Network settings and if I change to a non LTE 4G setting, it will lock up and then I can change to the normal 4G LTE setting and it's fine.

    But really, WTF?
    10-03-19 09:41 AM
  10. Chuck Finley69's Avatar
    How did everyone update their devices? What are the PRDs on said devices? Are these variants bought for a cheaper price that aren’t intended for their current regions? Most importantly, can devices still be returned for refund?
    10-03-19 09:50 AM
  11. breakerfall's Avatar
    My Key2 is BBF100-2
    Security patch: Sept 5, 2019
    Baseband: S.AT.3.1-00814-SDM660_GEN_PACK-1
    Hardware version: 09
    Kernel version: Fri Aug 30 16:24L26 EDT 2019
    Build number: ACD175

    I purchased from Swappa more than a year ago and I have the Amazon invoice from the original purchase. I believe it's the correct model for my region (US).

    Latest update came OTA, same as all the previous. The SIM card was not in at the time as it's not my primary phone.

    What's a PRD?

    edit: my switch to LTE thing is not working this morning. Non LTE 4G works.
    Last edited by breakerfall; 10-03-19 at 10:37 AM. Reason: more info
    10-03-19 10:03 AM
  12. yybenedb's Avatar
    There have been a few reports of that with the September patch.
    10-03-19 12:33 PM
  13. ShortyPiercer's Avatar
    Here's the weird part. I've tried 3 other Tmobile sim cards in my Key 2. All of them have the same error. They work fine in my Keyone and other samsung phones. I took a co-worker's ATT sim card and tried it in this Key2 and it worked fine! I called Tmobile and they have no suggestions or information since it's a "non tmobile device".

    BBF100-6
    PRD-63828-003
    10-03-19 01:07 PM
  14. breakerfall's Avatar
    You mean, like, other reports? These are reports right here

    Is there some official reporting contact that we can all get after?

    Ah, I see some others now here on the cb...
    Last edited by breakerfall; 10-03-19 at 01:37 PM.
    10-03-19 01:12 PM
  15. ShortyPiercer's Avatar
    I just tried putting it on 2g only and it's working better. Still giving a few errors but not as often. As soon as I switch to any other mode it resumes it's endless loop of "no sim card"
    10-03-19 01:33 PM
  16. Jamaa's Avatar
    I just tried putting it on 2g only and it's working better. Still giving a few errors but not as often. As soon as I switch to any other mode it resumes it's endless loop of "no sim card"
    Found a workaround to this problem. Seems it's related to the newest OS update ACD175

    /ask-question-f432/mobile-signal-goes-off-turns-back-every-2-seconds-1177656/

    Good luck!
    10-18-19 03:38 PM
  17. Jamaa's Avatar
    Happened again, tried the steps above, still nothing..

    Then..

    Turned off 2G

    Works now.

    Dunno if this works or if it's just another fluke



    BlackBerry key2 not reading simcard-screenshot_20191020-190224.jpeg
    10-20-19 10:04 PM
  18. ElbertR's Avatar
    Listed my experience in that thread. My Tmobile signal just kept on dropping/reconnecting. Never got a message about the sim card. Not sure what the cause is. Before this have been running the Sep update for weeks without problems. What made it work again was switching to a non-LTE signal. Then a few hours later it tried it with LTE again and everything was back to normal (and still is).

    Found a workaround to this problem. Seems it's related to the newest OS update ACD175

    /ask-question-f432/mobile-signal-goes-off-turns-back-every-2-seconds-1177656/

    Good luck!
    10-22-19 12:08 PM

Similar Threads

  1. Replies: 8
    Last Post: 10-18-19, 11:44 PM
  2. Where can I buy a KEYone or KEY2 in the UK?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-02-19, 04:22 PM
  3. Blackberry Hub Inbox Request? - Microsoft Planner Support
    By owenpye in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 10-02-19, 04:57 AM
  4. Blackberry Classic
    By Xiangjun Meng in forum Ask a Question
    Replies: 5
    Last Post: 10-02-19, 12:44 AM
  5. BlackBerry solutions now available on Microsoft Azure and AWS Marketplace
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 1
    Last Post: 10-01-19, 09:41 PM
LINK TO POST COPIED TO CLIPBOARD