1. Vince208gti's Avatar
    Hello guys,
    did anyone have that issue ? since yesterday afternoon, it seems i had an update for the hub + services module, and since my battery litteraly empty itself in an hour...

    does anyone have any solution for deactivating / resetting that module ? it says it's an administrator app and i can't deactivate it ...

    i already tried soft reset by long pressing the off button, but nothing changes ...

    it's really annoying, i had my phone for one month now, ( it's a key2 red edition ) and everything was fine ...
    04-24-19 04:50 AM
  2. Zebra 99's Avatar
    I don't think that issue caused by hub+, it's could be something else. Do you have monitoring app for battery?
    04-24-19 04:54 AM
  3. KunBajaj's Avatar
    Hi, it seems this thread is not being actively looked at, but will take a shot.

    I am having SERIOUS battery issues with Blackberry HUB+ Services eating battery like the cookie monster. I have it on my Key2, and have also tried it on a Oneplus. In both cases, it is eating more than 20% by end of day, the nearest next app is well in the low single digits. My OnePlus battery like was cut to 1/3rd because of the app.

    This has started happening over the past few months, before that it was fine on my Motion and Key2.

    I love BB HUB+ and want to use it on other Android devices, too. But battery usage is a MAJOR problem. Any tips?
    06-18-19 04:36 AM
  4. gadgetgirl37's Avatar
    for the first time I have the same problem. Woke up in the middle of the night and my phone was completely dead. This has never happened and I was upset because I'm on call this weekend coming and have to answer all calls.
    06-18-19 05:37 AM
  5. Trevstarr's Avatar
    Actually I just did an update for the hub yesterday and I am having same Issue, my phone also gets hot, battery lasts less than 7 hours with minimal usage....
    06-27-19 06:22 PM
  6. ZahidShad's Avatar
    Hello guys,
    did anyone have that issue ? since yesterday afternoon, it seems i had an update for the hub + services module, and since my battery litteraly empty itself in an hour...

    does anyone have any solution for deactivating / resetting that module ? it says it's an administrator app and i can't deactivate it ...

    i already tried soft reset by long pressing the off button, but nothing changes ...

    it's really annoying, i had my phone for one month now, ( it's a key2 red edition ) and everything was fine ...
    I have been having this issue for quite some time.
    07-09-19 03:57 PM

Similar Threads

  1. Where to buy BlackBerry Passport Silver Edition?
    By Chris360blocc in forum Ask a Question
    Replies: 6
    Last Post: 04-24-19, 10:31 PM
  2. Business Profile not integrated in Hub.
    By joergbrandt in forum BlackBerry KEY2
    Replies: 2
    Last Post: 04-24-19, 05:21 PM
  3. Blackberry Playbook log onto Wifi hotspot McDonalds A&W screen.
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 04-24-19, 02:19 PM
  4. Replies: 3
    Last Post: 04-23-19, 05:14 PM
  5. BlackBerry Hub+ Inbox and Hub+ Services beta releases updated
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 04-23-19, 11:51 AM
LINK TO POST COPIED TO CLIPBOARD