Built for Business - Learn more about BlackBerry KEY2
10-16-19 02:10 PM
31 12
tools
  1. rs87's Avatar
    My battery has gone nuts since this update yesterday! I went from 75% to 59% yesterday in half an hour and now I've gone from 100% to 80 % in two hours!

    What's happening here? It's got to be a bug and not an actual battery problem because I use it for all purposes all day every day and never need to charge it during the day.
    09-29-19 06:49 PM
  2. conite's Avatar
    My battery has gone nuts since this update yesterday! I went from 75% to 59% yesterday in half an hour and now I've gone from 100% to 80 % in two hours!

    What's happening here? It's got to be a bug and not an actual battery problem because I use it for all purposes all day every day and never need to charge it during the day.
    There is nothing inherently wrong with the OS, or we'd all be suffering from it.

    Try rebooting by holding down the power button for 32 seconds.

    If that fails, we can only assume something went wrong - not WITH the update, but DURING the update. You may have to do a factory reset.
    rs87, BigAl_BB9900 and swadarshan like this.
    09-29-19 06:56 PM
  3. rs87's Avatar
    There is nothing inherently wrong with the OS, or we'd all be suffering from it.

    Try rebooting by holding down the power button for 32 seconds.

    If that fails, we can only assume something went wrong - not WITH the update, but DURING the update. You may have to do a factory reset.
    Thanks for the quick reply! Just done that now and phone is on charge over night whilst I sleep (I live in UK). I'll report back tomorrow night.

    Hopefully just a glitch

    Thanks again Conite 👍
    09-29-19 07:01 PM
  4. ZeBB45's Avatar
    My battery is draining quick & my mobile network radios also disconnect from tim-to-time after installing this update.
    09-29-19 09:12 PM
  5. conite's Avatar
    My battery is draining quick & my mobile network radios also disconnect from tim-to-time after installing this update.
    Try the 32 second reboot. If that doesn't work, use the wipe autoloader.
    BigAl_BB9900 likes this.
    09-29-19 09:23 PM
  6. sowhoong's Avatar
    My battery has gone nuts since this update yesterday! I went from 75% to 59% yesterday in half an hour and now I've gone from 100% to 80 % in two hours!

    What's happening here? It's got to be a bug and not an actual battery problem because I use it for all purposes all day every day and never need to charge it during the day.
    I felt the same to me too.....
    09-30-19 06:46 AM
  7. danielstefan35's Avatar
    I have the same problem.
    09-30-19 08:20 AM
  8. mikeath's Avatar
    I've noticed this today. Never drained by battery in less than a day before, but heading that way now. Looking at about 4hrs SOT compared to around 6 before.
    Attached Thumbnails Battery Life Bug - ACD175 Update!!-51991.jpg  
    09-30-19 12:55 PM
  9. conite's Avatar
    Strange. I got my typical 16 hours, with 8 hours SoT yesterday.
    09-30-19 01:12 PM
  10. hemodad's Avatar
    I haven't had a problem. I have been on my phone almost constantly today since 0500hrs only down to 51% at 1450hrs.
    09-30-19 01:50 PM
  11. nevilleadaniels's Avatar
    Go into the Power Centre and manage automatic app settings switch off all the backgrounds for the ones you don't want running in the background obviously keep things like outlook and messenger apps running. According to your usage pattern.

    It seems that all mine were set to default as open instead of closed after the upgrade.

    I normally get 12 to 14 hours of home time intensive use. I noticed that is reduced to 9 to 11 hours. Believe would just be the background apps starting in the background.
    rs87 likes this.
    09-30-19 02:12 PM
  12. mikael11's Avatar
    No probs here either. Updated this morning (OTA) 16 hours passed and 59% left.
    09-30-19 02:40 PM
  13. Zebra 99's Avatar
    I have no such kind of issue after this update.
    Continue use phone will be 11 hours. And combine use around 48 hours
    09-30-19 05:28 PM
  14. i_plod_an_dr_void's Avatar
    ...check one (or all ) of your downloaded apps ....its probably ad-clicking off screen (sucking up the battery as you go) ...so you can't tell. Google Play seems to be constantly troubled by apps of this nature. Only Download apps from trusted sources and trusted developers. LOL. Who the Lol has any idea of who to trust? Google can't even manage the shenanigans going on on the apps in its own store. The malicious apps are generally discovered by other parties. Good luck with your privacy floating off into the ether.
    elfabio80 likes this.
    09-30-19 09:26 PM
  15. citystars41's Avatar
    My battery is draining quick & my mobile network radios also disconnect from tim-to-time after installing this update.
    I had the network issue too but mine was non-stop. just flipped back and forth rapidly. Who's your carrier?
    10-01-19 01:28 PM
  16. citystars41's Avatar
    dup
    skrble likes this.
    10-01-19 02:31 PM
  17. rs87's Avatar
    Reporting back 48 hours later as promised.... (don't quote me saying 24 hours 😁) and yes the problem seems to have gone since the 32 second/4x reboot cycle.

    It was a very sudden change of battery percentage when I had my fault and when I charged it it then dropped 11% instantly. But hey, working fine again now from what I can tell.
    10-01-19 03:02 PM
  18. AndreiRadu99's Avatar
    I have the same problem but for me started at ACA360. Because I saw no one complaining here I've just waited for the update but it seems that for me it continues. Also the charging is strange because it jumps from 90 to 100 in like 2 minutes.
    10-01-19 06:04 PM
  19. vikreddy51's Avatar
    have the same issue since update. mobile signal goes in and out constantly. battery drain in 5 hours.
    10-01-19 06:24 PM
  20. vikreddy51's Avatar
    have the same issue since update. mobile signal goes in and out constantly. battery drain in 5 hours.
    False alarm. I think I have a bad SIM card.
    10-01-19 06:43 PM
  21. BigAl_BB9900's Avatar
    There is nothing inherently wrong with the OS, or we'd all be suffering from it.

    Try rebooting by holding down the power button for 32 seconds.

    If that fails, we can only assume something went wrong - not WITH the update, but DURING the update. You may have to do a factory reset.
    Thanks - the 32 second reboot has worked for me
    swadarshan likes this.
    10-01-19 10:05 PM
  22. chetmanley's Avatar
    32 second reboot hasnt worked for me. My battery life has tanked to just 8 hours.
    10-05-19 12:45 PM
  23. chetmanley's Avatar
    Has anyone noticed an increase in activity from the TCL Preview app due to this OS?

    I had it disabled via ADB for months. This update reactivated it somehow.
    I then re-disabled it via ADB again.

    While it appears disabled, it looks like it is running in the background somehow. It's appearing on my device's battery usage, having used 3% in just 1 hour. It is also using memory but Netguard and the system show it as disabled, with no outgoing connections being made.
    10-06-19 10:56 AM
  24. conite's Avatar
    Has anyone noticed an increase in activity from the TCL Preview app due to this OS?

    I had it disabled via ADB for months. This update reactivated it somehow.
    I then re-disabled it via ADB again.

    While it appears disabled, it looks like it is running in the background somehow. It's appearing on my device's battery usage, having used 3% in just 1 hour. It is also using memory but Netguard and the system show it as disabled, with no outgoing connections being made.
    Doesn't appear on my battery list at all.
    10-06-19 11:23 AM
  25. chetmanley's Avatar
    Performed a factory reset. Battery usage is normal again and after ADB-disabling Preview, there is no sign of it's activity anymore.

    Following the factory reset I also noticed my DTEK score has improved, was Fair before, now it's Excellent dispite the exact same system setup.
    10-07-19 10:21 AM
31 12

Similar Threads

  1. Anyone thinking of updating their older iPhone to new iPhone this year?
    By Stephanie Medlock in forum Apple iPhone/iPad
    Replies: 10
    Last Post: 10-08-19, 03:36 AM
  2. Changing battery and charging port
    By Anaik17 in forum BlackBerry Priv
    Replies: 4
    Last Post: 10-05-19, 10:16 PM
  3. Replies: 3
    Last Post: 09-30-19, 08:07 PM
  4. Which screwdriver do I need to replace battery?
    By jackbuck93 in forum BlackBerry KEYone
    Replies: 4
    Last Post: 09-29-19, 11:01 PM
  5. Battery draining quicker?
    By GlamGemini in forum BlackBerry KEYone
    Replies: 3
    Last Post: 09-29-19, 07:32 PM
LINK TO POST COPIED TO CLIPBOARD