1. architectyuan's Avatar
    Anyone tried android auto with key2 yet? how's the performance? TY!
    07-02-18 11:38 AM
  2. RK_BB's Avatar
    Anyone tried android auto with key2 yet? how's the performance? TY!
    No different than the KEYᵒⁿᵉ with the exception of maybe not having to close all apps before connecting the device which is the case for at least the SE.
    07-02-18 12:09 PM
  3. destiny.seeker's Avatar
    No different than the KEYᵒⁿᵉ with the exception of maybe not having to close all apps before connecting the device which is the case for at least the SE.
    I really wish this is the the case since KEYᵒⁿᵉ BE really can not handle android auto at all with multiple messengers running or music streaming in the background. ...

    I heard and read from multiple people saying that key2 is 100x better than KEYᵒⁿᵉ in terms of multitasking, and that's the reason I pre-ordered key2 from bestbuy.
    07-02-18 12:17 PM
  4. RK_BB's Avatar
    I really wish this is the the case since KEYᵒⁿᵉ BE really can not handle android auto at all with multiple messengers running or music streaming in the background. ...

    I heard and read from multiple people saying that key2 is 100x better than KEYᵒⁿᵉ in terms of multitasking, and that's the reason I pre-ordered key2 from bestbuy.
    Same.
    07-02-18 12:18 PM
  5. Ondra Kolarik's Avatar
    And big issue. waze still not working on android auto.
    07-07-18 04:07 AM
  6. Ondra Kolarik's Avatar
    And waze still not working
    07-07-18 04:11 AM
  7. mriolo84's Avatar
    For me, the android auto experience with the keyone was painfully slow. I have the key2 now and its a completely different experience. Much happier.
    07-07-18 07:05 PM
  8. Vetboy's Avatar
    Tried mine for the first time today. Waze stalled on first attempt and I had to reboot phone. Seemed to work after that. It did get tripped up when my passenger unplugged it and plugged it back in. Had to restart Waze. Maybe still a little slow like the keyone, but worked.
    07-09-18 03:49 PM
  9. OfficalRockMusic's Avatar
    Tried mine for the first time today. Waze stalled on first attempt and I had to reboot phone. Seemed to work after that. It did get tripped up when my passenger unplugged it and plugged it back in. Had to restart Waze. Maybe still a little slow like the keyone, but worked.

    So I had simillar the same problem like all of you, but I can even come up with the fix.
    I have a 2018 Golf 7 with the big Navi and AA.
    After the last big update i got a black screen only showing home button ( not working) and notifcations.
    When i cleared my AA cache on my BB Key2 LE and deleted the App Data it worked for one single time.
    After unplugging - same problem.
    After a ****load of google help pages i found the trick to get this working.
    Nearly all apps ar battery optimized by BB.
    So i found the point to manage the optimization settings and changed all apps i want to use in the car to " not optimize ".
    In my Case it was :

    Android Auto
    Tidal
    Google Maps
    Google Assist
    Castbox
    Phone
    Messages
    Whatsapp
    Notification
    Calendar

    Then i wiped the cache for AA and Google Maps, configured the AA App unplugged and gave permissions.
    Since everything is working fine.
    I hope you can enjoy AA now.
    01-17-20 05:27 AM
  10. V-Tom's Avatar
    Android auto apps have worked pretty much flawlessly since I started using in on my 2019 Golf. I wish there was a way to reduce the next turn instructions on both Waze and Google Maps to one line though.

    ..Tom
    01-19-20 07:53 AM
  11. Matt J's Avatar
    Android Auto works perfectly on my KEY2 and 2019 Mercedes CLA250. Fast and stable. No lag or other issues.
    01-19-20 04:11 PM
  12. bh7171's Avatar
    Android Auto works perfectly on my KEY2 and 2019 Mercedes CLA250. Fast and stable. No lag or other issues.
    The car or the smartphone? 😎
    01-19-20 11:51 PM
  13. Matt J's Avatar
    The car or the smartphone?
    LOL. Both.
    01-19-20 11:53 PM
  14. antony99's Avatar
    I have been using Android Auto (mostly for Waze, Pocket Casts, Plex) for about 3 years - and it works really well.

    Sometimes Waze wont launch properly, or will just go wacky - but this is quite rare, less than once per week.
    Quickest option is to reboot the phone, but killing the Waze app and re-launching works fine too.

    You do need to have a really nice USB cable - and this is so important.

    Mine is connected to a Ford Sync3 system - and if the cable has any movement in the connector, then the Android Auto/Sync3 friendship is instantly broken, and if you have to wiggle it to work again. If you find yourself doing this, go and buy a high quality cable!

    There is absolutely no need to turn off battery optimisation for any of the apps - total waste of time and cause of confusion to think you have to adjust those settings.

    In my opinion the only app to watch out for that causes lots of issue for me is the "Google" app - force disable to make it revert to an old version and then stopping it from ever updating has made huge differences in the performance of my KEY2. You do need this app to be able to issue voice commands in Android Auto.
    01-21-20 11:59 PM

Similar Threads

  1. life with pets
    By pksy3927 in forum Discover BBM Friends
    Replies: 2
    Last Post: 07-10-18, 07:46 AM
  2. KEY2 and US carriers.
    By Dante Giugliano in forum BlackBerry KEY2
    Replies: 31
    Last Post: 07-06-18, 12:27 PM
  3. Facing an issue with whatsapp
    By sudheerai in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 07-03-18, 02:54 PM
  4. "Waiting for Backup" issue on KEY2
    By nilaymk in forum BlackBerry KEY2
    Replies: 2
    Last Post: 07-03-18, 12:05 PM
  5. Last few days with my keyone
    By SunnyD3687 in forum BlackBerry KEYone
    Replies: 5
    Last Post: 07-02-18, 05:03 PM
LINK TO POST COPIED TO CLIPBOARD