Built for Business - Learn more about BlackBerry KEY2
06-03-19 10:30 AM
203 ... 56789
tools
  1. TheBond's Avatar
    We've spent hours trying but have not been able to reproduce this.
    Really. It took me 5 minutes to reproduce the issue. I use only Gmail, so not sure if it's limited to it.

    This is how I was able to reproduce (and my use case too);
    1. Have 5+ unread emails (unreads are easily identified) in your Gmail
    2. Open Hub and in the main view highlight all of those emails that you want to delete
    3. Hit backspace button (to delete of course) and immediately press Home button (I do this quite often to clean my inbox)
    4. After a minute or so, go back to the Hub and press S, to launch Search (or just check through Productivity tab)
    5. You'll find the deleted emails there hanging around even though they disappeared from the Hub main view

    Note: if you don't press the Home button then staying in the Hub does delete the emails but in real world you don't wait or have time for it every time.

    It shouldn't take you hours to try above. It's pretty big issue in my books.
    I just tested it with syncing my deleted items folder and that seem to fix the issue though after I hit the Back key to delete selected messages and navigate away from Hub without waiting for the Undo Delay to complete, Hub then re-launches itself to the foreground.

    I kindly ask that you try and reproduce this using any of the deletion methods described in post # 100 and then immediately navigate away from Hub without waiting for the Undo Delay to complete. Please do so while your Deleted items folder is NOT synced.

    Then please try again with your deleted items folder synced and you should see that though messages gets deleted properly, Hub then pops on the screen without invitation.

    I will produce a video.
    I tried your solution and it does work however now my Productivity tab is full of items from Trash folder, since they're all Unread. Productivity tab is now unusable since I only see Unread items there.
    12-07-18 03:16 PM
  2. LiamQ's Avatar
    This is how I was able to reproduce (and my use case too);
    1. Have 5+ unread emails (unreads are easily identified) in your Gmail
    2. Open Hub and in the main view highlight all of those emails that you want to delete
    3. Hit backspace button (to delete of course) and immediately press Home button (I do this quite often to clean my inbox)
    4. After a minute or so, go back to the Hub and press S, to launch Search (or just check through Productivity tab)
    5. You'll find the deleted emails there hanging around even though they disappeared from the Hub main view

    Note: if you don't press the Home button then staying in the Hub does delete the emails but in real world you don't wait or have time for it every time.

    It shouldn't take you hours to try above. It's pretty big issue in my books.
    Thank you for the steps, but they do not reproduce the issue in my testing on a BlackBerry KEY2 or KEY2 LE with a Gmail account.
    12-07-18 03:38 PM
  3. RK_BB's Avatar
    Thank you for the steps, but they do not reproduce the issue in my testing on a BlackBerry KEY2 or KEY2 LE with a Gmail account.
    This issue is not specific to BlackBerry devices. I have had it on my Samsung S7 & @TheBond has it on his Samsung Note 8 device.

    I see no other way but to film a video and show it to you.
    12-07-18 04:18 PM
  4. max-bb's Avatar
    Again to set expectations, there is up to a 5 minute delay before deletes are synced to the server, that is totally normal and expected, and the messages are merely hidden until that happens. The video may help us to try, as we have spent quite some time trying your steps to no avail.
    12-08-18 10:28 AM
  5. RK_BB's Avatar
    Again to set expectations, there is up to a 5 minute delay before deletes are synced to the server, that is totally normal and expected, and the messages are merely hidden until that happens. The video may help us to try, as we have spent quite some time trying your steps to no avail.
    You know what, that might just be it?

    Questions:

    1. Can the delay be expedited by forcing a full refresh? If not then that might be it because I definitely tried refreshing by closing Hub entirely and then reopening only to find that messages are still on the server.

    2. How come deletions gets synced immediately when deleting from the Productivity Tab or from a Search view in Hub?
    12-08-18 02:22 PM
  6. max-bb's Avatar
    1. A refresh will likely cause any queued actions (deletions, mark read, etc.) to be performed. Note there is some throttling to prevent very quick refreshes which both wastes bandwidth and battery; and can potentially get the client blocked.

    2. Productivity Tab and Local Search View: I'm not sure. It should be about the same. The delete requests get saved to the database and a refresh will occur within a few minutes. Remote Search View: I don't remember if deletes are supported here, but these remote search views are handled quite differently.
    12-08-18 02:38 PM
  7. RK_BB's Avatar
    1. A refresh will likely cause any queued actions (deletions, mark read, etc.) to be performed. Note there is some throttling to prevent very quick refreshes which both wastes bandwidth and battery; and can potentially get the client blocked.

    2. Productivity Tab and Local Search View: I'm not sure. It should be about the same. The delete requests get saved to the database and a refresh will occur within a few minutes. Remote Search View: I don't remember if deletes are supported here, but these remote search views are handled quite differently.
    1. I am unable to get queued messages removed from the server with a forced refresh but perhaps I am blocked by throttling? Either way, I can have some messages sit in the que for days.

    2. On a Search view or Productivity Tab the deletion gets reflected on the server almost immediately without fail.
    12-08-18 02:45 PM
  8. RK_BB's Avatar
    @max-bb

    A message I deleted about two hours ago is still in the que.
    12-08-18 04:13 PM
  9. max-bb's Avatar
    Then unfortunately it is not the queuing that is the problem. If you've received any emails in the meantime, something else is broken.
    12-08-18 04:18 PM
  10. RK_BB's Avatar
    Then unfortunately it is not the queuing that is the problem. If you've received any emails in the meantime, something else is broken.
    I certainly received many more emails since.

    What can I do to assist you in discovering what you is actually broken?
    12-08-18 04:20 PM
  11. max-bb's Avatar
    I will have to talk with the team and get back to you on Monday.
    12-08-18 04:22 PM
  12. RK_BB's Avatar
    I will have to talk with the team and get back to you on Monday.
    Great! Thank you and have a good weekend in the meantime
    12-08-18 04:24 PM
  13. TheBond's Avatar
    Thanks guys. I'm keeping a close eye on this thread.
    the brother likes this.
    12-08-18 04:34 PM
  14. RK_BB's Avatar
    I will have to talk with the team and get back to you on Monday.
    Good Monday!

    Do you happen to have an update on this? Anything the team was able to identify?

    Happy to send you bug reports.
    the brother likes this.
    12-10-18 03:28 PM
  15. max-bb's Avatar
    We would love to see a video of how you use Hub when these issues happen for you. You can PM me or LQ a link to a video.
    the brother likes this.
    12-10-18 03:34 PM
  16. RK_BB's Avatar
    We would love to see a video of how you use Hub when these issues happen for you. You can PM me or LQ a link to a video.
    You got it. We'll try to produce one tonight for ya.
    the brother likes this.
    12-10-18 03:37 PM
  17. RK_BB's Avatar
    We would love to see a video of how you use Hub when these issues happen for you. You can PM me or LQ a link to a video.
    Just sent you a PM.
    the brother likes this.
    12-10-18 04:18 PM
  18. RK_BB's Avatar
    @max-bb following our PM exchange here is a video that document the following scenario:

    Delete -> Home -> Open another app (PlayStore for eg) and wait.

    https://photos.app.goo.gl/QMrD7WGSJY8EPts18

    It also happens by navigating away to another app using the Speed Key or turning the screen off by pressing the power button.

    As you mentioned it looks like the task is killed before the Undo is timed out which I would expect Hub to pick right back up as soon as the user relaunches it but instead the deleted messages stays in the intermediate position indefinitely.

    Please let us know what are your thoughts and possible resolution.
    TheBond likes this.
    12-10-18 06:22 PM
  19. max-bb's Avatar
    @RK_BB Now that we've been able to reproduce it, we're seeing if we can tackle it.
    RK_BB and TheBond like this.
    12-11-18 10:36 AM
  20. RK_BB's Avatar
    @RK_BB Now that we've been able to reproduce it, we're seeing if we can tackle it.
    That's awesome and all that I was asking for the entire time

    Thank you very much!
    12-11-18 10:37 AM
  21. RK_BB's Avatar
    Just received Hub+ Services update version # 2.1810.0.53475

    Is this the fix for the issue at hand? That quickly??
    12-11-18 04:19 PM
  22. TheBond's Avatar
    Just received Hub+ Services update version # 2.1810.0.53475

    Is this the fix for the issue at hand? That quickly??
    I really hope so. I don't have beta but will love to hear your feedback on this.
    If it has been resolved, then Bravo to the team behind it.
    12-11-18 04:36 PM
  23. max-bb's Avatar
    Sorry, no.
    the brother likes this.
    12-11-18 05:23 PM
  24. RK_BB's Avatar
    @max-bb just some thoughts as you work this through:

    1.This issue might amplify itself as we upgrade to Android P in which users are likely to delete multiple messages and then navigate away to a different app using any of the available gestures rather than hitting the Back key (which by the way is working every single time).
    2. IMO the issue is somewhat related to the Undo Delay feature. I recommend you test it with the feature disabled and see what happens; if you can navigate away from Hub using the Home key immediately after multiple email deletion and the task is performed properly then this is where the issue is at. I would release an interim Beta with no Undo Delay when multiple emails are deleted and disallow more than one email deletion at a time when swiping to delete until the issue is resolved.
    Last edited by RK_BB; 12-15-18 at 11:26 AM.
    12-15-18 11:11 AM
  25. baldy3577's Avatar
    I'll add that I too have this problem yet again for a few months now (after it appeared to be fixed last year). Is there a workaround at the moment that works for deleting multiple emails, across different email accounts/providers? I have 2 gmail accounts and 3 on different hosts for work. I check my emails and delete every morning, but whenever I log into the webmail for these accounts, the messages still appear. The frustrating bit is having to delete them all via webmail / desktop again (which takes a while since I have 5 accounts and within those accounts the emails go into separate folders as well).

    Any insight would be appreciated (I'm in the beta as well).
    01-03-19 03:47 PM
203 ... 56789

Similar Threads

  1. BBM not opened yet. Front Cam also
    By Janarthanan Jana in forum BlackBerry Z30
    Replies: 5
    Last Post: 08-01-17, 10:21 AM
  2. Smartlock Maps Not Opening
    By claytargets in forum BlackBerry DTEK60
    Replies: 2
    Last Post: 07-31-17, 05:29 PM
  3. Font in the HUB app
    By Konan Philippe-Alexandre in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-31-17, 12:17 PM
  4. How to delete previous Blackberry ID?
    By materes in forum BlackBerry Classic
    Replies: 2
    Last Post: 07-31-17, 08:22 AM
  5. Contacts not sync'ed
    By thidisbogus in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-30-17, 10:15 PM
LINK TO POST COPIED TO CLIPBOARD