06-03-19 10:30 AM
203 ... 23456 ...
tools
  1. RashKoms77's Avatar
    If you're not using a BB, we don't have system access to delete SMS or change their state.
    If you are using a BB, this is unfortunately a limitation in the SMS client. Most SMS clients no longer look at the system database to see changes, so may not reflect the changes we've made. We don't have a good workaround for this. Forcing your client to resync (eg, by deleting its data, or changing to a different SMS client and back, etc.) should cause the changes to show up.
    I am using #BBMotion only. Thanks. I am using default Message app for SMS. Can you please suggest how it can be forcefully resync to apply changes made in Hub to SMS client. ? What other SMS client I can use which syncs with Hub ?
    02-01-18 10:28 AM
  2. max-bb's Avatar
    I am using #BBMotion only. Thanks. I am using default Message app for SMS. Can you please suggest how it can be forcefully resync to apply changes made in Hub to SMS client. ? What other SMS client I can use which syncs with Hub ?
    A few months ago, Google seemingly changed their client to stop syncing FROM the system database. As I mentioned, you can probably get it to resync manually by going into the Apps Screen and deleting data, but this is heavy weight. It is probably best if you do your deletes within Messages.

    It is unusual in Android for the system database to change in this way, so we may never be able to get this to work properly.

    I have not tested other clients to see if any of them do two way sync. If you do try others, we would love to hear your results.
    02-01-18 10:35 AM
  3. RashKoms77's Avatar
    A few months ago, Google seemingly changed their client to stop syncing FROM the system database. As I mentioned, you can probably get it to resync manually by going into the Apps Screen and deleting data, but this is heavy weight. It is probably best if you do your deletes within Messages.

    It is unusual in Android for the system database to change in this way, so we may never be able to get this to work properly.

    I have not tested other clients to see if any of them do two way sync. If you do try others, we would love to hear your results.
    Thanks. Appreciate your reply with detailed info. Wish BBAndroid HUB works as smooth ar BB10 one in future. Using Microsoft SMS organizer app as an alternative to Messages App but it does not integrate with Hub so can't tell if both way sync can happen with it or not. Anyways Fabulous Feb ahead.. Cheers.. !!
    02-01-18 11:13 AM
  4. RK_BB's Avatar
    A few months ago, Google seemingly changed their client to stop syncing FROM the system database. As I mentioned, you can probably get it to resync manually by going into the Apps Screen and deleting data, but this is heavy weight. It is probably best if you do your deletes within Messages.

    It is unusual in Android for the system database to change in this way, so we may never be able to get this to work properly.

    I have not tested other clients to see if any of them do two way sync. If you do try others, we would love to hear your results.
    This is yet another reason why Hub should be an SMS client (in addition to being an email client of course) and stop relying on external app integration.

    Every time these independent SMS apps are making changes they potentially can affect the functionality of Hub; inevitability this can be an endless compatibility race.

    I urge you BlackBerry reps to consider this implementation; though it may be resource heavy it is totally worth it for that reason and many other reasons that are constantly popping around the forum.
    02-01-18 12:34 PM
  5. LiamQ's Avatar
    I've had this issue on the PRIV, DTEK60, KEYone and Motion. I usually run into it if I select a lot of emails to delete (25+, the higher the number the more likely it happens).
    I agree with this observation! It doesn happen when multiple emails are deleted at once.
    RK_BB, can you clarify your comment? It happens only when deleting multiple messages at once?
    02-05-18 03:50 PM
  6. 20blackone00's Avatar
    my BlackBerry services is using tremendous battery resources. I've cleared the services numerous times. emails are delayed and sometimes don't even come in unless i manually refresh. Nothing changed on my end at all and this started happening.
    02-05-18 04:11 PM
  7. RK_BB's Avatar
    RK_BB, can you clarify your comment? It happens only when deleting multiple messages at once?
    That's correct. The only times I have experienced this issue is when multiple emails were deleted in one action; in other words, several emails are selected and then deleted.

    I cannot tell whether that statement is true only for deleting multiple emails from multiple accounts though I tend to believe that this is the case.

    Example: 7 emails are selected, 3 x Gmail and 4 x Office 365
    02-05-18 04:33 PM
  8. LiamQ's Avatar
    my BlackBerry services is using tremendous battery resources. I've cleared the services numerous times. emails are delayed and sometimes don't even come in unless i manually refresh. Nothing changed on my end at all and this started happening.
    Which version of BlackBerry Hub+ Services? Could you send a Bug Report to bbappsupport@blackberry.com?

    To send a bug report, you will need to enable Developer options (tap 7 times on Build Number in Settings -> About Phone). Then in Settings -> Developer options, you can tap “Take bug report” and share that with an email client. If the option is greyed out, toggle “Enable USB Debugging”, which should enable it.
    02-06-18 08:55 AM
  9. 20blackone00's Avatar
    1.5.8.48852

    sending the report in a min
    02-06-18 09:23 AM
  10. 20blackone00's Avatar
    my battery is plugged in right now though. should i wait a few hours into the day? My emails are also sometime super delayed.
    02-06-18 09:24 AM
  11. RK_BB's Avatar
    This started happening again....it was working as intended for a while but just now when deleting multiple emails from multiple accounts they were simply not deleted off the server.
    04-16-18 01:04 PM
  12. baldy3577's Avatar
    This started happening again....it was working as intended for a while but just now when deleting multiple emails from multiple accounts they were simply not deleted off the server.
    Glad I'm not the only one. I thought it was a server issue for my IMAP email server.
    04-16-18 11:00 PM
  13. breakingpoint0's Avatar
    I'm also having the delete issue as well as the delayed arrival issue. I'm using whatever the latest version of the Hub is. It used to work fine and has, for whatever reason, degenerated.
    04-20-18 09:41 AM
  14. max-bb's Avatar
    We are aware there are issues with multi-selection.

    Our expert in that area thinks it should be more reliable if you try to restrict multi-select to less than 50 items, and maybe only from one account at a time.
    04-20-18 01:19 PM
  15. RK_BB's Avatar
    We are aware there are issues with multi-selection.

    Our expert in that area thinks it should be more reliable if you try to restrict multi-select to less than 50 items, and maybe only from one account at a time.
    I very rarely need to delete so many email at a time, if ever. It happens to me occasionally even when trying to delete as few as 5 emails.

    I would like to add that there seem to be a difference in the two ways that the OS or Hub handle email deletion:

    If an email is accessed from the widget, notification shade or Productivity Tab, the deletion doesn't generate the Undo toast message.

    If an email is accessed from Hub the Undo toast message appears.

    This may have something to do with how the deletion is processed, may or may not be related to this issue.
    04-20-18 01:52 PM
  16. RK_BB's Avatar
    This is happening on a daily basis now, even when deleting single emails. It has nothing to do with the mail client type / provider or multiple accounts deletion.
    breakingpoint0 likes this.
    04-30-18 09:40 PM
  17. RK_BB's Avatar
    Now that we can see ALL messages in the Productivity Tab, when this bug is in effect you can see the none deleted message in the Productivity Tab.

    1. A message is deleted by the user in Hub
    2. The bug happens and therefore the message doesn't really get deleted
    3. The message still appear in the Productivity Tab from which it can be opened and properly deleted or simply deleted from there.

    Hopefully the team can replicate this!
    @LiamQ @max-bb
    05-22-18 01:18 PM
  18. RK_BB's Avatar
    Now that we have all messages in the Productivity Tab its easier to catch this bug whenever it happens!

    Today I deleted one message with a swipe action; the message disappear from the Hub list yet still apear in the Productivity Tab.

    This goes to show that this bug has nothing to do with multiple selection deletion as suggested before.

    Tagging @LiamQ @max-bb
    06-09-18 11:02 AM
  19. RK_BB's Avatar
    It looks like this bug is still unresolved as it happened to me several times today.

    As you can see by the date stamp of this thread it goes back well over a year as I recorded occurances on a none BlackBerry device, a KEYᵒⁿᵉ and currently my KEY²; I am wondering if it's still being worked on.
    @max-bb @LiamQ if you can shed some light on the status of this.
    09-26-18 10:14 PM
  20. RK_BB's Avatar
    For anyone that's affected, here is a workaround I just found:

    Before deleting emails hit the S key which will bring up the search function.

    While the search function is active, go ahead and delete your emails with confidence knowing they they are also getting deleted on the server!

    Alternatively deleting emails from the Productivity Tab is just as reliable. (Mine is turned off until the SMS threading issue is fixed).
    09-27-18 11:38 AM
  21. LiamQ's Avatar
    It looks like this bug is still unresolved as it happened to me several times today.

    As you can see by the date stamp of this thread it goes back well over a year as I recorded occurances on a none BlackBerry device, a KEYᵒⁿᵉ and currently my KEY²; I am wondering if it's still being worked on.
    @max-bb @LiamQ if you can shed some light on the status of this.
    We're not actively working on this one. We're still busy with the bugs that we're able to reproduce

    I can ask our Support team to reach out to collect logs after it happens. We might find clues there. If you want to pursue that, please PM me the email address that you'd like our Support team to contact you at.
    09-27-18 11:40 AM
  22. RK_BB's Avatar
    We're not actively working on this one. We're still busy with the bugs that we're able to reproduce

    I can ask our Support team to reach out to collect logs after it happens. We might find clues there. If you want to pursue that, please PM me the email address that you'd like our Support team to contact you at.
    Done
    09-27-18 11:45 AM
  23. RK_BB's Avatar
    We're not actively working on this one. We're still busy with the bugs that we're able to reproduce

    I can ask our Support team to reach out to collect logs after it happens. We might find clues there. If you want to pursue that, please PM me the email address that you'd like our Support team to contact you at.
    No one contacted me yet but in the meantime I found a way to re-produce it so perhaps bug reports can confirm my findings as I should be able to reproduce it and generate them immediately thereafter.

    Reproduction steps require some preamble in order to understand the issue fully so please let me know if you want me too post it here or PM you.
    09-29-18 10:47 AM
  24. LiamQ's Avatar
    No one contacted me yet but in the meantime I found a way to re-produce it so perhaps bug reports can confirm my findings as I should be able to reproduce it and generate them immediately thereafter.

    Reproduction steps require some preamble in order to understand the issue fully so please let me know if you want me too post it here or PM you.
    Posting here is best.
    09-29-18 12:00 PM
  25. RK_BB's Avatar
    Posting here is best.
    Assumptions:

    1. Hub is set to delete emails on Hub & Server

    Cause of “Bug” theory:

    1. The Undo Delay of the first deleted message is overridden by an Undo Delay of multiple messages deleted at the same time or in immediate succession and ‘hang’ the message/s in an ‘unknown territory’ (term will be explained below).

    There are different ways to deleting an email for which the Undo Delay behave differently:

    1. From the Productivity Tab, No Undo Delay
    2. From the Notification Shade, Undo Delay Apply
    3. From Hub, method A, From the standard Hub list:
      a. Long press followed by Delete, Undo Delay Apply
      b. Open message followed by Delete, Undo Delay Apply
      c. Swipe to Delete, Undo Delay Apply
    4. From Hub, method B, Press the S key to activate the Hub search bar and then:
      a. Long press followed by Delete, No Undo Delay
      b. Open message followed by Delete, Undo Delay Apply – significantly shorter than usual
      c. Swipe to Delete, Undo Delay Apply – significantly shorter than usual

    The “Bug” occurs when deleting multiple messages at the same time or in immediate succession using methods 3a. and 3c.

    In order to understand the term ‘unknown territory’ mentioned in item 1 of the “Bug” theory we are going to delete an email message using method 3a. and while the Undo delay is going press the S key to activate Hub’s search bar.

    After the deletion action was performed the message was removed from the list but when the S key was pressed, Hub search bar was activated, and the deleted message reappeared in the list awaiting the Undo Delay to complete after which it will be entirely removed from Hub & the Server.

    The ‘unknown territory’ is therefore referred to where the message can be found after it was deleted by pressing the S key to activate Hub search bar.

    Reproduction of “Bug”:

    Delete multiple message (6 or more) using methods 3a. and 3c. (test both please). This time wait for the Undo Delay to complete and only then press the S key to activate Hub search bar and you will see all or some of the messages you intended to delete. The messages will hang in that 'territory' indefinitely and in fact, deleting them from that 'territory' actually complete the deletion action and remove them from the server.

    This “Bug” will not occur with any other deletion method described above.

    This "Bug" can be reproduce on any device, BlackBerry or not.
    10-01-18 02:49 AM
203 ... 23456 ...

Similar Threads

  1. BBM not opened yet. Front Cam also
    By Janarthanan Jana in forum BlackBerry Z30
    Replies: 5
    Last Post: 08-01-17, 10:21 AM
  2. Smartlock Maps Not Opening
    By claytargets in forum BlackBerry DTEK60
    Replies: 2
    Last Post: 07-31-17, 05:29 PM
  3. Font in the HUB app
    By Konan Philippe-Alexandre in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-31-17, 12:17 PM
  4. How to delete previous Blackberry ID?
    By materes in forum BlackBerry Classic
    Replies: 2
    Last Post: 07-31-17, 08:22 AM
  5. Contacts not sync'ed
    By thidisbogus in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-30-17, 10:15 PM
LINK TO POST COPIED TO CLIPBOARD