1. pdanny's Avatar
    A few days ago, without any changes to my settings, Exchange ActiveSync stopped working properly on my KeyOne. Emails are now truncated to 251 characters (always the same number) and are displayed in plain text (no HTML). I use Zoho for my email provider (msync.zoho.com). When I view emails in Thunderbird or the Zoho web email client, the emails are displayed properly and are not truncated. I also tried adding the account the Gmail app, using the EAS connection - emails are displayed properly there. So I conclude that this is only a problem in the Hub, possibly not playing well with the Zoho msync.

    I have tried removing the email account in my Hub and adding it again. This solves the problem for a few hours, then it goes back to showing truncated emails. Switching the the IMAP server also works perfectly, except it does not sync my calendar or contacts, which is not a good solution.

    I believe the last update to the Hub was Dec 20, 2018, so I don't think this is a problem related to an app update. There was a security fix that was pushed out a few days ago, but I'm not sure if that is exactly coincides with the problem starting - but I'm not ruling that out. All other accounts (Gmail, Hotmail, etc are fine using their own EAS servers).
    03-02-19 11:25 AM
  2. LiamQ's Avatar
    Which version of BlackBerry Hub+ Services are you using?
    pdanny likes this.
    03-02-19 07:11 PM
  3. pdanny's Avatar
    Hub+ Services Ver. 1.6.2.53586
    Hub Ver. 1.6.2.16480
    Also, I'm using a KeyOne with OS 8.1

    But neither of these version have been updated since the problem started happening.
    03-03-19 08:18 AM
  4. yeah1's Avatar
    A few days ago, without any changes to my settings, Exchange ActiveSync stopped working properly on my KeyOne. Emails are now truncated to 251 characters (always the same number) and are displayed in plain text (no HTML). I use Zoho for my email provider (msync.zoho.com). When I view emails in Thunderbird or the Zoho web email client, the emails are displayed properly and are not truncated. I also tried adding the account the Gmail app, using the EAS connection - emails are displayed properly there. So I conclude that this is only a problem in the Hub, possibly not playing well with the Zoho msync...........
    I am having the exact same issue as of approximately the exact same time. I'm on Blackberry Motion. Also have not updated Hub or Hub+ Services or anything else.
    pdanny likes this.
    03-04-19 04:37 PM
  5. pdanny's Avatar
    I'm guessing this was a change on the Zoho side of things rather than the BB/Hub side. I'm not sure we're going to get a fix from either Zoho or BB. What are you using as an alternative?
    03-05-19 11:02 AM
  6. LiamQ's Avatar
    Can you confirm if the same problem happens with today's update to BlackBerry Hub+ Services 2.1902.0.54792? Please try removing and re-adding the account after the update.
    pdanny likes this.
    03-05-19 04:39 PM
  7. max-bb's Avatar
    Also, are you using a Zoho business or personal account? Is EAS available for personal accounts?
    03-05-19 04:44 PM
  8. yeah1's Avatar
    Can you confirm if the same problem happens with today's update to BlackBerry Hub+ Services 2.1902.0.54792? Please try removing and re-adding the account after the update.

    Have updated, and still same problem.

    And it is a Zoho business account.
    pdanny likes this.
    03-05-19 06:43 PM
  9. pdanny's Avatar
    Yes, it is still happening after the version 2 update. If you remove and re-add the account after the update, it works for about 2 hours and then it goes back to the same truncated behavior. It's a Zoho Business account. Given that @yeah1 seems to have had the same thing happen around the same timing and not coincident with any BB/app updates, I'm guessing that Zoho did something on their end that doesn't play well specifically with the Android Hub+. Any thoughts?
    03-06-19 08:56 AM
  10. LiamQ's Avatar
    Can you ask Zoho what they changed?
    03-06-19 04:15 PM
  11. pdanny's Avatar
    I have reached out, but I doubt they'll reveal any specifics.
    03-06-19 07:27 PM
  12. yeah1's Avatar
    I have as well. Sent screenshots of issue to support, doubt they'll be helpful.

    Also spoke to them on the phone and specifically asked if they have made any changes to their mail product in the last week or so, and they said no, but not sure how accurate that actually is.
    pdanny likes this.
    03-06-19 08:19 PM
  13. pdanny's Avatar
    Well, this sucks... I guess its workaround time (I'll update if I hear anything helpful from Zoho or BB). You can add the account using the IMAP server and then sync your calendar with this: https://www.zoho.com/calendar/help/z...c-android.html and sync your contacts with this: https://www.zoho.com/contacts/help.html#android
    03-07-19 11:04 AM
  14. yeah1's Avatar
    Well, this sucks... I guess its workaround time (I'll update if I hear anything helpful from Zoho or BB). You can add the account using the IMAP server and then sync your calendar with this: https://www.zoho.com/calendar/help/z...c-android.html and sync your contacts with this: https://www.zoho.com/contacts/help.html#android
    Thank you
    03-07-19 11:24 PM
  15. pdanny's Avatar
    @yeah1 Zoho replied to my support ticket with an update saying the pushed a fix for the truncate issue. It seems to be working for me. Can you confirm AES works on your side after the Zoho fix?
    max-bb likes this.
    03-12-19 11:46 AM
  16. yeah1's Avatar
    @yeah1 Zoho replied to my support ticket with an update saying the pushed a fix for the truncate issue. It seems to be working for me. Can you confirm AES works on your side after the Zoho fix?
    Was just going to say they sent me a response to my ticket saying the same thing. Haven't tested it yet, but will shortly.
    pdanny likes this.
    03-12-19 02:07 PM
  17. yeah1's Avatar
    It works. Issue resolved.
    pdanny likes this.
    03-17-19 07:10 AM
  18. yeah1's Avatar
    @pdanny I have noticed though that I can no longer do remote search for this account in BlackBerry Hub. Can you?
    03-21-19 08:46 AM
  19. pdanny's Avatar
    I have noticed though that I can no longer do remote search for this account in BlackBerry Hub. Can you?
    I really never used remote search (because I always sync "forever"), so I have not noticed until you mentioned it. But it looks like you're right. Only the Zoho IMAP accounts appear when trying to do a remote search. The EAS account is not listed. Syncing forever, while possibly memory intensive, seems to work though.
    03-21-19 09:08 AM

Similar Threads

  1. Mobile Nations acquired by Future PLC
    By Heavens1 in forum Armchair CEO
    Replies: 65
    Last Post: 03-30-19, 07:53 AM
  2. Replies: 4
    Last Post: 03-23-19, 07:27 PM
  3. Blackberry Hub response
    By Tawfik Mohamed in forum BlackBerry KEYone
    Replies: 22
    Last Post: 03-12-19, 09:57 AM
  4. How to edit WhatsApp contact in Hub?
    By Zebra 99 in forum BlackBerry HUB+ Suite
    Replies: 2
    Last Post: 03-04-19, 01:48 AM
  5. From classic to keyone to key2.
    By Karan Riar in forum BlackBerry Classic
    Replies: 0
    Last Post: 03-01-19, 09:36 PM
LINK TO POST COPIED TO CLIPBOARD