1. saescott's Avatar
    Hi,
    I am trying to install the new version of the BB Launcher on my LG G4, and I get "Error 505".
    Has anyone else experienced this error with the new Launcher version? I know that it is a known and pesky Android issue, but I am wondering if my issue here has to do with the fact that I am a Blackberry Beta Tester, and that some conflict may have occurred due to the Beta version being on my device...
    I have tried all known solutions that come up on google, and nothing has worked. In th meantime, since one of the solutions involved deleting the prior version, I am Launcherless....
    If others have experienced it, please upvote this post so that BB takes notice...
    06-30-17 06:58 AM
  2. maxpowerxiii's Avatar
    I've got the same problem. I'm getting the 505 and I'm not a beta tester. I have subscribed to hub+ and it was working fine until there was a recent update. the update wouldn't install properly so I tried uninstalling and reinstalling and I get the 505 error. I've lost the launcher completely. I'm using an S7.
    I hope BlackBerry fixes it soon.
    saescott likes this.
    06-30-17 07:15 AM
  3. saescott's Avatar
    Problem solved.
    Cobalt referred to the issue here, so I downloaded his patched version (1.1.4.7109) from here, and it installed great, and even shows up in Hub+ as being installed.
    Again, thanks to Cobalt.
    Last edited by saescott; 06-30-17 at 08:28 AM.
    06-30-17 07:41 AM
  4. maxpowerxiii's Avatar
    Amazing. I downloaded a previous version from his repository yesterday and now I find that he's already patched the problem and uploaded a new version today. BlackBerry should hire this guy and make him their software director. He's been absolutely amazing since the BB10 days when he patched Google play to work. That's assuming he wants to work for BlackBerry.
    kbz1960 likes this.
    06-30-17 07:55 AM
  5. Cobalt232's Avatar
    As described in my thread, the new Launcher is trying to register a permission that is already used by the stock launcher on Samsung S6, S7 and maybe other models / manufacturers. This causes package manager to refuse installation.

    The current fix is to rename the permission. That's what I did in my patched version.

    This bug needs to be fixed by BlackBerry asap.
    anon(3641385) likes this.
    06-30-17 08:15 AM
  6. Ecm's Avatar
    Hi,
    I am trying to install the new version of the BB Launcher on my LG G4, and I get "Error 505".
    Has anyone else experienced this error with the new Launcher version? I know that it is a known and pesky Android issue, but I am wondering if my issue here has to do with the fact that I am a Blackberry Beta Tester, and that some conflict may have occurred due to the Beta version being on my device...
    I have tried all known solutions that come up on google, and nothing has worked. In th meantime, since one of the solutions involved deleting the prior version, I am Launcherless....
    If others have experienced it, please upvote this post so that BB takes notice...
    If you're stuck without a launcher and unable to install one from your device, try going to the Google Play store on desktop. Sign in, select a launcher (BlackBerry or other -- such as Nova or Arrow), and click Install. It will be pushed to your device and installed. That may get you going again.
    kbz1960 likes this.
    06-30-17 08:18 AM
  7. Cobalt232's Avatar
    Remote install via Play Store website. Good idea! But won't work for the described problem, at least not for BlackBerry Launcher.
    saescott likes this.
    06-30-17 08:21 AM
  8. Ecm's Avatar
    Yeah, but at least may get the OP a workable other launcher to try other options.

    And wow -- my comment was posted long after I actually responded.
    06-30-17 08:50 AM
  9. Cobalt232's Avatar
    BlackBerry has fixed the bug in BlackBerry Launcher. The new version is 1.1.4.7160.

    What was fixed:
    1. App name changed from LauncherFacade to BlackBerry Launcher
    2. Permission com.android.launcher.permission_READ_SETTINGS renamed to com.blackberry.blackberrylauncher.permission.READ_ SETTINGS
    3. com.android.launcher.permission_WRITE_SETTINGS renamed to com.blackberry.blackberrylauncher.permission.READ_ SETTINGS

    The new version now installs on Samsung S6/S7 and other devices where the conflict with the permissions occoured.

    Thanks bb
    anon(3641385) likes this.
    06-30-17 05:26 PM
  10. Cobalt232's Avatar
    Problem solved.
    Cobalt referred to the issue here, so I downloaded his patched version (1.1.4.7109) from here, and it installed great, and even shows up in Hub+ as being installed.
    Again, thanks to Cobalt.
    If you are SUBSCRIBED to the BlackBerry service, I highly suggest to remove the patched version of Launcher and to install the officially fixed version from Play Store, otherwise you won't be able to install future updates from Play Store.
    Ecm likes this.
    06-30-17 05:50 PM
  11. Ecm's Avatar
    Cool. Thanks.
    06-30-17 05:52 PM
  12. Cobalt232's Avatar
    @LiamQ

    Liam, are you aware of the issue with Launcher not installing on Samsung devices? It has surfaced again in the latest beta 1.1.5 of Launcher.
    08-15-17 04:22 AM
  13. Cobalt232's Avatar
    Solved, great!
    08-25-17 03:14 PM

Similar Threads

  1. Import Contacts *TO* 8530? Can This Still Be Done?
    By rlctnt in forum BlackBerry Curve Series
    Replies: 4
    Last Post: 07-12-17, 06:20 PM
  2. Can BlackBerry Classic be used as a Feature Phone !?
    By rajashekar sanga in forum Ask a Question
    Replies: 4
    Last Post: 07-05-17, 10:49 PM
  3. Error: bb10-0015
    By hamitako in forum BlackBerry Q5
    Replies: 1
    Last Post: 07-02-17, 10:11 AM
  4. My Blackberry Launcher has a weird bug...
    By johnnydoesai in forum BlackBerry Android OS
    Replies: 12
    Last Post: 06-30-17, 05:57 PM
  5. BB Passport - Error message when I turn it on
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-17, 02:46 PM
LINK TO POST COPIED TO CLIPBOARD