1. stardomains's Avatar
    Just updated the other day to latest Android BB Calendar.(I subscribe) My caldav calendar was not working anymore with it. Uninstalled it. Reinstalled. Reboot. Cleared app and phone cache. Readded caldav account. Will not show up in the Calendar app. Shows up on the phones settings-accounts. But not to be found in the Calendar app. Not under Settings-accounts and calendar folders nowhere. No BlackBerry app is being battery optimized. All permissions granted. This sucks. I use my calendar the most of any app.
    bobaloo and dewdo like this.
    12-14-17 02:06 PM
  2. LiamQ's Avatar
    We have a fix that we're testing for this.
    bobaloo and dewdo like this.
    12-18-17 03:53 PM
  3. bobaloo's Avatar
    Any update on this? I've been working on this for two days, both on the client and server side. I just realized that an old Z30 is working as expected and so is another android phone with an older calendar version. So I'm assuming it's an app issue.

    sooo, like I said. Any updates?
    01-09-18 06:17 PM
  4. LiamQ's Avatar
    BlackBerry Hub+ Services 1.5.7.48570 had a fix for CalDAV issues. Do you have that version?

    If you're still seeing the issue with the latest BlackBerry Hub+ Services, please send a Bug Report to bbappsupport@blackberry.com. To send a bug report, you will need to enable Developer options (tap 7 times on Build Number in Settings -> About Phone). Then in Settings -> Developer options, you can tap “Take bug report” and share that with an email client. If the option is greyed out, toggle “Enable USB Debugging”, which should enable it.
    bobaloo likes this.
    01-10-18 12:00 PM
  5. bobaloo's Avatar
    Thank you for the response.

    So I have hub+ ver. 1.5.7.48570
    I have calendar ver. 1.5.7.14179
    I have contacts ver. 1.5.7.14179
    I use a Samsung S8 on Verizon.

    I've been working on this two days. I have learned a lot and updated my description of the symptom so I won't take you down the whole path of my learning. If you're curious, you can check my post history to see the details

    The punchline is:
    We have our own server, I have access to logs.
    I use IMAP, carddav, and caldav.

    I've never had a problem since Z10 release.
    My wife's S8 with nearly identical setup but earlier calendar version works fine (Sorry I can't remember version number)
    For testing I fired up my old Z30; it works fine.

    Now I'm noticing I'm not syncing. I have not made settings changes on my galaxy s8 or email server. I check the server logs. My last successful caldav or carddav authentication was mid-day January 6. I noticed the symptom on the evening of the 8th.

    This applies for both carddav and caldav. I noticed the symptom as a syncing problem, but have learned that the problem with syncing is more an effect of other causes.

    When attempting to update account settings, when pressing "save" a message pops up stating "can't connect to server. Please check your settings, and try again." I know my settings are correct. But I've learned it has to do with the security type. If I choose ssl/tls, ssl/tls (accept all), starttls, or starttls (accept all) I get that error message. I've verified port settings. I've even played around with using non-standard ports after opening them up. Still get the same message. I've used multiple variations of the server address. Still get the same message.

    Now, if I change the "security type" setting to "none," I connect just fine and syncing works. However, on accounts whose settings are left over from before this symptom presented, selecting "none" does not give an error, but it also does not start syncing with the server, even when changing sync intervals or pressing "refresh." The only way to get it to sync is to delete the account and then reenter it with "none" selected as the security setting.

    I've deleted the app. I've cleared cache and data on both BB calendar and the stock calendar.

    (Not related, but I also have a perpetual duplicate account that I cannot get rid of or access any settings to, even after clearing data).

    IMAP email syncs perfectly on all folders using secure protocols.

    So that's about it I guess. I know you asked me to send a bug report... and I will. But I wanted to type this out here to see if you have any insight and also to give other people with similar issues something to compare against.

    Thanks again for your response. Look forward to any other info you may have. I'm looking into sending that report now.
    dewdo likes this.
    01-10-18 01:32 PM
  6. dewdo's Avatar
    Did you find a resolution to this? I have the same problem on dtek50s
    01-19-18 12:10 PM
  7. AdamQwert's Avatar
    Hi,
    not sure if the same , but also having issue with Blackberry Calendar on BB Motion.
    here the descritpion^ https://forums.crackberry.com/showth...1#post13123977

    Also had a ticket with BlackBerry support, but beside resetting to factory default they didnt suggested anything else. I did it at least 3 times..

    My issue is that Calendar app freezes for a second or two and then closes, but to background and not fully. In fact the behavior of the app is such that it is impossible to work with it.
    What I've noticed is that after the full reset to factory default, the app works perfectly, but after the update of Google Play for Hub and Calendar the issue starts.
    Also tried to download two other Calendar apps and no issues with them at all.
    01-23-18 09:12 PM

Similar Threads

  1. Replies: 4
    Last Post: 04-03-18, 04:36 PM
  2. Word update - made worse?
    By dorsetshaw in forum BlackBerry KEYone
    Replies: 14
    Last Post: 01-15-18, 02:32 PM
  3. Replies: 1
    Last Post: 01-07-18, 09:02 AM
  4. Replies: 6
    Last Post: 01-05-18, 09:41 AM
  5. Not receiving all emails (Gmail and Yahoo) on Q10
    By Zoe42 in forum Ask a Question
    Replies: 0
    Last Post: 12-14-17, 12:16 PM
LINK TO POST COPIED TO CLIPBOARD