1. WT44's Avatar
    And it has been doing so since they first introduced Dark theme to the Hub.

    Also, it messes with the original colors in emails. Colors are changed when using the dark theme. I do not think dark theme should mess with the original colors within emails. Only exchange black for white and that's it.

    Nobody from BB/TCL seems to care or simply do not have the knowledge to solve it. After all, it's an issue that already existed when they introduced the dark theme to the hub.

    I hate when people settle for mediocrity and don't bother to deal with sloppiness.

    This is just a warning for people who never used the default "normal theme": when you're using dark theme, you most likely are missing out on all kinds of stuff in emails compared to the default mode.

    I mentioned it already in November 2017 as a side comment to another issue. That's right, almost one year ago.

    Original thread: https://forums.crackberry.com/blackb...-also-1129754/

    No comment. No solution. No nothing. Hence the new "heads-up" with its own dedicated thread and with a strong request to take care of these bugs for once and for all.

    Original message (11-02-17 04:12 AM):


    P.S. What I also do not like is that dark theme changes colors where it does not seem necessary. I think dark theme should not mess with original colors that were used in E-mails (e.g. banner, lines, text) and should only make dark what was previously white and make white what was previously black.

    Example:
    No need to make the red lines (seen in the original default theme), all of a sudden, white:
    BE AWARE: Dark Theme for HUB DELETES words/sentences/icons in emails-.screenshot_20171102-093023.jpgBE AWARE: Dark Theme for HUB DELETES words/sentences/icons in emails-b.screenshot_20171102-092948.jpg

    Also, I'm already a bit skeptical that dark theme might make certain stuff disappear in E-mails that were originally there when opening it in the white theme. I hate the idea to miss out on something and not know it. I'm not only talking about text, but about actual E-Mail content also.

    Here's a text example (at least this time you can tell that "something" is missing):
    BE AWARE: Dark Theme for HUB DELETES words/sentences/icons in emails-1.screenshot_20171102-095131.jpgBE AWARE: Dark Theme for HUB DELETES words/sentences/icons in emails-2.screenshot_20171102-095045.jpg

    It's like "redactor" going all over email content.

    On a side note:
    Changing to dark theme or to white theme brings you all the way to the top of your hub list again. Would make more sense if the system would remember the position in the Hub after changing the theme color.
    Last edited by WT44; 10-15-18 at 12:36 PM.
    RK_BB likes this.
    10-08-18 01:00 PM
  2. WT44's Avatar
    Fast Forward.

    I waited all this time to see if BB/TCL MIGHT solve these horrible bugs when Oreo would be launched. I guess not.

    1 year later.

    Nothing solved.

    Original colors are still not retained.

    Changing theme still brings you to the top of the Hub in stead of remembering its position.

    Email content still disappears when dark theme is being used.

    BE AWARE: Dark Theme for HUB DELETES words/sentences/icons in emails-clipboard.jpg
    (Click on the image to enlarge; and no, I did not use "Redactor", Dark theme simply removes stuff or makes it unreadable; I always have this sour aftertaste when reading email using dark theme that I might have missed out on something due to this horrible bug).
    RK_BB and gizmo21 like this.
    10-08-18 01:02 PM
  3. LiamQ's Avatar
    If we don't drastically change the colours of a message in Dark Theme, it's quite common to find unreadable messages. Too many email senders specify dark text colours and assume that a light background will be used.

    It's not an easy problem to solve.

    Changing theme still brings you to the top of the Hub in stead of remembering its position.
    Fixing that will continue to be a low priority for us because switching themes is not a frequent user action.
    10-09-18 10:45 AM
  4. Bostil1987's Avatar
    Hello Liam,

    not related to this topic, but via crackberry-app I cannot write you directly.

    The following issue with BlackBerry Hub on Keyone Oreo 8.1 persists when opening attachments / images in hub with combination of the Piktures (from Google Play Store): the opened, viewed image is always shown with a fixed zoom and is not adjustable.

    Do you have a clue how to solve this ? Or is this related more to "Piktures" ?

    Thank you!
    10-11-18 04:28 AM
  5. LiamQ's Avatar
    The following issue with BlackBerry Hub on Keyone Oreo 8.1 persists when opening attachments / images in hub with combination of the Piktures (from Google Play Store): the opened, viewed image is always shown with a fixed zoom and is not adjustable.

    Do you have a clue how to solve this ? Or is this related more to "Piktures" ?
    I think you would need to take that up with the Piktures developers.
    10-12-18 03:12 PM
  6. WT44's Avatar
    Hello Liam,

    not related to this topic, but
    I reported this message some time ago as it not even remotely has anything to do with the issue at hand. Since none of the mod team cared to (re)move your totally off-topic message nor inform me as to why they won't (re)move it (this forum might not have policies regarding "thread-hijacking"), I'll ask you to further continue in a thread created by yourself about your topic: https://forums.crackberry.com/blackb...us-suite-f459/ ---->"Post new thread."
    10-13-18 11:49 AM
  7. ray689's Avatar
    I reported this message some time ago as it not even remotely has anything to do with the issue at hand. Since none of the mod team cared to (re)move your totally off-topic message nor inform me as to why they won't (re)move it (this forum might not have policies regarding "thread-hijacking"), I'll ask you to further continue in a thread created by yourself about your topic: https://forums.crackberry.com/blackb...us-suite-f459/ ---->"Post new thread."
    Lol chill out.
    10-13-18 12:00 PM
  8. WT44's Avatar
    If we don't drastically change the colours of a message in Dark Theme, it's quite common to find unreadable messages.
    But it's already common that parts are unreadable as you can see in the screen shots here above.

    Too many email senders specify dark text colours and assume that a light background will be used.

    It's not an easy problem to solve.

    Fixing that will continue to be a low priority for us because switching themes is not a frequent user action.
    I guess it's acceptable when in dark theme the colors need to change drastically in order for dark theme to more or less work, and I can understand that many people will probably hardly change from white theme to dark theme (in order to check if they might missed out on something), but can't you guys do anything about the most important thing I mentioned:
    Making sure that it doesn't look like "Redactor" got chunks of email content (text, mostly smaller letters; and stuff like rectangles, squares, triangles and what not) or at least have a look as to why text and other stuff often just disappears from emails? It's makes one feel that one can't trust dark theme as it obviously isn't 100% reliable in many cases.
    10-13-18 12:05 PM
  9. itsyaboy's Avatar
    I have only ever used the dark theme but have never experienced that this is/was an issue. Do you have some more examples? Especially with regard to the deletion of text? I was thinking that the emails likely to suffer from this are newsletters that use a lot of style edits. This is unlikely to happen with text-only emails, correct?
    10-15-18 05:01 AM
  10. LiamQ's Avatar
    Making sure that it doesn't look like "Redactor" got chunks of email content (text, mostly smaller letters; and stuff like rectangles, squares, triangles and what not) or at least have a look as to why text and other stuff often just disappears from emails? It's makes one feel that one can't trust dark theme as it obviously isn't 100% reliable in many cases.
    Is that consistently reproducible with messages from Dolce & Gabbana? We need a reproducible case to investigate that.
    10-15-18 09:54 AM
  11. WT44's Avatar
    I have only ever used the dark theme but have never experienced that this is/was an issue. Do you have some more examples? Especially with regard to the deletion of text? I was thinking that the emails likely to suffer from this are newsletters that use a lot of style edits. This is unlikely to happen with text-only emails, correct?
    I don't think text-only emails are affected. From what I can tell only smaller font letters and logos/basic geometric shapes are affected and it seems only the last parts of an email (like my examples show). However, the point is that whenever it happens, even if they are trivial newsletters, it makes one insecure that it could happen elsewhere too. The fear of potentially missing out on something or the feeling that one has to double check important messages in white theme to double-check if dark theme didn't erroneously delete certain parts in a disclaimer for instance. There clearly is some kind of nasty bug which makes it seem as if redactor got a hold of chunks of text. That's why I think it's interesting what would come out of this upon investigation.

    Is that consistently reproducible with messages from Dolce & Gabbana? We need a reproducible case to investigate that.
    For me, yes. Happens every time. You can sign-up here:
    https://store.dolcegabbana.com/en I'm not sure if the EU market (NL and GER in my case) gets the exact same newsletter as the American/Canadian market. You'll get two different newsletters when signing-up, one from: newsletter@dolcegabbana.it (sender: Dolce&Gabbana) and one from newsletter@news.dolcegabbana.com (sender: Dolce&Gabbana Online Store). It's the first that always gives issues with the smaller font letters at the end and with missing or (partly) removed geometric figures (as you can see in the examples shown here above). But it's not the D&G newsletter exclusively; same thing happens to me with newsletters from for example Hermès and Brunello Cucinelli, although it's been a while since I seen it in either of their newsletters, so it could be that something changed on their end? What is worse though is that it also happened on a few occasions with work-related emails. Always, the same type of issues as mentioned in this thread. Would be interesting to see what the final conclusions will be in the end.
    Last edited by WT44; 10-15-18 at 01:01 PM.
    10-15-18 12:35 PM

Similar Threads

  1. BlackBerry KEY2 LE will be available in India starting October 12
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-08-18, 10:30 AM
  2. BlackBerry KEY2 LE now available in France and the Netherlands
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-08-18, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD