03-10-19 09:04 AM
54 123
tools
  1. rgordon44's Avatar
    Really hope we can get Evolve in USA. Love the HUB and touchscreen keyboard on my Leap!
    Assume HUB, etc will be even better than on BB Motion?
    10-21-18 08:27 AM
  2. Chuck Finley69's Avatar
    Really hope we can get Evolve in USA. Love the HUB and touchscreen keyboard on my Leap!
    Assume HUB, etc will be even better than on BB Motion?
    The Evolve isn't USA compatible for the most part. BBMo/TCL made the Motion and it flopped. The Evolve would just be a Motion2. If you really want VKB, as others have suggested, you could buy premium VKB from different OEM and install the BB suite.
    Gerard62100 likes this.
    10-21-18 08:46 AM
  3. wbeckle's Avatar
    What's VKB?
    01-02-19 08:28 PM
  4. Chuck Finley69's Avatar
    Virtual Keyboard
    01-02-19 08:31 PM
  5. smasha132's Avatar
    01-28-19 12:23 PM
  6. conite's Avatar
    Network compatibility in North America makes the Evolve essentially useless.
    01-28-19 12:24 PM
  7. smasha132's Avatar
    I just cracked my screen on my motion....so I threw caution to the wind (especially since the motion doesn't seem available on amazon today) and ordered it. I will come back friday or Thursday with whether I had to return it or any other questions people have. I'm currently using AT&T prepaid so my fingers are crossed.
    01-28-19 02:05 PM
  8. conite's Avatar
    I just cracked my screen on my motion....so I threw caution to the wind (especially since the motion doesn't seem available on amazon today) and ordered it. I will come back friday or Thursday with whether I had to return it or any other questions people have. I'm currently using AT&T prepaid so my fingers are crossed.
    Fingers crossed for what? I already warned you.

    Evolve supports LTE bands 1, 3, 5, 7, 8, 40, 41.

    AT&T uses 2, 4, 5, 12, 14, 17, 19, 30, 66 - the main bands being 12 and 17.

    You have a single (low-priority) band in common (band 5). This is not workable.
    Last edited by conite; 01-28-19 at 02:24 PM.
    01-28-19 02:14 PM
  9. smasha132's Avatar
    ok.....but why would they sell it to US customers? Is a physical adjustment needed for the phone to access said bands?

    Looks like I'll be returning it....any options for getting another Motion? been looking all day.
    01-28-19 03:32 PM
  10. conite's Avatar
    ok.....but why would they sell it to US customers? Is a physical adjustment needed for the phone to access said bands?
    Band compatibility is built into the phone. You can't change it.

    I can't speak to NGPstoreusa.com's thoughts on the matter.

    Instead of a 15 month-old phone, I'd look at getting a Nokia 7.1 (64/4) for $349 and putting the BlackBerry App Suite on it.
    Last edited by conite; 01-28-19 at 04:15 PM.
    01-28-19 03:54 PM
  11. Amaroni's Avatar
    ok.....but why would they sell it to US customers? Is a physical adjustment needed for the phone to access said bands?

    Looks like I'll be returning it....any options for getting another Motion? been looking all day.
    Perhaps look at getting the screen replaced , might be a cheaper option right now .

    And no adjustment is possible. The Evolve wasn't designed to be sold outside of India . It will work in the USA but you may get reception, you may not, you won't get consistent 4 g connection if at all. It will be more than likely very hit and miss and very much dependant on your location.

    If you bought the device via Amazon you could try it and if it doesn't work return it under the terms and conditions set by Amazon
    01-28-19 03:57 PM
  12. thurask's Avatar
    Instead of a 15 month-old phone, I'd look at getting a Nokia 7.1 (64/4) for $349 and putting the BlackBerry App Suite on it.
    This advice is valid for any full-touch BB.
    01-28-19 04:32 PM
  13. Amaroni's Avatar
    This advice is valid for any full-touch BB.
    I would suggest the advice is valid for any 15 month old device, full touch , PKB or non blackbery however if you are comfortable with your device then there is no reason not to have it fixed or replaced if you can find a replacement.
    01-29-19 01:02 AM
  14. smasha132's Avatar
    Ok, back with my update. Received my Evolve, and inserted my SIM from AT&T into it. I was able to send and receive txt messages. I connected to whatsapp and was able to video chat and make calls within that app. I was NOT however, able to make or receive regular phone calls.

    I'm going to go to AT&T tomorrow and see if there is something I'm missing besides the bands you guys mentioned earlier.

    Other than that, its very tempting to keep this phone since pictures seem to be better than my motion. Even has a bokeh feature (depth of field) ei

    Any hope for Evolve to be sold in the U.S?-img_010219_203148b.jpg


    I haven't had a chance to go through everything yet but I can't keep this if I can't make phone calls. Wish I had asked questions prior even though I really think I like this thing.


    anywho if yall have any questions you got til Monday to ask.
    02-01-19 08:08 PM
  15. Amaroni's Avatar
    Ok, back with my update. Received my Evolve, and inserted my SIM from AT&T into it. I was able to send and receive txt messages. I connected to whatsapp and was able to video chat and make calls within that app. I was NOT however, able to make or receive regular phone calls.

    I'm going to go to AT&T tomorrow and see if there is something I'm missing besides the bands you guys mentioned earlier.

    Other than that, its very tempting to keep this phone since pictures seem to be better than my motion. Even has a bokeh feature (depth of field) ei

    Click image for larger version. 

Name:	IMG_010219_203148b.jpg 
Views:	24 
Size:	95.9 KB 
ID:	442773


    I haven't had a chance to go through everything yet but I can't keep this if I can't make phone calls. Wish I had asked questions prior even though I really think I like this thing.


    anywho if yall have any questions you got til Monday to ask.
    Such a pity that you can't make or receive calls , have you checked the settings in the Mobile Network section. There you can enable 4g enhanced lte mode plus choose which preferred network mode you wish to use . It may not have been set to take into account the AT and T band you have available.

    I hope you are able to find a solution but thank you for at least providing a definite answer as to whether the device will work in the USA. 😀

    Edit ....if you can send and receive texts then this is a setting issue. @ Chuck is there some activation that is needed when using an ATandT sim card ?

    Try checking the settings on the device failing which try doing a factory reset and see if that resolves the issue. When I got mine it wanted to do a security update plus all the apps wanted to update , did yours do the same?
    02-02-19 12:43 AM
  16. Chuck Finley69's Avatar
    Such a pity that you can't make or receive calls , have you checked the settings in the Mobile Network section. There you can enable 4g enhanced lte mode plus choose which preferred network mode you wish to use . It may not have been set to take into account the AT and T band you have available.

    I hope you are able to find a solution but thank you for at least providing a definite answer as to whether the device will work in the USA.

    Edit ....if you can send and receive texts then this is a setting issue. @ Chuck is there some activation that is needed when using an ATandT sim card ?

    Try checking the settings on the device failing which try doing a factory reset and see if that resolves the issue. When I got mine it wanted to do a security update plus all the apps wanted to update , did yours do the same?
    Unfortunately, technical aspects go above my knowledge base. There’s only single band 5 shared according to Conite and. I’ve only encountered problems having missing LTE data bands..
    02-02-19 06:38 AM
  17. smasha132's Avatar
    yes it updated everything...I've factory reset it once with no luck.
    02-02-19 10:24 AM
  18. Amaroni's Avatar
    yes it updated everything...I've factory reset it once with no luck.
    Ok and the mobile settings?
    02-02-19 11:47 AM
  19. Chuck Finley69's Avatar
    yes it updated everything...I've factory reset it once with no luck.
    How old is the SIM card? I would go to AT&T corporate store if possible and get new SIM card. Even if relatively new, you have nothing to lose forcing device and new SIM card through provisioning setup process.
    02-02-19 11:56 AM
  20. smasha132's Avatar
    Yes the settings were all set correctly.

    Went to AT&T and was told everything seems to be working (phone shows that I am on the LTE network showing send and receive data). He switched the SIM to SIM slot 2 and again the same thing. We were going to try a new sim card however my dumb *** left my license at home so he couldn't do it (they apparently have to scan your ID to initiate a new sim). Might try back later.
    02-02-19 12:07 PM
  21. smasha132's Avatar
    sim was around a year old.
    02-02-19 12:33 PM
  22. Chuck Finley69's Avatar
    On side note, AT&T is really serious about privacy and fraud regarding customer accounts. I’ve had the same experience before too. I’m amazed how they actually swipe your ID and it then it allows rep full access to your account.
    02-02-19 12:39 PM
  23. Amaroni's Avatar
    Yes the settings were all set correctly.

    Went to AT&T and was told everything seems to be working (phone shows that I am on the LTE network showing send and receive data). He switched the SIM to SIM slot 2 and again the same thing. We were going to try a new sim card however my dumb *** left my license at home so he couldn't do it (they apparently have to scan your ID to initiate a new sim). Might try back later.
    Perhaps if you can try a new sim card it would at least eliminate this as an issue . The fact that the guy at AT&T seemed to suggest everything is working then there are 2 possibilities.... Either the sim or a fault in the device.
    02-02-19 12:40 PM
  24. Chuck Finley69's Avatar
    Perhaps if you can try a new sim card it would at least eliminate this as an issue . The fact that the guy at AT&T seemed to suggest everything is working then there are 2 possibilities.... Either the sim or a fault in the device.
    Besides trying out new AT&T SIM , go and get a TMobile SIM and set up a per minute prepaid account.. Test voice that way. It might be possible that you can use that way. Still not ideal but worth a try since you have device in hand. In a T-Mobile store, rep might even swap out SIM from demo model for testing purposes in hopes for a new account. Remember to bring your ID..... sorry I couldn’t resist...
    Jake2826 likes this.
    02-02-19 12:47 PM
  25. LesterIngham's Avatar
    I had the same experience today with AT&T. I get data and text but no voice. My voda sim that uses the T Mobile did work, but that's not my primary carrier for data. AT&T tried numerous things including changing the sim, but nothing worked, so I sent it back. I also tried to get help from Blackberry, but after I typed in the IMEI, I was told that Blackberry doesn't support that phone... and for further help click on a link that didn't work. Such a disappointment!!!
    Last edited by LesterIngham; 02-02-19 at 03:58 PM.
    02-02-19 03:47 PM
54 123

Similar Threads

  1. Unable to Update the System in BlackBerry Evolve
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 01-07-19, 08:45 PM
  2. Replies: 50
    Last Post: 10-27-18, 03:37 PM
  3. Which forum is No. 1 in the CB10?
    By Frank Wu2 in forum BlackBerry Passport
    Replies: 27
    Last Post: 10-19-18, 01:21 PM
LINK TO POST COPIED TO CLIPBOARD