1. wgmalcolm's Avatar
    Hi, wondered if I can pick anyone's brains for some help, please.
    Just bought a new DTEK 60 for my wife. She had her old phone at work so I got it up and running, updates, apps, etc etc. She comes home from work and I pop the SIM card in and nothing happened. I've rebooted, removed it, rebooted again, taken it and made sure it's in correctly and all the usual.
    Is this a known issue or just a dodgy phone?

    Posted via CB10
    09-27-17 05:45 PM
  2. rcab's Avatar
    by chance do you have to contact the carrier before it works properly?
    09-27-17 07:26 PM
  3. claytargets's Avatar
    is the SIM card for a supportive network, like AT&T or Tmobile?
    09-27-17 09:55 PM
  4. SandKicker760's Avatar
    Hi, wondered if I can pick anyone's brains for some help, please.
    Just bought a new DTEK 60 for my wife. She had her old phone at work so I got it up and running, updates, apps, etc etc. She comes home from work and I pop the SIM card in and nothing happened. I've rebooted, removed it, rebooted again, taken it and made sure it's in correctly and all the usual.
    Is this a known issue or just a dodgy phone?

    Posted via CB10
    Maybe an Ambassador or some other specialist for CB might chime in soon. I wish you and your wife luck with the BlackBerry experience.
    09-28-17 01:03 AM
  5. wgmalcolm's Avatar
    I don't think so. I'll check but I've never had to do that before with an unlocked phone. I'll give them a call though, thanks.

    Posted via CB10
    09-28-17 01:05 AM
  6. wgmalcolm's Avatar
    Sorry, can't seem to reply to the actual post I meant to reply to!
    I'll give the carrier a call, thanks for that. It's unlocked from CPW in UK, on Virgin. I've used BlackBerry for a very long time (SO struggling to leave my Passport and still hangin in there) and it's taken me an age to convince the wife to try BlackBerry Android (she was on Windows).
    There are five of us and we've all upgraded a few times. I've always just bought unlocked, popped in the SIM, been hunky dorey. So I'm wondering if this is an individual phone problem. But I thought I'd ask here in case there is anything obvious I am missing.
    Thanks for all the replies and sorry I can't seem to reply individually.
    Cheers.

    Posted via CB10
    09-28-17 01:10 AM
  7. OTCHRussell's Avatar
    you might try posting in the Get Help forum.
    I'm curious what you find out. I just popped my AT&T nano SIM into my unlocked Dtek60 and it worked.

    BB9000>Q10>Z10>Z30>Z30>Classic>Dtek50>Dtek60
    09-28-17 06:46 AM
  8. wgmalcolm's Avatar
    CPW said to take it to a branch for a diagnostic check. They are sending a new one. It's all odd as the phone recognised the SIM OK but just wouldn't connect to the network. They said it's a hardware issue (I kinda guessed that). Chap said it's like they forgot to insert an antenna. Dunno about that!
    Anyway, all sorted.
    Good thing, I guess, is that it did allow me a play about with a BlackBerry Android device so I also ordered a Keyone for myself. Gonna miss my Passport but it really is time to say bye bye.
    Hopefully the wife's replacement Dtek will be fine too.
    Thanks again.

    Posted via CB10
    09-28-17 07:09 AM

Similar Threads

  1. BBM for W8.1 on W10?
    By A Noise Annoys in forum General BBM Chat
    Replies: 15
    Last Post: 10-10-17, 08:01 AM
  2. Why don't all photos appear on apps ?
    By T_MONEY_TX in forum BlackBerry KEYone
    Replies: 2
    Last Post: 10-03-17, 10:01 AM
  3. Can I bock someone on WhatsApp?
    By emanuel julio in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 10-02-17, 04:06 PM
  4. New beta apps
    By gjh1978 in forum BlackBerry KEYone
    Replies: 50
    Last Post: 09-28-17, 11:53 AM
  5. Replies: 0
    Last Post: 09-27-17, 11:05 AM
LINK TO POST COPIED TO CLIPBOARD