1. BCITMike's Avatar
    I've had my DTEK60 for like 10 days or something. Been working fine. Was using it this evening and seemed fine. Turned off the display with power button and put it in my pocket. 20 minutes later, get to a restaurant and go to turn it on, and display won't come on. I can hold in power or power+voldown, but neither works. After say, 13 seconds or so, the bottom right corner of the screen will flash on for a split second with some jagged purple colour and turn off. Right now, I can see the screen occasionally trying to turn on for a split second without any button presses.

    I do not have debug mode enabled to backup with adb I don't recall what I said about Google backup. I'd hate to lose all my settings, apps and history that I've added since migrating from Z30, but I'm guessing the phone is pooched and will need to be RMA'd.

    I'm currently on a work trip where I really, really need the phone. Hotel wifi is crap and logs out and disconnects way faster than downloading the autoloader. I might be able to download on worksite, but that's not ideal.

    Anyone run into this and found a way out of this, other than autoloader or RMA? The phone had like 69% charge when I last saw screen on, and I plugged it in when I got back to the hotel. So I'm guessing power level might be back up closer to 100% and would take a long time for it to discharge on its own (seeing if a complete reboot might help?)

    When I get back from this work trip, I'd be home for less than 20 hours before leaving for Mexican vacation. So I was really looking forward to having this Android phone for the airline apps and what not. If the phone isn't likely to be physically broken, I would like to avoid RMA if at all possible. Since I can't force reboot into fastboot, I'm pretty certain its fubar.

    Thanks in advance for any tips on recovering this phone.
    12-07-16 12:19 AM
  2. Uzi's Avatar
    Have you try holding down power button for 32 seconds?
    12-07-16 12:22 AM
  3. BCITMike's Avatar
    Have you try holding down power button for 32 seconds?
    Just tried for 72 seconds. Screen flashed 6-7 times, but no power down, no reboot, and nothing that stays on screen for more than a split second.
    12-07-16 12:40 AM
  4. Uzi's Avatar
    Volume button + and - at the same time ?
    12-07-16 12:56 AM
  5. BCITMike's Avatar
    Volume button + and - at the same time ?
    Same result. So then I tried power + volUp, and the screen still flickers for split second, but this key combination flashes the red led momentarily before the screen flashes. Both volumes or power+voldown doesn't flash the red led. Not sure if that is an indication of anything.

    Since I can't get into fastboot, looks like the phone will need to be RMA'd.

    Thanks for the suggestions.
    12-07-16 01:08 AM
  6. SDTRMG's Avatar
    I'd contact blackberry support see if they can tell you anything to do.
    12-07-16 01:12 AM
  7. baldy3577's Avatar
    Mine went into a boot loop, and I wasn't backed up either.

    Called BlackBerry support and was told to reload the OS. Not much help.

    What is ADB? I'm still looking for a BB Link alternative.
    12-08-16 01:37 AM
  8. Divesh Korem's Avatar
    Hello, do anyone find Solution for this? I'm facing the same problem now
    06-07-17 11:39 PM
  9. tonythecanuck's Avatar
    I've had my DTEK60 for like 10 days or something. Been working fine. Was using it this evening and seemed fine. Turned off the display with power button and put it in my pocket. 20 minutes later, get to a restaurant and go to turn it on, and display won't come on. I can hold in power or power+voldown, but neither works. After say, 13 seconds or so, the bottom right corner of the screen will flash on for a split second with some jagged purple colour and turn off. Right now, I can see the screen occasionally trying to turn on for a split second without any button presses.

    I do not have debug mode enabled to backup with adb I don't recall what I said about Google backup. I'd hate to lose all my settings, apps and history that I've added since migrating from Z30, but I'm guessing the phone is pooched and will need to be RMA'd.

    I'm currently on a work trip where I really, really need the phone. Hotel wifi is crap and logs out and disconnects way faster than downloading the autoloader. I might be able to download on worksite, but that's not ideal.

    Anyone run into this and found a way out of this, other than autoloader or RMA? The phone had like 69% charge when I last saw screen on, and I plugged it in when I got back to the hotel. So I'm guessing power level might be back up closer to 100% and would take a long time for it to discharge on its own (seeing if a complete reboot might help?)

    When I get back from this work trip, I'd be home for less than 20 hours before leaving for Mexican vacation. So I was really looking forward to having this Android phone for the airline apps and what not. If the phone isn't likely to be physically broken, I would like to avoid RMA if at all possible. Since I can't force reboot into fastboot, I'm pretty certain its fubar.

    Thanks in advance for any tips on recovering this phone.
    Hold power button down constantly for 32 seconds, or until the device turns on, whichever comes first. This works when the phone freezes.
    06-08-17 08:01 AM
  10. tonythecanuck's Avatar
    Hello, do anyone find Solution for this? I'm facing the same problem now
    Hold power button down constantly for 32 seconds, or until the device turns on, whichever comes first. This works when the phone freezes.
    06-08-17 08:01 AM
  11. tonythecanuck's Avatar
    Have you try holding down power button for 32 seconds?
    This worked for me.
    06-08-17 08:02 AM
  12. BCITMike's Avatar
    This isn't a simple phone freeze. The phone is fubar.
    Perhaps you missed "After say, 13 seconds or so, the bottom right corner of the screen will flash on for a split second with some jagged purple colour and turn off. "

    I've held the power down for minutes... the hardware was bad.
    06-08-17 03:06 PM
  13. 312's Avatar
    Woke up this morning and discovered that my DTEK60 bricked itself overnight. Tried everything - no luck. Called Amazon and they've agreed to a refund. After problems with my Priv which caused me to lose hundreds of contact and now this, I think I may be permanently done. Really wish Hub+ would be brought to iOS.
    06-18-17 10:56 PM

Similar Threads

  1. Why doesn't Boost Mobile Blackberry 9670 ring on my end?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-08-16, 02:05 AM
  2. Any idea/fix for lacking of comma/period on the physical keyboard?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-07-16, 03:18 AM
  3. Replies: 0
    Last Post: 12-06-16, 11:43 PM
  4. why wont my phone charge or turn on?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-06-16, 10:15 PM
  5. How do I find the device pin on my priv.
    By o308ajamu in forum Ask a Question
    Replies: 1
    Last Post: 12-06-16, 06:12 PM
LINK TO POST COPIED TO CLIPBOARD