1. nucks26's Avatar
    I seem to be having issues with my home WiFi on my new DTEK60. I must admit, my home WiFi has never been the greatest, and I'm in the process of updating my router, but it seems any android device in my house has issues sustaining a connection for very long. My PRIV was also victim to this.

    However, specifically to my DTEK60, my WiFi will disconnect, and then the network won't even be found under the list of available networks. It's as if it has disappeared. My apple devices like my Mac and iPad never have wifi issues at all. I do not know what it is, but I've definitely narrowed this down to be an android device specific issue, and even worse on my DTEK60. Does anybody have any thoughts as to why this could be happening on my android devices versus any of my apple devices? It is weird, because my DTEK WiFi radio seems otherwise strong. It can pick up 5-7 other networks in my area that my apple devices cannot, yet it will not even show my own.
    12-08-16 09:31 PM
  2. anon(757282)'s Avatar
    I have two DTEK60 phones and use home wifi regularly. I have no issues. Have used my phone on various open wifi spots without issues too.

    Since you say you also had issues with the Priv on wifi, I think you need to look at the factor that is common to both phone issues: your wifi system. With your comment about your wifi system not being the best, you should look there. Router hardware or settings need attention. If the router is more than a couple years, you are due for a new one.

    Doesn't sound like a phone issue.
    12-08-16 11:15 PM
  3. Alain_A's Avatar
    I have two DTEK60 phones and use home wifi regularly. I have no issues. Have used my phone on various open wifi spots without issues too.

    Since you say you also had issues with the Priv on wifi, I think you need to look at the factor that is common to both phone issues: your wifi system. With your comment about your wifi system not being the best, you should look there. Router hardware or settings need attention. If the router is more than a couple years, you are due for a new one.

    Doesn't sound like a phone issue.
    But he has no problem with his apples
    12-10-16 02:41 PM
  4. nef1307's Avatar
    I used to have this same problem with my Z10 and Z30. And it was very frustrating. I feel your pain.
    Since going to dtek60 it has been excellent and always a good strong wifi 📶
    12-10-16 03:32 PM
  5. Mig Iver's Avatar
    I'm sure I read somewhere that the 60 searches for 5 G first. This of course requires a dual band router. Most Bluetooth devices run on 2.4 frequency so a smart dual band router will switch you to the best available frequency. My Z10 & Z-30 also jump to that band. For the record, I am using Asus RT-AC66U Gigabit Router. No problems on any devices.
    12-10-16 05:57 PM

Similar Threads

  1. Comma and capitalizes the N issue
    By muHeinze in forum General BlackBerry News, Discussion & Rumors
    Replies: 6
    Last Post: 12-14-16, 03:02 AM
  2. can i trade in my blackberry passport for a dtek60?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 12-08-16, 03:27 PM
  3. Replies: 2
    Last Post: 12-08-16, 02:03 PM
  4. Wifi issue after update
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-08-16, 08:28 AM
  5. dtek60 dead pixels?
    By ahmedhanif911 in forum BlackBerry DTEK60
    Replies: 2
    Last Post: 12-08-16, 12:17 AM
LINK TO POST COPIED TO CLIPBOARD