1. 1REDRUM's Avatar
    My wifes DTEK 60 is having issues while roaming in USA. Everything works fine in Canada but in the USA roaming Data will not work. All settings on the phone are the same as my DTEK 60. Both are with Telus.

    When I was in the USA in October I spent considerable time on the phone with Telus tech support but no luck.

    Any suggestions? Re install from the beginning?

    This happened after I sent back her phone to BlackBerry support due to her charging port not working. At that time when her phone came back software had to be updated / reloaded.

    Thoughts?
    02-12-18 08:41 AM
  2. 1REDRUM's Avatar
    she was in the USA earlier this month and it was still not working but had no time to call Telus while in the USA. we will be there again in March and really want data to work
    02-12-18 08:43 AM
  3. tickerguy's Avatar
    If the APN is correct it's your carrier; it is refusing the roaming data when the phone registers back through the system and your carrier authenticates it. Telus may be doing something wonky with IMEIs that is responsible for this.
    02-12-18 12:24 PM
  4. nrussell18's Avatar
    she was in the USA earlier this month and it was still not working but had no time to call Telus while in the USA. we will be there again in March and really want data to work
    Being from Windsor I head to Detroit often and have never had an issue with the phone. Before this Dtek60 I had a passport and had an issue but it was because of Bell's service. I had to get a cheap US plan just for a week, have you looked into that?
    02-14-18 08:31 PM
  5. 1REDRUM's Avatar
    Thanks. I will check the APN. Both of our phones have the same plan with Telus so that should not be it. perhaps Telus has the IMEI blacklisted for roamimg? what I should have done is switched sims and see if that did anything?
    02-15-18 06:47 AM
  6. Completing's Avatar
    Buy a local card with enough data service. Better than roaming and getting ripped of by CA and USA service providers.
    02-17-18 01:03 PM

Similar Threads

  1. Does DTEK60 charge while in fastboot menu? Please confirm.
    By moonflyer in forum BlackBerry DTEK60
    Replies: 3
    Last Post: 02-15-18, 05:47 PM
  2. HUB can no longer File emails after 2-7 update
    By jhimmel in forum BlackBerry HUB+ Suite
    Replies: 9
    Last Post: 02-15-18, 08:54 AM
  3. Telefono no enciende
    By Claudio Gambetta in forum BlackBerry DTEK50
    Replies: 4
    Last Post: 02-12-18, 05:07 AM
  4. KEYone on Verizon Wireless Mobil Data Issue
    By nvite in forum Ask a Question
    Replies: 3
    Last Post: 02-10-18, 09:46 PM
  5. 30 or 60 FPS for laggy app
    By Blemurdefender in forum BlackBerry KEYone
    Replies: 2
    Last Post: 02-05-18, 03:49 PM
LINK TO POST COPIED TO CLIPBOARD