1. SeanKent's Avatar
    Hi all,

    So I've set up my DTEK60 - it's absolutely amazing! One issue I have though, is that it can't seem to detect the WiFi at my work. My Passport is still connecting to it fine, and everyone else here can see and connect to the WiFi (including my Galaxy S5 that I was using temporarily), so would there be any particular reason why my DTEK60 can't see it?

    Posted via CB10
    11-03-16 09:16 AM
  2. DaFoxGrey's Avatar
    Is the work WiFi's SSID hidden?

    A lot of businesses, such as the one I work for, will set their WiFi network to not broadcast the SSID, so random "drive by" WiFi users wont try to connect.
    When your device is scanning for WiFi networks, a hidden one will not appear.
    But, if you manually connect to the WiFi network, by entering the SSID name, then you can log in and save it.
    From then on, the device will be able to auto-connect to it if so enabled.

    Try manually connecting to it, use the network SSID as you have it saved on your Passport.
    11-03-16 09:24 AM
  3. SeanKent's Avatar
    Is the work WiFi's SSID hidden?

    A lot of businesses, such as the one I work for, will set their WiFi network to not broadcast the SSID, so random "drive by" WiFi users wont try to connect.
    When your device is scanning for WiFi networks, a hidden one will not appear.
    But, if you manually connect to the WiFi network, by entering the SSID name, then you can log in and save it.
    From then on, the device will be able to auto-connect to it if so enabled.

    Try manually connecting to it, use the network SSID as you have it saved on your Passport.
    That's the first thing I thought of, but the WiFi isn't hidden in this case. I tried it on another phone which wasn't connected, and it's there ready to be connected to!

    I also tried to add it manually. I put the SSID, security stuff etc, all correctly too, but despite it going into my saved networks, it still doesn't connect. It's really odd to be honest

    Posted via CB10
    DaFoxGrey likes this.
    11-03-16 09:43 AM
  4. YeemanBB's Avatar
    Check if the WiFi frequency band is set to automatic.
    11-03-16 10:21 AM
  5. SeanKent's Avatar
    So I still haven't managed to sort this. I was thinking to do a factory reset while it's early to see if that helps. What's the best way to do this? Would it be through the phone's settings menu or better using an Autoloader?
    Last edited by SeanKent; 11-08-16 at 08:22 AM.
    11-06-16 04:46 AM
  6. SeanKent's Avatar
    Sorry to bump this thread, but this is an absolute mystery to me.

    I have no trouble connecting to any other router. About 10 different WiFi signals appear, just none of them the correct one from my work. No one else at work has any trouble finding and connecting to the router - and both my Passport and a Galaxy S5 I have at home connects perfectly fine. As mentioned, I can easily connect to any other signal anywhere else including home and another work site. It's just this phone can't connect to that particular router. I've even tried using the WPS button and that doesn't work. I've tried manually inputting the details, and that doesn't work. I've tried changing the frequency band etc. Nothing at all works! I don't really want to wipe the phone either, just to find out it still can't connect to the router.

    Has anyone encountered something like this? Should I contact BlackBerry (would they even be able to do anything?)
    11-08-16 08:27 AM
  7. Blackwidowman's Avatar
    Does not sound like its a phone issue since you can see other networks. See if other cell you have that connects can still see the network once you ask it to forget the network. If the network is set to broadcast on non US channels IE : channel 13 and your phone is a US variant it may not be able to see that channel.
    11-08-16 09:36 AM
  8. SeanKent's Avatar
    Does not sound like its a phone issue since you can see other networks. See if other cell you have that connects can still see the network once you ask it to forget the network. If the network is set to broadcast on non US channels IE : channel 13 and your phone is a US variant it may not be able to see that channel.
    I'll do that tomorrow, although I'm certain it will still be able to see the network.

    Interesting about not being able to see the channel - I bought the phone from Shop BlackBerry UK, but if it's a US variant is there anything I can do? Saying that, I should be able to just change the channel of the router if this is the case. I'll have a play around and see what I can do. Thanks
    11-08-16 10:24 AM
  9. Blackwidowman's Avatar
    Use an app like Wifi analyser it will show you the SSID and the channel being use regardless if its hidden. Yes put the channel to auto or change to another one.
    11-08-16 10:45 AM
  10. SeanKent's Avatar
    Use an app like Wifi analyser it will show you the SSID and the channel being use regardless if its hidden. Yes put the channel to auto or change to another one.
    Okay so I downloaded "Wifi Analyzer" from the Playstore. It had about 10 million downloads so seemed like a good one.

    It is pretty good, it shows all the channels for each connection etc, but still my work WiFi doesn't appear on the app. It REALLY is a mystery to me. I'm going to contact BlackBerry and see what they say.
    11-09-16 08:21 AM
  11. Blackwidowman's Avatar
    Is that network set up as ad-hoc?
    11-09-16 10:32 AM
  12. SeanKent's Avatar
    Just going to update this. I came to work this morning, and the phone automatically connected to the WiFi (I had manually put the details in last week). Neither I or anyone here changed the router settings. But, the only difference being, I now have a sim card in my DTEK60 which I didn't before - I was solely relying on WiFi.

    So, why would having a sim card with Internet access now allow me to connect to the WiFi, but without it I couldn't? Odd, but my problem is solved either way.
    11-14-16 03:09 AM
  13. danp2000's Avatar
    Maybe the access point / router was rebooted?

    Posted via CB10
    11-14-16 05:42 AM
  14. SeanKent's Avatar
    Maybe the access point / router was rebooted?

    Posted via CB10
    I tried that numerous times last week. It seems the only difference is that my phone has a sim card inside it. Anyway, no more problem but can't say it was ever solved!
    11-14-16 07:51 AM
  15. blackburberry's Avatar
    I tried that numerous times last week. It seems the only difference is that my phone has a sim card inside it. Anyway, no more problem but can't say it was ever solved!
    If it happens again, or to anyone else that experiences this issue, remove and reinstall your sim.
    11-14-16 04:19 PM
  16. Colemann84's Avatar
    I experienced similar problems on my BB Passport. I can successfully connect to the Wifi at my workplace, in the gym or even in the bank. Whenever I am at home and try to connect to my own Wifi I face constant problems. The Wifi is not hidden, it is visible and the signal is strong (the umbrella is full). Sometimes my BB manages to connect to the Wifi and works well, I can use the Internet smoothly but the last couple of days it is unable to connect to. I have no trouble connecting to any other router. My sister and brother use the same Wifi without any trouble. Why is that? This issue has not occured before. What can be the route of the problem? How can I solve it?
    11-02-17 09:08 AM

Similar Threads

  1. Where I can buy Dtek50 in Tamil Nadu, India?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-20-16, 06:27 AM
  2. can't open BBM
    By Ian Logan1 in forum BlackBerry DTEK50
    Replies: 2
    Last Post: 11-03-16, 09:46 AM
  3. Bb z3 not detecting sim card
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-03-16, 02:01 AM
  4. New Priv can't access BB Protect
    By Sir D in forum BlackBerry Priv
    Replies: 1
    Last Post: 11-03-16, 12:18 AM
  5. Can you somehow sideload Google play services?
    By ego_sum_spartacus in forum Ask a Question
    Replies: 2
    Last Post: 11-02-16, 08:36 PM
LINK TO POST COPIED TO CLIPBOARD