1. Guinnibles's Avatar
    My BBA100-2 (EMEA) only displays two preferred network types in settings:
    *4G&3G
    *4G&3G&2G

    Phone is on Freedom Mobile network (Canada) that has LTE coverage in my area either on AWS-1 (Band 4) and/or Band 7 (2500MHz).

    BlackBerry's spec sheet (https://us.blackberry.com/smartphone...specifications) says the BBA100-2 supports Freedom's LTE bands.

    Note: The LTE option seems to follow the SIM. LTE option available on BBA100-1/2 regardless of network availability with Roger, but not with Freedom.

    Help accessing LTE greatly appreciated.
    12-07-17 02:32 PM
  2. anon(2259524)'s Avatar
    "Note: The LTE option seems to follow the SIM. LTE option available on BBA100-1/2 regardless of network availability with Roger, but not with Freedom. "

    That's good to know. I am having the same issue with a freedom on my unlocked AT&T Blackberry Priv.

    I can confirm that it does work with LTE when selecting it in the 4563# menu, however it reverts back when making a call or restarting the phone.
    12-19-17 11:06 PM
  3. Gomark75's Avatar
    I also only have those two network selection with wind. I do see my signal switch to 4G LTE from time to time, their coverage still sucks.
    12-20-17 07:21 AM

Similar Threads

  1. Replies: 8
    Last Post: 12-23-17, 02:47 PM
  2. Kevin Missing In Action??
    By yamahammer in forum BlackBerry KEYone
    Replies: 37
    Last Post: 12-11-17, 10:43 AM
  3. keyone in a z10 oem holster anyone?
    By javelin in forum BlackBerry KEYone
    Replies: 3
    Last Post: 12-07-17, 09:42 AM
  4. BlackBerry and Qualcomm team up in next-generation connected vehicles
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 12-07-17, 09:30 AM
LINK TO POST COPIED TO CLIPBOARD