1. 9M-MRS1's Avatar
    Has anyone experienced this; DTEK60 does not charge even when plugged in to original charger or any charger at all? It only start charging when I restart the phone. Can anyone help?
    01-19-18 02:00 AM
  2. Dunt Dunt Dunt's Avatar
    Number of folks have had issues with the Power Systems on the DTEK60.

    Might try a factory rest.
    Is the phone under warranty, if so call BBMo.
    01-19-18 10:08 AM
  3. tonycanuck's Avatar
    Number of folks have had issues with the Power Systems on the DTEK60.

    Might try a factory rest.
    Is the phone under warranty, if so call BBMo.

    Unfortunately, the DTEK60 is defective. The device begins to fail around the ten-month mark. The battery is inadequate and the electronics are faulty.

    I have already sent mine back to the "authorized Alcatel Repair Centre" in my country (SBE Canada) twice. There was no improvement in performance, even after the battery had been replaced.

    Local independent repair shops have refused to repair the DTEK60, indicating that it is not the battery that is the problem, but rather the motherboard.

    I have initiated legal action. Presently in negotiation with the dealer for a refund or replacement.
    01-19-18 07:30 PM

Similar Threads

  1. Hub is having problems with downloading attachments
    By ulric-gc in forum General BlackBerry News, Discussion & Rumors
    Replies: 9
    Last Post: 03-21-18, 03:27 AM
  2. Replies: 4
    Last Post: 01-19-18, 05:32 AM
  3. Replies: 2
    Last Post: 01-18-18, 11:04 PM
  4. Is anyone having and issue with bluetooth?
    By Chakkita81 in forum BlackBerry KEYone
    Replies: 4
    Last Post: 01-18-18, 10:23 PM
  5. Replies: 1
    Last Post: 01-18-18, 04:14 PM
LINK TO POST COPIED TO CLIPBOARD