02-24-17 03:31 PM
36 12
tools
  1. Dat Gui's Avatar
    I've had 3 Dtek60 and all of them just feels kind of slow and sluggish considering their specs. I don't have any games on its, just social media like Facebook, snapchat, twitter, etc. Just using those and Firefox for my browser, the phone sometimes just freezes or becomes super slow. Anyone else noticing this?
    02-18-17 10:22 PM
  2. AmritD's Avatar
    I guess that is just super bad luck on your part!
    I have mostly read very positive reviews about the speed and the overall functioning of the phone

    Z30STA100-2/10.3.2.2876
    LoveMyLBZ likes this.
    02-18-17 10:51 PM
  3. trader69's Avatar
    I've had 3 Dtek60 and all of them just feels kind of slow and sluggish considering their specs. I don't have any games on its, just social media like Facebook, snapchat, twitter, etc. Just using those and Firefox for my browser, the phone sometimes just freezes or becomes super slow. Anyone else noticing this?
    I have the phone from the launch day and never had slow device or freeze. I reboot the phone once a day and make every update.
    LoveMyLBZ likes this.
    02-18-17 10:56 PM
  4. Carjackd's Avatar
    No issues here at all since launch day. I've had some sluggishness with a couple apps but noticed updates to those quickly after it happened (within a couple of days).
    02-18-17 11:19 PM
  5. roleli's Avatar
    02-19-17 05:35 AM
  6. Macdtek's Avatar
    No sluggishness here. Mind I'm not running and social media persey, just online news papers and music.
    02-19-17 09:23 AM
  7. dlmsd's Avatar
    I've had 3 Dtek60 and all of them just feels kind of slow and sluggish considering their specs. I don't have any games on its, just social media like Facebook, snapchat, twitter, etc. Just using those and Firefox for my browser, the phone sometimes just freezes or becomes super slow. Anyone else noticing this?
    Mine is very fast, had a PRIV and it feels snappier than that ever was, and stays way cooler, battery life is pretty darn good too. My wife has an iPhone 7, just as fast or faster in some cases, in fact I catch my her playing games on my 60 instead of her 7 due to the speed.
    My biggest gripe is the lack of quality accessories, cases, screen protectors. Seidio says they have no plans to make a case for it. Other than the little Android issues the Dtek60 is a great phone, just not marketed the way the big two market their products.
    02-19-17 12:00 PM
  8. SlcCorrado's Avatar
    Sluggish??? That's the last word I would use to describe the dtek60. Mine is lightning fast. Tons of apps and games installed and it never skips a beat.
    LoveMyLBZ likes this.
    02-19-17 12:08 PM
  9. danp2000's Avatar
    Sluggish?
    Every so often my DTEK60 does get Sluggish and a hard reboot is the only thing I've found to bring my phone back to normal.
    02-19-17 01:01 PM
  10. Macdtek's Avatar
    Mine is very fast, had a PRIV and it feels snappier than that ever was, and stays way cooler, battery life is pretty darn good too. My wife has an iPhone 7, just as fast or faster in some cases, in fact I catch my her playing games on my 60 instead of her 7 due to the speed.
    My biggest gripe is the lack of quality accessories, cases, screen protectors. Seidio says they have no plans to make a case for it. Other than the little Android issues the Dtek60 is a great phone, just not marketed the way the big two market their products.
    I've searched under alcatel idol 4s and its the same for the model as well.
    02-19-17 04:09 PM
  11. SlcCorrado's Avatar
    Every so often my DTEK60 does get Sluggish and a hard reboot is the only thing I've found to bring my phone back to normal.
    Glad I haven't come across that
    02-19-17 04:29 PM
  12. Irwin II's Avatar
    Sluggish??? That's the last word I would use to describe the dtek60. Mine is lightning fast. Tons of apps and games installed and it never skips a beat.
    I completely agree! Excellent device. Build quality is good and very responsive in my experience.
    LoveMyLBZ likes this.
    02-19-17 05:31 PM
  13. dirk_ddiggler's Avatar
    It takes me about 6-7 days of uptime for this to happen. And when it does happen, it feels like the phone hits a wall fairly quickly. I don't know if it's a memory leak, memory fragmentation, virtual memory issue, or maybe something else at the driver/kernel/OS level. A reboot is the only fix.

    And I am running very lean too with just a few Exchange accounts syncing, and no social media or news apps at all....

    For the folks who don't experience this, what's your typical uptime before a reboot?
    02-19-17 05:42 PM
  14. Irwin II's Avatar
    It takes me about 6-7 days of uptime for this to happen. And when it does happen, it feels like the phone hits a wall fairly quickly. I don't know if it's a memory leak, memory fragmentation, virtual memory issue, or maybe something else at the driver/kernel/OS level. A reboot is the only fix.

    And I am running very lean too with just a few Exchange accounts syncing, and no social media or news apps at all....

    For the folks who don't experience this, what's your typical uptime before a reboot?
    I'd say days, but don't know exactly as I haven't yet had a "need" to do a restart.
    02-19-17 05:47 PM
  15. dirk_ddiggler's Avatar
    I'd say days, but don't know exactly as I haven't yet had a "need" to do a restart.
    Can you avoid rebooting to see if you hit the wall eventually too?
    02-19-17 05:49 PM
  16. dlmsd's Avatar
    It takes me about 6-7 days of uptime for this to happen. And when it does happen, it feels like the phone hits a wall fairly quickly. I don't know if it's a memory leak, memory fragmentation, virtual memory issue, or maybe something else at the driver/kernel/OS level. A reboot is the only fix.

    And I am running very lean too with just a few Exchange accounts syncing, and no social media or news apps at all....

    For the folks who don't experience this, what's your typical uptime before a reboot?
    I have had mine for about a month and the only reboot was on the Feb 5 update. I have 121 apps, and run my phone pretty hard, no issues so far.
    LoveMyLBZ likes this.
    02-19-17 05:52 PM
  17. TI_Master's Avatar
    I run into this occasionally but a reboot sets it right for me.
    02-19-17 08:07 PM
  18. Dat Gui's Avatar
    I don't have to do a reboot. The phone will just become super slow or freeze and I'll just have to wait it out, usually two minutes or less and then it's normal.
    02-20-17 10:10 AM
  19. Bla1ze's Avatar
    I don't have to do a reboot. The phone will just become super slow or freeze and I'll just have to wait it out, usually two minutes or less and then it's normal.
    Mine only does that when using Snapchat, in all it's poorly coded glory. If you're using an adblocker for Chrome, that has come up as an issue that causes devices to lock up as well. Other than those two scenarios, I have had zero issues with my DTEK60.
    LoveMyLBZ likes this.
    02-20-17 07:39 PM
  20. Dat Gui's Avatar
    Mine only does that when using Snapchat, in all it's poorly coded glory. If you're using an adblocker for Chrome, that has come up as an issue that causes devices to lock up as well. Other than those two scenarios, I have had zero issues with my DTEK60.
    Yea I am a heavy snapchat user, so maybe I'll stop using it for a couple days and see if that does the trick.
    02-20-17 07:42 PM
  21. Irwin II's Avatar
    I don't use Snapchat at all so maybe that contributes to my not having those issues.
    02-20-17 07:49 PM
  22. DonZ10's Avatar
    Mine's been up 12 days currently with no performance issues.
    LoveMyLBZ likes this.
    02-20-17 07:51 PM
  23. Carjackd's Avatar
    Mine only does that when using Snapchat, in all it's poorly coded glory. If you're using an adblocker for Chrome, that has come up as an issue that causes devices to lock up as well. Other than those two scenarios, I have had zero issues with my DTEK60.
    Bla1ze any issue with your Bluetooth turning off....there are some in other threads talking about this and I've come across it myself in the last week.
    02-20-17 08:36 PM
  24. Bla1ze's Avatar
    Bla1ze any issue with your Bluetooth turning off....there are some in other threads talking about this and I've come across it myself in the last week.
    Not that I've come across but, I don't really use Bluetooth either often enough to possibly have noticed it.
    02-20-17 08:52 PM
  25. Carjackd's Avatar
    Ok it just something I've stumble across the last week or so...maybe since the Feb patch. I hop in my car in the morning and my Bluetooth is turned off, I turn it back on its good all day, next morning it's off again.
    02-20-17 08:56 PM
36 12

Similar Threads

  1. HD Voice on AT&T with DTEK60?
    By Drakkar NOiR in forum BlackBerry DTEK60
    Replies: 22
    Last Post: 03-04-17, 01:23 PM
  2. Social apps for Dtek60
    By mrbquick in forum BlackBerry DTEK60
    Replies: 6
    Last Post: 02-22-17, 05:30 PM
  3. Can I skip the tutorial after security wipe on Z3?
    By rcky1113 in forum Ask a Question
    Replies: 1
    Last Post: 02-20-17, 10:15 PM
  4. Replies: 2
    Last Post: 02-20-17, 09:20 PM
  5. Android apps not see the SD card
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 02-20-17, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD