1. Johnny Li's Avatar
    Hi, ever since I installed the latest security update, I've been getting annoying notifications when I use the camera. If I open the Blackberry Camera, my phone vibrates twice and I get a notification that says "Blackberry Camera accessed your camera".

    Does anyone know how to white-list apps so they don't produce this notification? Thanks.
    07-18-17 07:08 PM
  2. Bla1ze's Avatar
    Open DTEK, presumably where they're coming from, and go to Apps and Permissions. Find BlackBerry Camera, tap on it, then tap on the 'bell' that says NOTIFICATIONS. Disable them.
    07-18-17 07:19 PM
  3. Johnny Li's Avatar
    It didn't work. I set it to Block All and I'm still getting that notification.
    07-18-17 07:42 PM
  4. Centerman66's Avatar
    You have to go into each app and shut off notifications. A new bug.
    07-18-17 09:35 PM
  5. Johnny Li's Avatar
    I did, I went to Blackberry Camera and QR Scanner and turned off all notifications for each, but I'm still getting notifications.
    07-18-17 09:47 PM
  6. Johnny Li's Avatar
    Oh, I finally figured it out, I can't access it from settings, I have to click on the notification when it shows up to turn the notifications off... So strange...
    dbcoe likes this.
    07-18-17 09:51 PM
  7. SlcCorrado's Avatar
    Yeah... that was annoying. Easy fix though
    dbcoe likes this.
    07-18-17 09:53 PM
  8. Mig Iver's Avatar
    yeah, what a nuisance, grandson visiting hit the camera button in the sun and have no idea why my 60 is zapping out, never thought a pool party was so "insecure" , sheesh, that could be fixed. on the 50 to I think, wife was nagging about something but I wasn't really listening hehe.
    07-18-17 09:54 PM
  9. neefer's Avatar
    Oh, I finally figured it out, I can't access it from settings, I have to click on the notification when it shows up to turn the notifications off... So strange...
    Launch the DTEK app.

    Click on "Apps and permissions"

    The APPS "tab" loads by default. Select the PERMISSIONS "tab".

    Select "Camera".

    Select "NOTIFICATIONS".

    You will now have a list of apps, and the ability to enable / disable notifications for each one regarding if they have requested camera access. Or you can globally disable notifications for any app accessing the camera.

    Scroll down to "Blackberry Camera" and move the slider so it changes from blue to grey.

    Optionally, scroll through the rest of the list for any apps you know "should" be using the camera, and turn off those notifications as well, so that you are only notified of apps that might be trying to be sneaky.

    Click the back button, and now select PERMISSIONS (instead of NOTIFICATIONS).

    Here I've done the opposite of the permissions setup, meaning: everything is disabled (grey) except for the apps that I think should be allowed to use the camera (barcode scanner, BBM, Blackberry Camera, my online banking, my photos apps, etc.)

    Edited to Add: The above is based on the version of the DTEK app that is on my KeyOne. So your mileage may vary.
    07-20-17 01:55 PM
  10. chockster's Avatar
    Whew!!! Thanks everybody. I just came across this issue tonight while hastily trying to get a couple of quick pics of a couple of Deer that meandered in front of me while out on a bike ride. Problem solved, thanks.
    07-20-17 09:15 PM
  11. buzzer76's Avatar
    Go to camera settings and turn off geolocation. I had the same problem.
    07-30-17 06:58 PM
  12. tonythecanuck's Avatar
    Hi, ever since I installed the latest security update, I've been getting annoying notifications when I use the camera. If I open the Blackberry Camera, my phone vibrates twice and I get a notification that says "Blackberry Camera accessed your camera".

    Does anyone know how to white-list apps so they don't produce this notification? Thanks.
    Yes, I have exactly the same annoying notification since Ethernet June update!
    07-30-17 08:28 PM
  13. tonythecanuck's Avatar
    You have to go into each app and shut off notifications. A new bug.
    OMG, that's really bad!!
    07-30-17 08:28 PM
  14. tonythecanuck's Avatar
    Launch the DTEK app.

    Click on "Apps and permissions"

    The APPS "tab" loads by default. Select the PERMISSIONS "tab".

    Select "Camera".

    Select "NOTIFICATIONS".

    You will now have a list of apps, and the ability to enable / disable notifications for each one regarding if they have requested camera access. Or you can globally disable notifications for any app accessing the camera.

    Scroll down to "Blackberry Camera" and move the slider so it changes from blue to grey.

    Optionally, scroll through the rest of the list for any apps you know "should" be using the camera, and turn off those notifications as well, so that you are only notified of apps that might be trying to be sneaky.

    Click the back button, and now select PERMISSIONS (instead of NOTIFICATIONS).

    Here I've done the opposite of the permissions setup, meaning: everything is disabled (grey) except for the apps that I think should be allowed to use the camera (barcode scanner, BBM, Blackberry Camera, my online banking, my photos apps, etc.)

    Edited to Add: The above is based on the version of the DTEK app that is on my KeyOne. So your mileage may vary.
    This doesn't work: a message pops up saying "turn off screen overlays" which makes no sense.
    07-30-17 08:34 PM
  15. tonythecanuck's Avatar
    unfortunately every time I take a picture I get a notification message. Incredibly annoying! BlackBerry is truly finished.... very sad...
    07-30-17 08:39 PM
  16. terminatorx's Avatar
    You have to go into each app and shut off notifications. A new bug.
    I don't think it's a bug. But after installing the latest Dtek50 update, I too started receiving the notifications. I think somehow the security update reset some settings in the Dtek50 app relating to these notifications. Just disable as per the instructions noted, issue fixed. Not a big deal.
    07-30-17 10:52 PM
  17. tonythecanuck's Avatar
    I don't think it's a bug. But after installing the latest Dtek50 update, I too started receiving the notifications. I think somehow the security update reset some settings in the Dtek50 app relating to these notifications. Just disable as per the instructions noted, issue fixed. Not a big deal.
    It's not a bug; nothing will turn off the annoying camera notifications. Really annoying.
    07-31-17 05:12 AM
  18. terminatorx's Avatar
    It's not a bug; nothing will turn off the annoying camera notifications. Really annoying.
    It sounds like you're not following the instructions correctly to disable this. If you get the message about screen overlay detected, you should be presented with an option to temporarily disable the overlay so you can set the permission. Otherwise have a look at the following:

    http://support.blackberry.com/kb/art...mber=000038261
    07-31-17 08:43 AM
  19. tonythecanuck's Avatar
    It sounds like you're not following the instructions correctly to disable this. If you get the message about screen overlay detected, you should be presented with an option to temporarily disable the overlay so you can set the permission. Otherwise have a look at the following:

    http://support.blackberry.com/kb/art...mber=000038261
    Oh boy....
    07-31-17 09:35 AM
  20. tonythecanuck's Avatar
    After numerous attempts I seem to have been able to silence the camera notifications. Hurrah.
    07-31-17 09:37 AM

Similar Threads

  1. Blackberry Leap Camera
    By Mansuet in forum BlackBerry Leap
    Replies: 3
    Last Post: 07-20-17, 02:34 AM
  2. Notification issue after Jilly update
    By attaturk in forum BlackBerry KEYone
    Replies: 13
    Last Post: 07-19-17, 03:19 AM
  3. Awesome notification on priv
    By mad_orsi in forum BlackBerry Priv
    Replies: 6
    Last Post: 07-18-17, 01:24 PM
  4. Change LED color for text notification KEYONE
    By Jason Byers in forum BlackBerry Android OS
    Replies: 5
    Last Post: 07-18-17, 10:03 AM
  5. No Vibration for Notifications
    By gqmovement in forum BlackBerry KEYone
    Replies: 2
    Last Post: 07-17-17, 07:36 PM
LINK TO POST COPIED TO CLIPBOARD