1. Johnny Dollar's Avatar
    The headphone jack icon is on when nothing is plugged in and no sound is coming from the phone now. I've tried rebooting / restarting and I've tried a factory reset. Icon still comes up and no sound.

    So what can I do..if anything?? Thanks
    09-06-18 08:45 AM
  2. Dunt Dunt Dunt's Avatar
    Could try an electronics cleaner and a Q-Tip....
    09-06-18 09:04 AM
  3. Johnny Dollar's Avatar
    Update : The phone God's were smiling down upon me this morning as I turned on the phone and no headphone icon appeared and sound was coming from the phone again.

    Has this happened to anyone else? 3+ years I've had this phone and it's the first time I've seen this glitch. Just wanna know what to do in case it happens again and not go through a factory reset again TYVM.. Lol.
    09-06-18 11:16 AM
  4. StefLab's Avatar
    I had to replace the broken 3.5 mm earphones connector on my DTEK50
    Johnny Dollar likes this.
    09-14-18 05:33 PM

Similar Threads

  1. Replies: 7
    Last Post: 09-12-18, 01:37 AM
  2. How secure is the hub?
    By neil74 in forum BlackBerry HUB+ Suite
    Replies: 3
    Last Post: 09-10-18, 12:03 PM
  3. This site is such an amazing resource. Thank you for all the help!
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 09-07-18, 01:31 AM
  4. KEY2 is a.w.e.s.o.m.e
    By darkbull in forum BlackBerry KEY2
    Replies: 5
    Last Post: 09-07-18, 12:19 AM
  5. Java software on my BlackBerry Passport Silver edition
    By Suraj Singh9 in forum Ask a Question
    Replies: 1
    Last Post: 09-05-18, 04:29 PM
LINK TO POST COPIED TO CLIPBOARD