06-22-18 07:30 AM
109 ... 2345
tools
  1. jcbrunson's Avatar
    Another really bad side effect of this update will be turning off their "Find My Device" administration and failing to turn it back on after the update. A month from now they will misplace their DTEK or PRIV, won't be able to locate it or lock it out. As a forum faithful follower, I am making sure all the device security features for my family are turned on or restored after they are turned off. But the casual user will leave the "Find My Device" feature off after this update, and they won't even know that they intentionally turned it off when they truly need this feature.
    dpw09 likes this.
    12-22-17 07:44 AM
  2. GapBoyPCS's Avatar
    Last night the update came back up for me. I had to uninstall the updates to Google Play Services, as well, to make it work.

    It's strange how I had to do it for this update. Other updates on both my DTEK50 and Priv never needed the downgrade of Google Play Services. I hope this was a one-time fluke.
    12-22-17 08:25 AM
  3. dpw09's Avatar
    Last night the update came back up for me. I had to uninstall the updates to Google Play Services, as well, to make it work.

    It's strange how I had to do it for this update. Other updates on both my DTEK50 and Priv never needed the downgrade of Google Play Services. I hope this was a one-time fluke.
    Many have had to do it over the past 2-3 updates. This is the only one I had to do it on.
    12-22-17 08:28 AM
  4. Chuck Finley69's Avatar
    Another really bad side effect of this update will be turning off their "Find My Device" administration and failing to turn it back on after the update. A month from now they will misplace their DTEK or PRIV, won't be able to locate it or lock it out. As a forum faithful follower, I am making sure all the device security features for my family are turned on or restored after they are turned off. But the casual user will leave the "Find My Device" feature off after this update, and they won't even know that they intentionally turned it off when they truly need this feature.
    It's part of the instructions to follow... people should be able to not mess up simple instructions.
    12-22-17 08:47 AM
  5. jcbrunson's Avatar
    It's part of the instructions to follow... people should be able to not mess up simple instructions.
    Agreed, but you know how this goes. Install the update, restore Google Play services to the current version... then forget to reactivate the security features. I myself used the KB instructions to turn it back on for my household, but I'm betting there are even people on this forum that forgot to turn it back on...
    CDM76 likes this.
    12-22-17 08:53 AM
  6. HughJarsse's Avatar
    It's part of the instructions to follow... people should be able to not mess up simple instructions.
    Sure, but WHY should we have to follow a load of additional instructions, especially when there should be no need to if the update was properly configured in the FIRST place, and better still, in the SECOND ATTEMPT!! which STILL needs people to do some 'workaround' to get it to work!!??
    BB unable to even sort out their own updates to install correctly now!! WHY??
    CDM76 likes this.
    12-22-17 09:38 AM
  7. Chuck Finley69's Avatar
    We shouldn't and if you think it's a big deal just buy another brand. Just a phone.
    12-22-17 10:58 AM
  8. Chuck Finley69's Avatar
    Sure, but WHY should we have to follow a load of additional instructions, especially when there should be no need to if the update was properly configured in the FIRST place, and better still, in the SECOND ATTEMPT!! which STILL needs people to do some 'workaround' to get it to work!!??
    BB unable to even sort out their own updates to install correctly now!! WHY??
    We shouldn't and if you think it's a big deal just buy another brand. Just a phone.
    12-22-17 10:58 AM
  9. jellybeen's Avatar
    sounds like the security updates are not secure at all
    12-22-17 12:09 PM
  10. conite's Avatar
    sounds like the security updates are not secure at all
    How's that?
    12-22-17 12:11 PM
  11. jellybeen's Avatar
    can't verify...so
    12-22-17 12:15 PM
  12. conite's Avatar
    can't verify...so
    Sure it can. That problem was solved.

    Nor was it a security problem. Quite the opposite, it demonstrates that the device will not allow the installation of software without the correct signature (they were originally signed with carrier signatures instead of user signatures).
    CerveloJohn likes this.
    12-22-17 12:16 PM
  13. HughJarsse's Avatar
    We shouldn't and if you think it's a big deal just buy another brand. Just a phone.
    Which is exactly what I intend to do once these 'DIY updates' cease next year (or sooner if TCL/BB decide they can't be bothered to cobble them together)
    You say 'we shouldn't' and appear to think it's not a big deal. On it's own, probably not, but taken in account with all the other 'problems' that the Dtek's have suffered, it becomes more than I feel is acceptable..
    12-22-17 02:02 PM
  14. Chuck Finley69's Avatar
    Which is exactly what I intend to do once these 'DIY updates' cease next year (or sooner if TCL/BB decide they can't be bothered to cobble them together)
    You say 'we shouldn't' and appear to think it's not a big deal. On it's own, probably not, but taken in account with all the other 'problems' that the Dtek's have suffered, it becomes more than I feel is acceptable..
    I mean that it's not acceptable service wise but I don't worry about things like my phones other than basic function smartphones.
    12-22-17 02:39 PM
  15. Johnny Dollar's Avatar
    Christmas has indeed come early as the December update downloaded and installed on my DTEK50. I am at 1 with the world once again. Peace.
    12-23-17 11:52 PM
  16. Bethaloid's Avatar
    Device owned: DTEK50, STH100-2. Location: UK.

    As at 24-Dec-17, this issue is not resolved for me.
    I have both Google Play Services and Google Play Store disabled. I don't have the Find My Device app, but when I go to disable device administrators via Security, it (Find My Device) shows up and I can't untick the box (it says that Settings has stopped working, when it hasn't).
    Can anyone (without subjective opinion and unnecessary blah, blah, blah if possible) help me to resolve this? Going to Blackberry direct is fruitless and I find this site seems to be much more helpful and productive.
    Thanks in advance and Merry Christmas!
    12-24-17 05:04 AM
  17. Ethynil's Avatar
    Device owned: DTEK50, STH100-2. Location: UK.

    As at 24-Dec-17, this issue is not resolved for me.
    I have both Google Play Services and Google Play Store disabled.
    Play Store is not required to be disabled, only Play Services and if applicable, Find Device.

    Consider rebooting the phone and reinstating Play Store to rule out Play Store as being the issue.
    12-24-17 10:23 AM
  18. dpw09's Avatar
    Device owned: DTEK50, STH100-2. Location: UK.

    As at 24-Dec-17, this issue is not resolved for me.
    I have both Google Play Services and Google Play Store disabled. I don't have the Find My Device app, but when I go to disable device administrators via Security, it (Find My Device) shows up and I can't untick the box (it says that Settings has stopped working, when it hasn't).
    Can anyone (without subjective opinion and unnecessary blah, blah, blah if possible) help me to resolve this? Going to Blackberry direct is fruitless and I find this site seems to be much more helpful and productive.
    Thanks in advance and Merry Christmas!
    As mentioned store is not required. Only services. But it can't be disabled. It needs to be downgraded and enabled. So in short re-enable both and follow the Kb article link in your update screen to properly downgrade services only.
    12-24-17 10:29 AM
  19. Johnny Dollar's Avatar
    Yes YES you need to follow the instructions in the initial update. Uninstall Google services updates and temp disable (uncheck) the find my Phone (device administration's) then the security update will install. I did it last night and it installed successfully.
    Ethynil likes this.
    12-24-17 04:51 PM
  20. Bethaloid's Avatar
    Thanks Ethynil, dpw09 and Johnny Dollar.
    I've reenabled Play Services, reinstated Play Store, downgraded and rebooted. Unfortunately, it seems to make no difference. The option to update has now disappeared. Unistalling Play Services updates is not an option, and so the box for Find My Device in Security still prompts a 'Settings has stopped working' note and can't be unticked.
    So, no change!
    12-27-17 11:47 AM
  21. dpw09's Avatar
    Thanks Ethynil, dpw09 and Johnny Dollar.
    I've reenabled Play Services, reinstated Play Store, downgraded and rebooted. Unfortunately, it seems to make no difference. The option to update has now disappeared. Unistalling Play Services updates is not an option, and so the box for Find My Device in Security still prompts a 'Settings has stopped working' note and can't be unticked.
    So, no change!
    Try going to settings . About . Updates
    12-27-17 12:58 PM
  22. oldoz56's Avatar
    I've been trying to work through this on my wife's dtek50 also. Gone through it step by step a dozen times. I can't uncheck the Find My Device box either. I get the settings has stopped working message. I'll monitor forum for some kind of solution.

    Posted via CB10
    12-27-17 02:57 PM
  23. jcbrunson's Avatar
    I've been trying to work through this on my wife's dtek50 also. Gone through it step by step a dozen times. I can't uncheck the Find My Device box either. I get the settings has stopped working message. I'll monitor forum for some kind of solution.

    Posted via CB10
    Try turning it off by going to settings, security, device administration, then tap on "find my device" and hit "deactivate". Give it a shot. Remember to re-enable it after the update.
    12-27-17 04:41 PM
  24. oldoz56's Avatar
    Already tried that route too. Same behavior.

    Posted via CB10
    12-27-17 04:54 PM
  25. pgg101's Avatar
    I've tried and tried. carefully followed the steps but I can't get the update to install. I think I will wait and update my wife's D50 to Pixel 2 on her bday. I don't know how or why they think people are going to jump through a million steps just for an update. Whatever they did to the December update, they truly messed up the D50.
    HughJarsse likes this.
    12-27-17 05:41 PM
109 ... 2345

Similar Threads

  1. BBM for Android: Emtek brought new emojis
    By skrble in forum General BBM Chat
    Replies: 28
    Last Post: 01-01-18, 04:56 PM
  2. Couldn't Update - System Update - Help please -
    By Googey in forum BlackBerry Priv
    Replies: 11
    Last Post: 12-18-17, 09:00 AM
  3. Replies: 2
    Last Post: 12-15-17, 09:51 PM
  4. my blackberry dek 50 is stuck in the boatloader
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-15-17, 06:09 PM
  5. Replies: 0
    Last Post: 12-15-17, 03:02 PM
LINK TO POST COPIED TO CLIPBOARD