1. Rrrr7's Avatar
    Hi guys,
    I don't know why but since yersterday my DTEK50 connects to my usual Wifi networks but says "Connected, no internet access". It does this on my usual home networks WICH WORK 100% because I have other devices including my old Q10. It also does it on other networks wich also work 100%. I tried forgetting those networks, rebooting the phone, rebooting the router, nothing. What the hell?
    Oh, and to make things more interesting, I disabled the Cellular Data and guess what, I can actually access the Internet just fine on the Wifi networks in question, even though it says "Connected, no Internet".

    I disabled data limit and warning also.

    AAI795
    Patch level January 2017
    02-11-17 09:20 AM
  2. Johnny Dollar's Avatar
    Ok 2 things...

    Since this just happened recently I would speak to your cell provider/home provider re: any recent network problems or changes. 2. Download and run BlackBerry Virtual Expert to test your phones wifi.

    Oh, maybe Restart the phone.

    Good luck.
    02-11-17 12:09 PM
  3. YeemanBB's Avatar
    Try switching off Aggressive WiFi to cell data handover (under Settings>Developer mode) if it is switched on. Developer mode can be made accessible by tapping several times rapidly on the Build number of your phone under Settings>About Phone.
    02-11-17 12:34 PM
  4. dimmi10's Avatar
    Try to go to wifi settings on your dtek50 and choose help and feedback. That helps me
    02-11-17 04:36 PM
  5. Rrrr7's Avatar
    Ok 2 things...

    Since this just happened recently I would speak to your cell provider/home provider re: any recent network problems or changes. 2. Download and run BlackBerry Virtual Expert to test your phones wifi.

    Oh, maybe Restart the phone.

    Good luck.
    Hi, i did several restarts including the networking equipment. I'm actually writing this on my home wifi but with the notification in the status bar, as I said the internet connection works but the phone thinks it's not.
    I don't see what it has to do with my carrier, I have unlimited plan anyways.
    It does work correctly on some wifi networks!
    Virtual expert shows everything is okay.
    02-11-17 05:54 PM
  6. Rrrr7's Avatar
    Try switching off Aggressive WiFi to cell data handover (under Settings>Developer mode) if it is switched on. Developer mode can be made accessible by tapping several times rapidly on the Build number of your phone under Settings>About Phone.
    Hi, did just that. Aggressive wifi to cell data was off though. No change.
    02-11-17 05:55 PM
  7. Rrrr7's Avatar
    Try to go to wifi settings on your dtek50 and choose help and feedback. That helps me
    I can't seem to find help and feedback, I only see help, which sends me to some blackberry help and faq website.
    02-11-17 05:56 PM
  8. zoom6628's Avatar
    I tried the solution on my brand new DTEK60 purchased yesterday
    Instructions at end of this page network programming - android 6.0.1 force wifi connection with no internet access - Stack Overflow
    Seems this is an Android 6.0 issue and not a DTEK issue. Copied below for convenience.

    Reboot phone, connect to the non-Internet Wifi;
    Go to Settings and create a new user;
    Continue, continue, and continue until you see "Checking connection";
    As soon as you see "checking connection", switch off your phone;
    Switch on your phone again, you will be in "Owner" user, keep it;
    Toggle Wifi, and the exclamation mark should disappear quickly
    Remove that new user or just leave it there;
    02-13-17 05:30 PM
  9. Rrrr7's Avatar
    I tried the solution on my brand new DTEK60 purchased yesterday
    Instructions at end of this page network programming - android 6.0.1 force wifi connection with no internet access - Stack Overflow
    Seems this is an Android 6.0 issue and not a DTEK issue. Copied below for convenience.

    Reboot phone, connect to the non-Internet Wifi;
    Go to Settings and create a new user;
    Continue, continue, and continue until you see "Checking connection";
    As soon as you see "checking connection", switch off your phone;
    Switch on your phone again, you will be in "Owner" user, keep it;
    Toggle Wifi, and the exclamation mark should disappear quickly
    Remove that new user or just leave it there;
    I'll try that! Thanks!
    02-14-17 04:19 PM
  10. Rrrr7's Avatar
    The problem seems to have disappeared by itself. After about four days with the issue I noticed the wireless started to work normally again.

    I also got the February patch yesterday so now it's hard to know what exactly fixed it.
    02-18-17 03:45 PM

Similar Threads

  1. Fast charging on dtek50 and battery life etc
    By Rarefrith in forum BlackBerry DTEK50
    Replies: 7
    Last Post: 03-26-17, 09:43 PM
  2. We know the launch date, but when is ordering&shipping?
    By Kaizerin in forum BlackBerry KEYone
    Replies: 79
    Last Post: 02-23-17, 11:12 AM
  3. Fast Charge DTEK50
    By DanielCostaRJ in forum BlackBerry DTEK50
    Replies: 4
    Last Post: 02-14-17, 11:54 AM
  4. Can't no longer like a comment on the forum on CB10 app
    By Q10Bold in forum Site and App Feedback & Help
    Replies: 5
    Last Post: 02-11-17, 04:52 PM
  5. Regretfully having to say bye
    By Flo de Bretagne in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 02-10-17, 08:05 PM
LINK TO POST COPIED TO CLIPBOARD