1. T_Hume's Avatar
    I have had my Dtek50 for almost a year now, liked it until recently when my audio jack broke.

    It can still play audio, but the port itself cannot secure my headphones (i.e. it doesn't "snap" or "click" when I plug it in). I use the same headphones for my laptop so I know it's not the headphones.

    Can I get this fixed or do I have to wait to get a new phone?

    Thanks in advance!
    02-26-18 01:52 PM
  2. Bla1ze's Avatar
    Can I get this fixed or do I have to wait to get a new phone?
    Probably. It's not as if the parts don't exist. Just a matter of finding a spot to do it and deciding if their cost is worth it.
    02-26-18 06:16 PM
  3. planetbollox's Avatar
    My Dtek50 audio jack is developing the same issue, I have had my Dtek50 just over a year. Perhaps there is a design weakness or is this just coincidence?
    03-08-18 02:46 AM
  4. falbo's Avatar
    How about using a Bluetooth headphone instead. I use this and it's great

    Posted via CB10
    Johnny Dollar likes this.
    03-08-18 10:21 AM
  5. Johnny Dollar's Avatar
    I use wireless headphones for this exact reason of not wearing out the jack.
    03-08-18 09:18 PM
  6. planetbollox's Avatar
    I would use wireless headphones but it does rankle that after I had paid out good money for Bose headphones just to use with my phone, I can no longer use them.
    04-07-18 04:26 AM
  7. Susmitsingh Pawade's Avatar
    same problem comes in dtek60.
    08-18-18 02:58 PM

Similar Threads

  1. Notifications not in Hub
    By offray in forum BBM on Android
    Replies: 3
    Last Post: 03-02-18, 02:19 PM
  2. Why Blackberry Keyone Keyboard not responding after update
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-26-18, 11:36 AM
  3. Google and BB voice not active long
    By Soapm in forum BlackBerry KEYone
    Replies: 0
    Last Post: 02-24-18, 11:40 PM
  4. Can a Blackberry Dtek50, bought in India, be used in Europe too ?
    By CrackBerry Question in forum BlackBerry DTEK50
    Replies: 1
    Last Post: 02-24-18, 08:30 AM
  5. hub favourites not populating email address
    By tthieman in forum BlackBerry HUB+ Suite
    Replies: 1
    Last Post: 02-23-18, 06:40 PM
LINK TO POST COPIED TO CLIPBOARD