1. nick903's Avatar
    Not sure anyone have meet this problem or anything I have set it wrong. I have plug my Dtek 50 into different charger (and even portable charger). And I also try use different charger and it appears that I can't charge the phone at office. But I am ok to charge it at home?
    Any ideas? Or any setting I have set it wrong ?

    I am using priv before but it never got any charging problem with the same group of chargers.
    Attached Thumbnails Dtek 50 charging issue - can't charge at office-screenshot_20170328-195913.jpg  
    03-28-17 08:03 AM
  2. Dunt Dunt Dunt's Avatar
    You have used a number of different chargers and no of them function at work?

    What about your workmates, do those chargers work on their phones or their chargers work on yours?
    03-28-17 08:47 AM
  3. Johnny Dollar's Avatar
    Does the outlet your using to charge at work actually work? Dumb questions you need to ask sometimes.
    03-28-17 10:13 AM
  4. falbo's Avatar
    Might try testing out that charger lead if you also use it with the portable charger to charge the phone :-)
    03-28-17 12:09 PM
  5. nick903's Avatar
    Luckily, One of the portable battery can charge it when it drop to below 30%, it that means I have to bring it all the time with me?,
    Very strange, I bring back the charger (charger for Passport SE), it can charge at home, but not at office.

    Using Dtek50 for a week, think it is pretty smooth and the battery life is ok. The only thing I missing on Priv is the slightly better back camera (and slow motion video which I seldom use it). And my free memory on the phone is gone to 3.5Gb now, not happy about that.

    Other than that, everything is fine. Strange that I have get used to the white LED, as I haven't the red led for so many years. And it is also strange that I have finally get used to the virtual KB after used Priv. And unfortunately my main KB is Google Cantonese keyboard as I like the Swype keyboard and also can type Chinese + emoji at the same time.

    So, the only reason I stay in BlackBerry is because the Hub and the security and also long time relationship with BB😛
    03-28-17 01:40 PM
  6. BerrySpawn's Avatar
    So the same charger and USB cable works at home but not at the office? The zigzag in your pic seems to indicate it is plugged in. Did you try using an app (like Ampere) to check what kind of current charge/discharge rate you are getting? Could it be that at the office, you are farther away from a cell tower so power drain is higher. Or perhaps you are connected to a Bluetooth device at the office but not at home so again draining more power. Having said that, the stock charger should have a charging rate still higher than the drain rate.
    03-28-17 02:15 PM
  7. nick903's Avatar
    So the same charger and USB cable works at home but not at the office? The zigzag in your pic seems to indicate it is plugged in. Did you try using an app (like Ampere) to check what kind of current charge/discharge rate you are getting? Could it be that at the office, you are farther away from a cell tower so power drain is higher. Or perhaps you are connected to a Bluetooth device at the office but not at home so again draining more power. Having said that, the stock charger should have a charging rate still higher than the drain rate.
    Yes, same charger. Downloaded Ampere, it looks strange, it will charge a little bit and showing discharging but the right top battery logo are still showing charging .
    Attached Thumbnails Dtek 50 charging issue - can't charge at office-screenshot_20170330-142342.jpg  
    03-30-17 02:30 AM

Similar Threads

  1. Can you help me retrieve lost contacts and photos from Classic?
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 03-28-17, 01:51 PM
  2. Where can i buy a new Bold 9900 or Bold 9780 ?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-28-17, 08:27 AM
  3. Replies: 2
    Last Post: 03-27-17, 04:52 PM
  4. Replies: 1
    Last Post: 03-27-17, 04:34 PM
  5. Replies: 1
    Last Post: 03-27-17, 02:56 PM
LINK TO POST COPIED TO CLIPBOARD