1. jddbeyondthesky's Avatar
    My phone will appear to start up when I plug it in to charge, stop starting and have the full screen battery indicator appear and look like its charging from 1%, and then it just sits there, white light on, doing nothing.

    What is it and what can I do?
    06-27-17 09:07 AM
  2. 1122334455667788's Avatar
    Have you tried a different USB cord?
    06-27-17 09:53 AM
  3. bikeboy1's Avatar
    My phone will appear to start up when I plug it in to charge, stop starting and have the full screen battery indicator appear and look like its charging from 1%, and then it just sits there, white light on, doing nothing.

    What is it and what can I do?
    Just wondering if you came up with a solution to this problem as my phone is doing the same thing only it will eventually charge but takes longer than normal. Also tethering keeps disconnecting while the charging shows connected/disconnected.
    08-27-17 10:09 PM
  4. Froboy817's Avatar
    I had to go to using only Blackberry USB cords. I was having charging problems with another brand.
    08-31-17 12:21 PM

Similar Threads

  1. Replies: 13
    Last Post: 06-27-17, 07:00 PM
  2. whatapps messages not displayed on BlackBerry keyone BlackBerry hub
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-17, 09:13 AM
  3. BlackBerry Passport bbm videocall not available.why?
    By Alfred T Jose in forum Ask a Question
    Replies: 2
    Last Post: 06-27-17, 04:08 AM
  4. List of play store apps not showing
    By Diogo Cardoso in forum Ask a Question
    Replies: 1
    Last Post: 06-26-17, 05:03 PM
  5. Does the Keyone really have a different charge plug than the Classic?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 06-26-17, 03:49 PM
LINK TO POST COPIED TO CLIPBOARD