1. Rrrr7's Avatar
    Hi,
    Anyone have issues with Bluetooth devices not reconnecting automatically after switching Bluetooth on or off on the Dtek?

    I have a Plantronics M50 connected to both my old Q10 and Dtek50, but if the Dtek loses the connection be it because I go out of range, or I turn off the headset, it doesn't reconnect automatically, I have to either re-pair the headset every time or trying several reconnection attempts.
    The Q10 off course works perfectly.

    This is the second issue I noticed on this Android BlackBerry, I'm starting to miss the old OS10 a lot, it just worked flawlessly.
    02-21-17 06:31 PM
  2. Bla1ze's Avatar
    This seems to be a problem introduced in the Feb. update. Is that what you are on?
    02-21-17 08:16 PM
  3. SlcCorrado's Avatar
    This seems to be a problem introduced in the Feb. update. Is that what you are on?
    Weird. We have a 50 and a 60 in the house, and neither seem to have this problem with our Gear S2's
    02-21-17 08:45 PM
  4. Bla1ze's Avatar
    Weird. We have a 50 and a 60 in the house, and neither seem to have this problem with our Gear S2's
    I haven't had any issues with it either, but it seems others have.

    http://forums.crackberry.com/blackbe...91/index2.html
    02-21-17 08:47 PM
  5. Rrrr7's Avatar
    This seems to be a problem introduced in the Feb. update. Is that what you are on?
    Yes, Feb update.

    After several pairings, headset resets, re-pairings and so I managed to get the Dtek reconnecting to the headset when headset is turned on, re-entering the range or when I turn off and on bluetooth on the phone, so far seems ok (let's see how long).

    BUT

    What I noticed is that if I leave the room and get a distance until it loses the connection, then get back and it auto-reconnects, calls have distorted audio, stuttering. This only happens on calls with the Dtek, the Q10 works perfectly. I have to turn on and off the headset in order to hear the person I'm talking with and vice-versa.
    02-22-17 07:21 AM
  6. Ethynil's Avatar
    My DTEK50 is paired with three different (relatively new) devices, that I tested using the described scenarios and reconnect worked on each as expected.

    Would the described issue have anything to do with Bluetooth versions on the paired devices, perhaps?
    02-22-17 09:00 AM
  7. dvmblues's Avatar
    I have the same error, with the UPDATE in february, if I turn off the device, when starts, I have to active bluetooth.
    02-23-17 05:11 AM
  8. Rrrr7's Avatar
    Is there a BlackBerry bug reporting system somewhere, so we can file bug reports?

    P.S: Today I had a lot of calls using my Plantronics M50 headset being in the car almost all day and there is definitely a problem with Dtek50 and it's bluetooth connection to headsets, I barely managed to talk using the headset and had to go back to my Q10.
    02-23-17 08:03 AM
  9. Ethynil's Avatar
    A bit more detail describing the unexpected behavior might help diagnose the problem:

    if I turn off the device,
    Do you mean turning OFF the DTEK50 or turning OFF the remote bluetooth device?

    I have to active bluetooth.
    Is the bluetooth setting turned OFF on the DTEK50 and needs to be turned back on after restart, and is the remote bluetooth device still showing on the list or available devices, or does it need to be re-paired or just reconnected if it already listed?
    02-23-17 08:22 AM
  10. dvmblues's Avatar
    Hello, I say that if I reboot device, Bluetooth is disable and I have to enable,turn on, and sometimes connect automatically and others I have to connect manual devices that always were connected like car Bluetooth.
    02-24-17 02:07 AM
  11. kitmo's Avatar
    Since the February security update, my DTEK50 will not stay on Bluetooth. I have to keep going into setting to turn it on. It came to my attention when my phone wouldn't sync with my Ford C-Max Energi.
    03-08-17 11:42 AM
  12. kitmo's Avatar
    I got the new March security update, and the problem with Bluetooth is still there.
    03-11-17 11:45 AM
  13. Ethynil's Avatar
    Since the February security update, my DTEK50 will not stay on Bluetooth.
    I would suggest reviewing the apps you installed since the problem first occurred. I experienced some bizarre interaction from a poorly written app that affected bluetooth operation as well as other basic function settings on my DTEK50 as well as on another Android device (same app).

    At the time, I removed one app at a time to rule out which one was at fault, until I discovered the culprit. It happened to be one of the accessory apps associated with Avast (not Avast Mobile Security itself, but one of the separately downloaded accessories)

    Both my DTEK50's are paired with three separate bluetooth devices and each connects as expected (March update installed)
    03-14-17 01:39 PM
  14. kitmo's Avatar
    Thanks Ethynil. I will try what you did. I read this and assumed my DTEK 50 was maybe experiencing the same issues and it was a google problem. [Update: Fix coming soon] Bluetooth randomly turning itself off on some devices, including the Pixel and Pixel XL

    But maybe it is what you say.
    03-14-17 08:35 PM
  15. Ethynil's Avatar
    I read this and assumed my DTEK 50 was maybe experiencing the same issues and it was a google problem
    Maybe it is..I was not aware of the published issue. However, efficient troubleshooting involves ruling out all possible known issues in order to find the causative issue.

    Will be interesting to know your findings.

    Thanks for the article.

    Steve
    03-15-17 08:40 AM
  16. kitmo's Avatar
    Maybe it is..I was not aware of the published issue. However, efficient troubleshooting involves ruling out all possible known issues in order to find the causative issue.

    Will be interesting to know your findings.

    Thanks for the article.

    Steve
    I have gone through all my apps. I did uninstall three that were new since my problems with Bluetooth. One was a radio am app, one find my fitbit app, and a business card photo app. I will let you know how long I stay connected to Bluetooth lol.

    So far so good with getting rid of the 3 apps. My phone has stayed on Bluetooth for the last 3 or 4 hours. Before it would go off Bluetooth within an hour or so. So Steve your solution may work for me. I check back in the morning as an overnight test will be best.
    Last edited by kitmo; 03-15-17 at 07:24 PM. Reason: Update
    03-15-17 01:58 PM
  17. kitmo's Avatar
    Ethynil (Steve),
    Uninstalling the 3 apps that were new on my phone over the last month or so, seems to have corrected my Bluetooth problem! Thanks for your help.

    Laurel
    03-16-17 10:28 PM
  18. Ethynil's Avatar
    Uninstalling the 3 apps that were new on my phone over the last month or so, seems to have corrected my Bluetooth problem! Thanks for your help.
    That's great to hear, Laurel! I had a similarly perplexing situation last summer with another phone, which curiously duplicated itself on my new DTEK50. That's what tipped me off at the time to investigate a possible troublesome app.

    By process of elimination, I discovered one of the Avast accessories to be the culprit, as I explained earlier.

    Until that experience, I never thought to look for app/app interference when a basic Android would behave unexpectedly. The interesting part of the discovery is that the feature adversely affected may not have any relevance or connection to the errant app.

    Makes life interesting!

    Best!

    Steve
    03-18-17 01:07 PM
  19. adonesc's Avatar
    Hi,
    Anyone have issues with Bluetooth devices not reconnecting automatically after switching Bluetooth on or off on the Dtek?

    I have a Plantronics M50 connected to both my old Q10 and Dtek50, but if the Dtek loses the connection be it because I go out of range, or I turn off the headset, it doesn't reconnect automatically, I have to either re-pair the headset every time or trying several reconnection attempts.
    The Q10 off course works perfectly.

    This is the second issue I noticed on this Android BlackBerry, I'm starting to miss the old OS10 a lot, it just worked flawlessly.
    I downloaded all the OS updates on my mom's DTEK50 and today connected her phone via Bluetooth to her car. It only took a few minutes, no problems there...

    Respect My Autoritah!
    03-21-17 07:02 PM

Similar Threads

  1. Bluetooth keeps shutting itself down
    By raxamillion in forum BlackBerry DTEK60
    Replies: 21
    Last Post: 03-12-17, 10:09 AM
  2. Camera switch button doesn't work anymore
    By Koekiemonster in forum BlackBerry Priv
    Replies: 6
    Last Post: 02-24-17, 01:00 AM
  3. Channel doesn't exist
    By spookyentertainment in forum Discover BBM Channels
    Replies: 1
    Last Post: 02-20-17, 02:38 PM
  4. How do I back up my Q10 now that Link doesn't work with Sierra OS?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-20-17, 02:04 PM
  5. Replies: 9
    Last Post: 02-20-17, 08:35 AM
LINK TO POST COPIED TO CLIPBOARD