1. Massif's Avatar
    I've been struggling with a power cycling curve for the last 2 days. The same issue happened to me a few weeks ago and I fixed it by downgrading to OS 4.3 and then re-installing 4.5. However, just yesterday it started again. This time the downgrade/upgrade technique does not work.

    I'm beginning to think that this isn't even software related since now my device has been completely wiped and continues to power cycle. I got it to the 507 screen and ran "javaloader -usb resettofactory" from there. After it rebooted, the "Wiping" screen came up and completed. I've taken out my micro-sd card in case that was the problem, but no luck.

    Is there any chance this is still a software issue? Is there a way to do an even deeper wipe on the device?
    06-17-10 03:24 PM
  2. pkcable's Avatar
    Moisture damage?
    06-17-10 03:35 PM
  3. jwebste9's Avatar
    When in doubt hit it with a hammer! Just kidding. I would be leanign towards hardware issue if wiping it clean did not help, such as moisture as pkcable suggested
    06-17-10 03:40 PM
  4. Massif's Avatar
    I really hope it's not that. I've had 2 other curves I had to replace because of moisture damage. Both of those just had weird keyboard issues afterwards, but nothing like this. At this point it's probably too late to do the baggie full of rice trick...
    06-17-10 03:47 PM
  5. syedreza's Avatar
    Hi Massif,

    When you replaced the previous curves, did you change the battery?

    I think that this issue might be a hardware issue with your battery. Maybe try another battery?
    06-17-10 04:17 PM
  6. Massif's Avatar
    syedreza,

    Actually it's been the same battery across all 3 phones. I'll try putting a different battery in.
    06-18-10 08:33 AM
  7. Massif's Avatar
    Hmmm, no luck. Different battery, same issue.
    06-18-10 08:43 AM
  8. pkcable's Avatar
    Almost GOT to be hardware, since the problem keeps coming back, some sort of secordary board must be failing.


    EDIT: Come on deep down inside you've been wanting a Storm2 or a 9700. Now might be the time.
    06-18-10 08:48 AM
  9. Massif's Avatar
    Yeah, I think this weekend I'll bite the bullet and go buy another curve online. Still another 10 months left on my contract and I'm not quite ready to sign another one just yet...
    06-18-10 08:50 AM
  10. MrObvious's Avatar
    I would wait because there are a couple newer BBs coming out that look promising like the 9800 slider. If it wasn't on GayT&T I would buy it. I already hate their DSL service. </rant>
    06-18-10 12:03 PM
  11. Massif's Avatar
    I left it sitting at the 507 error screen for several hours unplugged with the battery in. After doing that I was able to re-install OS 4.5 without a hitch. I restored all of my backup up data to the device, disconnected it from the computer...and then it power cycled again. It gives me a tiny bit of hope and then tears it away!

    *EDIT* Upon further use, I've managed to reinstall App World, Facebook, Twitter and BBM without a reboot... Maybe it will survive another 3 weeks...

    *EDIT* And it's rebooting again...but soft rebooting this time. It goes back to the screen it was previously on after it's rebooted...
    Last edited by Massif; 06-18-10 at 03:20 PM.
    06-18-10 02:33 PM
LINK TO POST COPIED TO CLIPBOARD