1. thang14k's Avatar
    Hello everyone,

    My Javelin 8900 went to white screen while I can receive call! I don't know how to fix this problem! I removed the battery and plugged in but fat change! Should I upgrade ROM up to 5.0? My current OS is 4.6 which is default when I buy it from T-Mobile! Btw, I'm living in Vietnam and my Javelin was shipped from USA! Have you face with this problem? Help me!

    Thanks!
    10-16-09 05:53 AM
  2. Smurfy71's Avatar
    Are you running a 3rd party theme? If so switch back to a factory theme and see if that fixes it.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-16-09 05:58 AM
  3. thang14k's Avatar
    Thank you for your feedback! I use the default theme from T-Mobile. My cellphone's screen is always on white! I just only receive the call and can't see anything from it! It really makes me crazy!
    10-16-09 06:03 AM
  4. DroDough's Avatar
    I hate to tell you this. I just had this problem not 2 weeks ago, there is nothing you can do. You have to call T-Mobile and request a device swap.
    10-16-09 03:26 PM
  5. thang14k's Avatar
    Thank you your feedback Dro Dough! I'm really worry about this! I am using it in Vietnam and there are no have any Blackberry 's professional repairing workshop! How can I send it back to USA and request an other one from T-Mobile?
    10-16-09 10:15 PM
  6. elezdi's Avatar
    Hmmm do u guys have a mailing system in vietnam? Lol
    10-16-09 10:51 PM
LINK TO POST COPIED TO CLIPBOARD