1. megaloo82's Avatar
    Hello! I just tried upgrading my OS to the 4.5 and somehow my phone is all sorts of screwed up.
    The upgrade process didn't complete, DM was reading "erasing applications" and then the USB got bumped and then DM said "fatal error occurred, please close and retry."
    Now my phone is just blinking red on the LED just two quick blinks and I can't turn it on. I've pulled the batttery, tried reconnecting it to the DM and no go.
    I have a curve 8330.
    Can someone PLEASE tell me what to do to get my phone back?!
    08-03-09 10:48 PM
  2. digitard's Avatar
    08-03-09 10:53 PM
  3. FordThunder's Avatar
    so it doesnt make it to the error code ?
    just a black screen , red flashing light ?
    08-03-09 10:55 PM
  4. megaloo82's Avatar
    I'll check out the link.

    While I have the phone plugged into the computer to upgrade, the phone is blank with just a solid red LED light...just like when it freezes up or when I restart the phone after I've added an application. While the computer or Desktop Manager was updating, it didn't finish and since I've had a red flashing light and the phone doesn't even turn on.
    08-03-09 11:00 PM