1. benwah364's Avatar
    Hello,

    First off, I have a Netgear WPN824v3 wireless router, I searched around on the forums but didnt find anything really pinpointing this issue, or maybe i didn't search well enough.

    My questions stems from this; I have a curve 8900, my girlfriend has a curve 8320, we have a netbook running ubuntu, and a PSP. If I set the security settings on the router to "WPA-PSK [TKIP] + WPA2-PSK [AES]" both our phones connect to UMA but the netbook and PSP don't work wirelessly. If I set the router to "WPA-PSK [TKIP]" everything connects to wireless except my curve 8900.

    Does anyone have an idea why the curve 8900 doesn't like the "WPA-PSK [TKIP]" security setting? Is there a setting on the curve I need to change? Just seems weird it will connect to a setting that includes WPA-PSK [TKIP] but won't connect to the exclusive one. It also won't connect if set to WEP with the appropriate WEP settings set on the device.
    09-28-09 11:07 PM
  2. sonar_chris's Avatar
    I have the same router and I didn't have any problems connecting to TKIP. When you search for a network and find it, you click the next button on the phone it will give you a pin number, you don't want to do this, hit the back button and it will ask you for your TKIP code. Enter it and you should connect just fine.
    09-29-09 12:48 AM
  3. benwah364's Avatar
    i tired a few ways, manually adding, and scanning for wireless networks and i never get this process with a pin that you are describing. did you do any additional configurations on your router for your BB?
    09-29-09 10:49 AM
  4. fatboy97's Avatar
    I don't necessarily have all the equipment you have, and I've never had to do one thing with my T-Mobile Linksys router... but there is also a pretty good thread on UMA in my signature below... you might give that a read... Good Luck!!!
    09-29-09 11:08 AM
  5. 3CISSBB's Avatar
    Blackberries have a known compatibility issue with Netgear routers. That's why Linksys routers work perfectly and others don't. All routers are NOT created equally.
    09-29-09 11:47 AM
  6. DroDough's Avatar
    I use a netgear router at my home and have no issues connecting with my 8900. Like Sonar_Chris said when you search for networks it will bring up a box that list what ever router's are in range, after selecting one, thats when it will give you the pin number to enter into your router. You do not need to do this. Really you can go through set-up wi-fi and click manually add network, when the new screen shows it will ask for the name of the router (SSID) after that it will ask for the security type choose pre-shared key(PSK). Once that is done you will have to put the router password in that you have set-up, then click connect or save. That should work, or at least that is what I had to do when I called netgear.
    09-29-09 12:39 PM
  7. benwah364's Avatar
    Thanks for all the info guys, i don't ever get that pin info to add to the router though. I do new > scan for networks > select my SSID > it asks for the PSK > i enter it > only options are back, save, and connect. never get anything about a pin.

    I'll try a linksys router though, see what happens.

    Don't know if this was information that may have been important, it connects, at least it says it does after the configuration, on WPA-TKIP. On my Wi-Fi profiles, next to my home network, it has a square with a minus sign and then a green radio antenna. I just don't get a UMA connection and the wifi on the home screen is dim. In the wifi diag screen, under UMA i have a red X next to connection and W006.1 error. I've tried all the proposed solutions on this forum for a W006.1, and none of them have prevailed yet.

    I don't think it's the hardware, since it connects when the router is set to WPA2-AES, it has to be some kind of setting that is missing.
    Last edited by benwah364; 09-29-09 at 06:26 PM.
    09-29-09 06:03 PM
  8. skeet719's Avatar
    I don't necessarily have all the equipment you have, and I've never had to do one thing with my T-Mobile Linksys router... but there is also a pretty good thread on UMA in my signature below... you might give that a read... Good Luck!!!
    Dude thanks for that.. I've been having connection issues. It seems like if I dont have a call over it for a little while, when I do, its a bad connection and it eventually drops. Then, I make the next call, and its fine. Who knows..
    10-01-09 12:03 AM
  9. benwah364's Avatar
    Just wanted to update the situation, I went out and bought a linksys router, set it up with the same settings as the netgear router, and my phone connects to UMA fine. That really is weird to me that the router really does make a difference.
    Last edited by benwah364; 10-05-09 at 01:06 PM.
    10-05-09 12:42 PM
  10. 3CISSBB's Avatar
    Just wanted to update the situation, I went out and bought a linksys router, set it up with the same settings as the netgear router, and my phone connects to UMA fine. That really is weird to me that the router really does make a difference.
    Yes, it really is weird but this is why I have always recommended Linksys, and yet another reason why T-Mo chose Linksys for their own branded router.
    10-05-09 01:52 PM
  11. fatboy97's Avatar
    I've had two Linksys routers... I will not buy anything else right now.
    10-05-09 02:21 PM
LINK TO POST COPIED TO CLIPBOARD