1. asolis's Avatar
    I've had the Curve 8530 for a few weeks now. Up until yesterday the trackpad was working correctly. The problem I am now having is that when I press the trackpad to open a link online nothing happens. I have to open the menu and click on Open Link. The trackpad works correctly in all other places except opening a link online. Is there a trackpad setting that I may have turned off by mistake? Thanks.
    02-18-10 03:36 PM
  2. papped's Avatar
    Is it all links on any page, or only certain pages?

    If it's certain pages then it might be a javascript being disabled issue or something similar.
    02-18-10 04:28 PM
  3. asolis's Avatar
    The trackpad won't open a link on any web page. It used to and then yesterday it stopped for some reason.
    02-18-10 04:42 PM
  4. John Yester's Avatar
    What's the page address, let's test it..
    02-18-10 05:01 PM
  5. asolis's Avatar
    It doesn't work on any site -- cnn.com, nyt.com, etc.
    02-18-10 05:05 PM
  6. John Yester's Avatar
    I would take your device in to have it looked at by a Tech.

    Showing the issue may prove there is a problem and it may get worse...
    02-18-10 05:55 PM
  7. kawaine's Avatar
    one thing i noticed on mine is the links open, but sometimes they are the link above or below the link I want, really strange. I've tried this with BB browser as well as opera. One of the biggest problem sites is craigslist. . .
    02-19-10 01:07 PM
  8. papped's Avatar
    Some pages don't render properly in column view. Try hitting X to switch to page view and see if they work correctly
    02-19-10 01:20 PM
  9. fedge's Avatar
    my 8530 was doing the same thing for 2 days i finally did a battery pull (i should've tried before) and issue was resolved.
    03-21-10 02:20 PM
  10. jeberry9876's Avatar
    I have had the same issue. Usually after I use slacker radio. I just do the alt shift del. Problem solved. Opera mini will go buggy and freeze on me have to do the same thing. ( My curve is in an otterbox defender ).

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-10 02:45 PM
  11. kpoohcsu's Avatar
    I have been having the same problem recently as well. I have to press the enter button to open the link. I'll try the page view option and see if that works.
    03-21-10 03:59 PM
  12. markaveli420's Avatar
    Links on my bb only work when click on the trackpad the enter button doesn't work for me but only on log in screens do I have this issue

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by markaveli420; 03-22-10 at 01:46 AM.
    03-22-10 01:10 AM
  13. motheringingrace's Avatar
    I was having this problem (thus my visit to this forum) and it was completely fixed with a battery pull.
    06-29-10 04:38 PM
LINK TO POST COPIED TO CLIPBOARD