1. Up2date's Avatar
    Hope someone can help. The trackball on my 8330 has gone crazy. If I roll it right, the screen goes left. In some programs like Docs to go, I can't get to part of my charts anymore because they are on the right. I had replaced the trackball once before, so took this one out, made sure the pins on the ring were still all there, and they are. Made sure that the trackball was seated properly with the notches on the side. Tried rebooting, changing batteries, tried different programs, like calendar - and can't get to certain dates if they are right of where I start. I am going crazy, because I can't get to a lot of information. I even put the phone in a device that I use in my office for small electronics with advanced circuitry to try and dry it out, since it has been so humid, but it didn't help - and my wife, who has the same phone, has not experienced the problem, so I didn't think that was the problem anyway, but it was worth a try. Verizon of course says the phone can't be fixed - of course, they told me that also before I replaced the trackball the first time. Their solution was to of course buy a new phone. It was only a few months ago, when I got a new 8530 and in less then a week, it rained and even though in a case and under my jacket, it got wet, and I couldn't get it to work so went back to my 8330. Verizon says they will get me a used phone of a lower model for about $150.00 and I told them to go jump. Any suggestions would be appreciated.
    07-11-10 11:54 PM
  2. xdr0x's Avatar
    In might be that you put the rollers back in the wrong direction. Do a search in this forum and look for trackball replacement- there's a great tutorial on it. Pay close attention to the way the rollers are supposed to face when reinserted, there are four corners to it and they have to be placed in the correct direction otherwise things can get wonky. That should help...

    Posted from my CrackBerry at wapforums.crackberry.com
    07-12-10 01:06 PM
  3. Up2date's Avatar
    xdrOx: Thanks for the reply. Since I had already replaced the track ball once and it worked, then it would appear that it was in correctly. This problem only started about two days ago, and the trackball has been in for about a month or more without any problem. However, to be sure, I did take it out yesterday, watched several videos, and put it back again - but it didn't help. If you have any other thoughts, I'd be happy to listen.
    07-12-10 01:27 PM
  4. xdr0x's Avatar
    That's odd, I wonder if one of the rollers is broken or something like that? I'm really at a loss hopefully someone else has another suggestion?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-10 12:22 PM
  5. Up2date's Avatar
    Hi, thanks again for your thoughts. I went through a bunch of older postings and saw the same problem. These had solutions of pushing in on the Track ball when going in the direction you wanted, using compressed air, and cleaning with alcohol. I did all of those and had no success. Then I had another thought. When I replaced it before, I really only needed to replace the ring, because the pins had broken, but I replaced both. On a whim, I took the old ball minus the ring and installed it, with the ring from the new ball. It works better now, not perfect - so there is still some problem, but at least I can use it, with less frustration. Maybe it means that the ball needs to be replaced again, even though it has only been a short while. Maybe someone knows if there are different quality of balls that you can get?
    07-13-10 12:40 PM
LINK TO POST COPIED TO CLIPBOARD