1. black thoughts's Avatar
    First off sorry if this has already been asked, I tried the search bar. All of the parts are out, that's including the ring, the center piece with the 4 magnets and the ball. I attached the picture of all the parts I have.

    I think I might be missing something because the place where the trackball should be on the curve is just white background, nothing else. And when I try to attach the magnets and put it in, they get out of place somehow, without fail.

    I'm frustrated, I would appreciate anyone with info.
    Last edited by black thoughts; 09-16-09 at 08:01 PM.
    09-16-09 07:59 PM
  2. xliderider's Avatar
    Use this tutorial to get your TB back together:

    http://forums.crackberry.com/f3/quic...kballs-202396/

    Posted from my CrackBerry at wapforums.crackberry.com
    09-16-09 08:12 PM
  3. black thoughts's Avatar
    thanks for the suggestion, but I think that I'm missing a peice.
    09-17-09 05:47 AM
  4. Iceman0803's Avatar
    First off sorry if this has already been asked, I tried the search bar. All of the parts are out, that's including the ring, the center piece with the 4 magnets and the ball. I attached the picture of all the parts I have.

    I think I might be missing something because the place where the trackball should be on the curve is just white background, nothing else. And when I try to attach the magnets and put it in, they get out of place somehow, without fail.

    I'm frustrated, I would appreciate anyone with info.
    Looks like you're going to have to buy a new trackball. It looks like the housing that the ball sits in fell apart, from what I can tell, (pic is a bit blurry) and you're missing a piece. Not to worry a replacement is only 10 bucks and takes less than a minute to install. LINK
    Last edited by Iceman0803; 09-17-09 at 06:18 AM.
    09-17-09 06:08 AM
LINK TO POST COPIED TO CLIPBOARD