1. zippox180's Avatar
    Hello crackberry nation! I have a tmobile curve that I got my hands on from a friend who upgraded. The buttons are unresponsive and once the backlight goes out I can not get it back on. It is recognized by the computer and it charges however other than that nothing. I've tried the usual battery pulls and reloading software which works fine with no errors . It does not have any water damge I was told as that was the first thing I asked. After the reload of software I cannot select agree or advance. The trackball does not scroll. It clicks but will not select. The mute and lock button do not work either. I hope I have given enough information. I looked at other threads with no success .thanks in advance .
    06-02-10 10:50 PM
  2. Ahmed G.'s Avatar
    Hello

    Have you tried installing a different Operating System version ?
    06-03-10 07:12 AM
  3. zippox180's Avatar
    I have not hmm maybe ill try that and post results. Thanks for the tip
    06-03-10 07:15 PM
  4. Ahmed G.'s Avatar
    Anytime . . Yeah, post the results so you keep us updated
    06-04-10 12:07 PM
LINK TO POST COPIED TO CLIPBOARD