1. NorseBerry's Avatar
    Took delivery of this phone mid-July with 4.5.0.131 installed. Despite multiple provisions, battery pulls, and bandwidth tests at random locations in 15 mile radius (solid EVDO Rev A coverage area), the download speed has only exceeded 450 Kb/s once. Sitting in my den, I see 1XEV and five bars, then it randomly drops or brings back all five bars. There are 3 cell towers within a 1/2 mile radius.

    Just a little disgusted (new to BB), took the phone to a Sprint Corporate store for diagnostics. The tech came back and said they saw nothing obviously wrong with the phone. He did say that in that particular store, every BB regularly shows 1200 - 1500 Kbps download speed and he observed that my Curve was throttled at 450 Kbps. His comment was to replace the phone.

    Ironically, a friend of mine got the same phone at the same time. Last evening, his download speed was 120 Kbps and upload was 36 Kbps. We are both where Sprint advertises solid EVDO Rev A coverage.

    We both use Xtremelabs Speedtest app as proxy-based browsers do not work with dslreports speed tests.

    For those of you who may wonder if you have a bad radio in this Curve model, the Sprint tech is convinced that my radio is bogus. My friend needs no further proof.
    08-13-09 04:41 PM
  2. rcnathan's Avatar
    The Curve only has EVDO Internet - its doesn't have EVDO Rev A internet that the Tour 9630 model does. So your download speeds are normal around the 300-400kbps. Just like any other ISP download speed will vary depending on the amount of bandwidth that is being taken up by other users.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-13-09 05:26 PM
  3. Jackamus's Avatar
    Took delivery of this phone mid-July with 4.5.0.131 installed. Despite multiple provisions, battery pulls, and bandwidth tests at random locations in 15 mile radius (solid EVDO Rev A coverage area), the download speed has only exceeded 450 Kb/s once. Sitting in my den, I see 1XEV and five bars, then it randomly drops or brings back all five bars. There are 3 cell towers within a 1/2 mile radius.

    Just a little disgusted (new to BB), took the phone to a Sprint Corporate store for diagnostics. The tech came back and said they saw nothing obviously wrong with the phone. He did say that in that particular store, every BB regularly shows 1200 - 1500 Kbps download speed and he observed that my Curve was throttled at 450 Kbps. His comment was to replace the phone.

    Ironically, a friend of mine got the same phone at the same time. Last evening, his download speed was 120 Kbps and upload was 36 Kbps. We are both where Sprint advertises solid EVDO Rev A coverage.

    We both use Xtremelabs Speedtest app as proxy-based browsers do not work with dslreports speed tests.

    For those of you who may wonder if you have a bad radio in this Curve model, the Sprint tech is convinced that my radio is bogus. My friend needs no further proof.

    Hey there, I am in Tampa FL, and my Blackberry Curve does the same thing as yours does. I'll have all 5 bars, and then NONE, and then five bars again. My curve that was on the Alltel network, never did that. However, my Sprint Curve 8330m does that. The store replaced my first BB Curve because it was doing that, and the 2nd one is doing the same thing. Even though the radio drops all bars, I still have a connection. So, if this is happening to you, then it makes me wonder if it is a software issue with the Curve on the Sprint network..
    08-14-09 01:24 PM
  4. Geebus's Avatar
    just got my sprint from curve last friday how could i tell how many kbps im using?
    08-14-09 01:28 PM
  5. p4tr1ck's Avatar
    I had the same problem I upgraded my OS and it seemed to stop it from jumping around so much, maybe this was my imagination but it seems to be fine now. Just try upgrading to .138 or you could even try .160 (which I have).
    08-14-09 01:43 PM
  6. Jackamus's Avatar
    I had the same problem I upgraded my OS and it seemed to stop it from jumping around so much, maybe this was my imagination but it seems to be fine now. Just try upgrading to .138 or you could even try .160 (which I have).
    I have .131 on my BB Curve M. I haven't found any official updates for my Curve, can someone point me in the right direction for an update to the OS?

    Thanks,
    jack
    08-14-09 01:46 PM
  7. p4tr1ck's Avatar
    http://forums.crackberry.com/f52/new...evices-185702/

    Just follow the steps in this post and everything should work just fine.

    EDIT: just had to go the next page to fine the .160 so here is the link to that as well.

    http://forums.crackberry.com/f52/new...-160-a-282826/

    Your choice on which one you want just read some of the comments and see what people have to say.
    08-14-09 01:49 PM
  8. OmegaF150's Avatar
    Personally the .131 is supposed to be the best for my verizon curve so when I installed the last hybrid I swapped the radio for .131 and it totally blows! The internet is fine but the call quality is so terrible. I was going to swap the radio back this morning but my comp froze so I will get to it later when I have a few extra min.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-14-09 01:59 PM
  9. Jerry Hildenbrand's Avatar
    Known issue with the 8330m. Some folks have it, some don't. Luckily I don't. What I can tell you is the 4.5/4.6/5.0 hybrid with the .131 radio posted here on CB made my 8330m quicker, just as stable, and excellent call quality with a very small hit in battery life. Once you get everything backed up and ready, might want to give it a test run.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-14-09 02:21 PM
  10. Jackamus's Avatar
    I plan to do the upgrade to .138 tonight, to see if that fixes the radio issue with the signal dropping off all of a sudden.
    08-14-09 02:29 PM
  11. p4tr1ck's Avatar
    I plan to do the upgrade to .138 tonight, to see if that fixes the radio issue with the signal dropping off all of a sudden.
    Have you noticed a difference???
    08-15-09 12:39 AM
  12. rcnathan's Avatar
    Ya know...I haven't noticed it dropping at all now that I think about it. I did the upgrade a couple of night ago. Plus, I have seen a speed improvement too. Which, in and of itself, is a good reason to upgrade imho

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 12:44 AM
  13. Jackamus's Avatar
    I haven't yet done the upgrade. Will be doing it soon. I sure hope this corrects the radio issue with the Blackberry Curve 8330M. . Please wish me luck.....

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 12:57 AM
  14. Jackamus's Avatar
    Alrighty folks, the update is installed, and so far...so far... and I mean so far.... (LOL) I don't see the signal strength bar moving up and down. I have installed the .138 update. So, hoping this goes okay. So far, everything is working on the Curve, no issues that I can tell, and all my software was restored.
    08-15-09 02:15 AM
  15. p4tr1ck's Avatar
    Awesome! This should fix your fluctuation problem. I also noticed an improvement on my battery life when I upgraded.
    08-15-09 02:23 AM
  16. Jackamus's Avatar
    So far it seems to have worked, but we shall see. =) I have been testing everything. I noticed that this BB Curve battery went down faster than my previous one, on the Alltel Network. So, with this update, I am hoping it will improve the battery life. (I am on the Sprint network now. )
    08-15-09 02:26 AM
  17. p4tr1ck's Avatar
    Have you noticed a difference in the battery life????
    08-15-09 04:06 PM
  18. Jackamus's Avatar
    Can't tell a major difference, but then again I have been using my BB a lot more today...
    08-15-09 04:09 PM
  19. doc69's Avatar
    Known issue with the 8330m. Some folks have it, some don't. Luckily I don't. What I can tell you is the 4.5/4.6/5.0 hybrid with the .131 radio posted here on CB made my 8330m quicker, just as stable, and excellent call quality with a very small hit in battery life. Once you get everything backed up and ready, might want to give it a test run.

    Posted from my CrackBerry at wapforums.crackberry.com
    +1 This is true. I'm liking this Hybrid a lot so far.
    08-15-09 04:30 PM
LINK TO POST COPIED TO CLIPBOARD