1. doomsdayclock's Avatar
    Hello. Recently, when receiving calls from my contacts, only their phone number appears (not including the name of the contact).

    I am not certain what occurred but I am unable to fix the problem. I tried resetting my phone, taking out the sim card, deleting all my contacts then adding them back, etc.
    01-09-09 01:41 PM
  2. cellison1460's Avatar
    Make sure you contacts are entered with only numbers.
    Ie. 8001231234 and not (800) 123-1234

    Also if you have your phone locked and the address book protected it will only show the number.

    To unprotect your address book:
    Option>security options>general settings>address book = No

    Posted from my CrackBerry at wapforums.crackberry.com
    01-09-09 02:37 PM
  3. doomsdayclock's Avatar
    Thank you!
    01-09-09 03:26 PM
  4. SyracuseWolvrine's Avatar
    there's also some callers that may be behind a corporate phone system that will show one generic number for anyone calling from that company.
    01-09-09 07:26 PM
LINK TO POST COPIED TO CLIPBOARD