1. Alyusha's Avatar
    Hi guys, I have a Curve 8330. Last night before I went to be the battery was at least at 45%. I didn't have it plugged it. But when I woke up today to check it, it was off. No matter what I did, I couldn't get it to turn on. So I plug it in, and the red LED comes on and a battery with a blue lighting bolt. Once, I got it to go to white screen with time symbol. But now nothing. I would hope it was just a REALLY dead battery, but I dont get how it would have died, Nor has it ever been this dead on me.

    Any suggestions?
    08-13-09 01:56 PM
  2. Alyusha's Avatar
    Never mind.... left it charging and it works now. That's really strange though! Its never in the time Ive had it done that! Maybe my dog was laying on it making it open applications. Who knows.
    08-13-09 02:04 PM
  3. fatboy97's Avatar
    First, this is the 8900 forum... but try this...

    Take out your battery, plug your device into a power source (pc or power cord), give it a couple seconds and then put your battery back in, leave it for a minute, then push and hold the Red Phone button for about 5 to 10 seconds.
    08-13-09 02:04 PM
  4. aristile's Avatar
    Your phone will not work when the battery is too low, you need to charge it a bit with the phone powered off first so that the battery can have more of a charge. Also, it is not good for your battery to get that low, I highly recommend that you avoid this in the future.
    08-13-09 02:19 PM
  5. alexdjay's Avatar
    i have the same problem with my 8900 curve, i left it connected to my laptop and the next morning was dead , wont power on, when i plug the charger ,red led is on ,and after 30 sec i see the white screen with the battery symbol in the middle ,and nothing more, i just tried the battery solution and still nothing ,any ideas ? thx.
    08-13-09 05:03 PM
LINK TO POST COPIED TO CLIPBOARD