08-22-09 07:34 PM
188 ... 45678
tools
  1. semispm's Avatar
    still no GPS on Google Maps with this update on my 8330m on Sprint but the GPS works in every other program I have tried so its obviously a Google problem.
    06-25-09 09:03 AM
  2. hdkilner's Avatar
    still no GPS on Google Maps with this update on my 8330m on Sprint but the GPS works in every other program I have tried so its obviously a Google problem.
    hey I have gps on google but its like a mile or so off
    06-25-09 11:08 AM
  3. swissfire's Avatar
    what is the difference between 8330 and 8330m?
    06-29-09 12:19 AM
  4. wildjoker12000's Avatar
    So here's what I have gleaned from all this if I'm wrong please correct me.

    1) BACKUP ALL YOUR STUFF BEFORE YOU START MONKEYING WITH YOUR CURVE!!!

    2) This new OS will only work on the 8330m (which I have) and you need to check two places inside the wrench for that first: One - check the about menu for 8330m designation, and two, check the Status menu's last 2 lines for an MEID as opposed to the old school ESN HEX/DEC.

    3) Use Version 4.5 of the loader to give the best chance at a successful load of the update.

    4) Make sure to delete the line in the OS as per the instructions.

    If you get thru all that, the only changes are that you lose you call timer clock, Google Maps GPS sucks, but your Curveball should be a bit snappier and responsive. Did I get it all?

    Posted from my CrackBerry at wapforums.crackberry.com
    06-29-09 02:58 AM
  5. RiDeC58's Avatar
    Newbie upgrade question. My 8330 system software and my DSM software are both 4.5.X.

    Does the DSM need to match the Handset software? I notice that DSM 4.7 is available. Would this still be compatible with my 4.5 handheld and would there be any advantage to upgrading the DSM?

    Thanks.
    06-29-09 06:22 PM
  6. stengel680's Avatar
    Newbie upgrade question. My 8330 system software and my DSM software are both 4.5.X.

    Does the DSM need to match the Handset software? I notice that DSM 4.7 is available. Would this still be compatible with my 4.5 handheld and would there be any advantage to upgrading the DSM?

    Thanks.
    I have Desktop Manager 4.7 and Device OS 4.5.0.X with no problems. Started DM 4.5 but almost immediately upgraded to 4.7 so I couldn't tell u the difference.

    Anybody know when an OS newer than .138 gonna be out for 8330m? Seems like were not getting much love from RIM in the OS dept.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-09 06:31 AM
  7. blackhorse's Avatar
    Does this work on the regular 8330?

    Posted from my CrackBerry at wapforums.crackberry.com
    He said above it would not :-P
    07-07-09 01:12 PM
  8. RAB1961's Avatar
    Ok good to know, anyone know what the "m" stands for and whats the difference between a 8330 and a 8330m??? I honestly didnt even know a 8330m existed lol.
    The 8330 is rhe English version. The 8330m is multi-language version for English and Chinese.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-10-09 09:35 PM
  9. camarojones's Avatar
    The 8330 is rhe English version. The 8330m is multi-language version for English and Chinese.

    Posted from my CrackBerry at wapforums.crackberry.com
    I'm sorry, but the 8330 is an ESN device.

    The 8330m is MEID.
    07-10-09 10:00 PM
  10. spiknek's Avatar
    yo man let us know how did the new OS worked for your Metropcs 8330m?
    PIN3069C7BA ping me and let me know?
    07-10-09 10:42 PM
  11. MrTomRN's Avatar
    So I decided tonight would be the night I upgrade the OS. But when I hooked up the BB (DM 4.7) it said there was an update. So I did that (to see what would happen). My BB now shows it to be running 4.5.0.160.

    Only flakiness I have to report is my calendar did not sync, and the i-net is perilously slow. Shows 1x more than EVDO, but will see how it averages out over the next several days. GPS remains intact. Only in the first hour post install so be watching this over the next week for updates. And yes, it really is an "m" series. If it continues to be this slow, I may downgrade to a .13x or hybrid.
    07-23-09 10:18 PM
  12. snakester9's Avatar
    Help. Nothing i do seems to be making this update take. I deleted vendor.xml, that didn't work, I downgraded my BBM to 4.6 then 4.5, that didn't work. I know for a fact I have an 8330m but I even tried the 8330 plain upgrade and that didn't work! I can't think of anything else to try and the "Oh, you have five bars... oh wait now you don't cuz you just finished a data session" is beginning to drive me up a wall.
    07-24-09 11:42 AM
  13. camarojones's Avatar
    Don't use the DM for this. Install the device 138an delete the vendore file, then run loader.exe from that same folder.

    Don't forget to do a DM backup, and an app backup before installing the new OS. Do a search for the app backup.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-24-09 01:10 PM
  14. snakester9's Avatar
    Don't use the DM for this. Install the device 138an delete the vendore file, then run loader.exe from that same folder.

    Don't forget to do a DM backup, and an app backup before installing the new OS. Do a search for the app backup.

    Posted from my CrackBerry at wapforums.crackberry.com

    When I do that it just shows me all the apps on my phone and gives me the option to remove them... doesn't give me an upgrade option or even show the new OS in the list, or prompt me for an upgrade.
    07-25-09 02:11 PM
  15. camarojones's Avatar
    OK...lets get you through this...

    Make a backup, and save it to...your desktop for example, or your My Documents folder. Then close DM and UNINSTALL IT.

    Remove ALL OS from your control panel on PC, then browse to:
    c:/program files/common files/research in motion. and delete EVERYTHING in here.

    Reboot.

    Install DM 4.5

    Plug up your BB to make sure it sees it, then make another backup just to be safe, then exit the program.

    Install 138, delete the Vendor file, then try loader.exe

    -----------------------------------
    If the above doesn't work, continue:

    Go here to WIPE your device:
    http://forums.crackberry.com/f3/how-...l_cmder-53502/

    Run loader.exe from the vendor folder. (You'll either see pin:UNKNOWN or pin:<yourpin#>)

    At this time hit NEXT!

    This will prompt you to install the 138 OS.

    There are a few threads in the Blackberry 101 area in case you can't get it to load.
    BlackBerry 101 How-To Lecture Series | CrackBerry.com

    I've done this about 4 times in the past day trying to work out bugs in my OS, and troubleshoot a few data issues I was having, but it does work.

    If you have any problems, let us know!
    07-25-09 05:53 PM
  16. snakester9's Avatar
    Now I've got a useless Berry and an apploader that's saying "no software for your device"...

    EDIT: Putting Sprints .131 back on it, so AppLoader is having no trouble recognizing the phone, it just seems to be completely incapable of putting .138 on it.
    Last edited by snakester9; 07-25-09 at 10:04 PM.
    07-25-09 09:50 PM
  17. camarojones's Avatar
    WOW...that is really odd...REALLY odd...

    I've lost count how many times I've loaded 138 up on mine.

    wow...

    I wonder if yours is really a M model...I've heard of a few folks that have had problems loading a newer OS because of being a wrong version...or at least the device thinking it is something else...

    Might have to start digging into this...
    07-25-09 10:20 PM
  18. snakester9's Avatar
    WOW...that is really odd...REALLY odd...

    I've lost count how many times I've loaded 138 up on mine.

    wow...

    I wonder if yours is really a M model...I've heard of a few folks that have had problems loading a newer OS because of being a wrong version...or at least the device thinking it is something else...

    Might have to start digging into this...

    Shows up as an M on the About screen, has an MEID, and while it was bricked I tried loading the .160 8330 OS and that was a no-go too. Sprint .131 was more than happy to load up on it tho.
    07-25-09 10:22 PM
  19. camarojones's Avatar
    That completely surprises me...WAIT!

    Have you tried to re-download the file? I was trying out some hybrid OSes the other day and a couple of them did the same thing.

    When trying to reload 138, I had inadvertently overwritten the file name and it wouldn't load...

    Have you tried deleting the OS (on the PC) and re-downloading it?
    07-25-09 10:28 PM
  20. snakester9's Avatar
    That completely surprises me...WAIT!

    Have you tried to re-download the file? I was trying out some hybrid OSes the other day and a couple of them did the same thing.

    When trying to reload 138, I had inadvertently overwritten the file name and it wouldn't load...

    Have you tried deleting the OS (on the PC) and re-downloading it?
    I haven't tried re-downloading it. I've uninstalled it multiple times though. I'll give that a try right now (once the backups are done restoring) and see if it works without wiping the device. If it doesn't I'll try wiping the device again tomorrow.

    I'm willing to try almost anything to get rid of that signal bar issue; it seems to confuse some apps that use streaming data (slacker, etc) and just looks really dumb.
    07-25-09 10:31 PM
  21. snakester9's Avatar
    Nope, deleting, redownloading and reinstalling didn't work either

    Is there any way I could maybe edit the vendor.xml and trick it into working? I've got backups of my phone so nuking isn't something i'm horribly worried about.
    Last edited by snakester9; 07-26-09 at 01:26 AM.
    07-26-09 01:23 AM
  22. camarojones's Avatar
    Nope, deleting, redownloading and reinstalling didn't work either

    Is there any way I could maybe edit the vendor.xml and trick it into working? I've got backups of my phone so nuking isn't something i'm horribly worried about.
    LOL. I've got backups too.

    As far as editing the vendor file, I have no idea...Hopefully someone else can chime in because you've reached the edge of my knowledge on this part...it just bothers me that you can't get it to load...not sure what to do next. lol

    Good luck!
    07-26-09 09:05 AM
  23. snakester9's Avatar
    LOL. I've got backups too.

    As far as editing the vendor file, I have no idea...Hopefully someone else can chime in because you've reached the edge of my knowledge on this part...it just bothers me that you can't get it to load...not sure what to do next. lol

    Good luck!
    Thanks for trying, much appreciated

    For anyone else who wants to give it a go, i'll post some info from my about screen just in case it's of any help:

    BlackBerry 8330m
    smartphone (CDMA)
    v4.5.0.131 (Platform 3.4.0.25)
    Cryptographic Kernel v3.8.5.32a
    Micro Edition Configuration; CLDC-1.1
    Micro Edition Profile: MIDP-2.0
    Micro Edition JTWI Version: 1.0
    Micro Edition media Version: 1.1
    Micro Edition PIM Version: 1.0
    Micro Edition File Version: 1.0
    Micro Edition Bluetooth Version: 1.0
    Micro Edition Location Version: 1.0.1

    Under my CAPS+ALT+H screen

    Vendor ID: 104
    Platform 3.4.0.25
    App Version: 4.5.0.131 (188)
    PIN: 308**9b1
    07-26-09 09:58 PM
  24. ahyougotme's Avatar
    Update dm snake. Make sure you're offline and your comp recognizes your phone. Sorry you have such a problem. Hopefully .160 will be out soon for us

    Posted from my CrackBerry at wapforums.crackberry.com
    07-26-09 11:03 PM
  25. snakester9's Avatar
    Update dm snake. Make sure you're offline and your comp recognizes your phone. Sorry you have such a problem. Hopefully .160 will be out soon for us

    Posted from my CrackBerry at wapforums.crackberry.com
    Comp definitely recognizes the phone, and I've tried BBDM 5.0, 4.7, 4.6, and 4.5. Also tried Loader.exe. As said, I even wiped the phone and tried it and it wouldn't do anything, just said "no software available for your phone"... of course when I installed the Sprint OS (.131) on my computer, it was more than happy to put that on it.

    I didn't try taking my laptop offline while doing the update though, I'll go give that a try and see waht happens.

    EDIT: Nope, same old "There are no updates available for your device." Soooo frustrating.
    Last edited by snakester9; 07-26-09 at 11:32 PM.
    07-26-09 11:06 PM
188 ... 45678
LINK TO POST COPIED TO CLIPBOARD