1. Robbi's Avatar
    Just got a curve 8900 for ATT. Got a quick question. I'm coming from a curve 8330 and the trackball seems so different. It seems to stick a little and go a little slower then my other curve. Is this normal?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 05:06 PM
  2. aristile's Avatar
    The 8900 trackball is much better than the one you had on your 8330.
    08-15-09 05:12 PM
  3. Robbi's Avatar
    So I'm guessing that I might have a defective one. I think I might go back to the store with it and check it out.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 05:16 PM
  4. aristile's Avatar
    If it goes "slower" just check your settings:

    Options > Screen / Keyboard > Adjust the Horizontal and Vertical Trackball Sensitivity settings.
    08-15-09 05:22 PM
  5. Robbi's Avatar
    I adjusted the sensitivity already. Its not that. Its like when u roll the trackball, it stops it the middle of rolling. I hope I'm making sense of this. And thanks for your help.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 05:33 PM
  6. mrJayC's Avatar
    my track ball works fine. i ts alot better than the 8300s
    08-15-09 05:34 PM
  7. Robbi's Avatar
    I'm going to take it back to the store and see what they say. Thanks again!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 05:59 PM
  8. orzywife's Avatar
    My trackball did what yours is doing when I first received it. It has since "loosened" up and works much better. Sandra ")

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 06:14 PM
  9. Robbi's Avatar
    Ok. Now I don't know what to do. Maybe ill go by the att store and try out the display models. Lol. I appreicate your help. Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 06:38 PM
LINK TO POST COPIED TO CLIPBOARD