1. captrx's Avatar
    Wanted to get on the internet today but somehow my Browser Icon has disappeared from the display. How can I recover same? I am a Verizon Customer with a Black Berry Curve 8333. Thanks for your help in advance.
    01-10-09 05:52 PM
  2. SevereDeceit's Avatar
    Go to options>advanced options>host routing table>hit menu>register now...
    01-10-09 05:54 PM
  3. rachel0179's Avatar
    Resending service books
    Either log onto your carriers BIS where you can edit your email info etc and resend from there, or find the manage internet email icon and follow that thru.

    Register the Host Routing Table
    Options, advanced, host routing table, menu key register
    01-10-09 05:55 PM
  4. Ye's Avatar
    Eh, nevermind. Everyone beat me to it LOL
    01-10-09 05:55 PM
  5. dragon_storm's Avatar
    i had to delete all my service books and log into BIS site and resend them...problem solved
    01-10-09 05:55 PM
  6. xliderider's Avatar
    Or go to the icon Email Settings > Service Books > Send Service Books
    01-10-09 06:08 PM
  7. SevereDeceit's Avatar
    Registering the device is what will give you back the icon...
    01-10-09 06:10 PM
  8. captrx's Avatar
    Thank you Severe Deceit and Rachel0179 your quick response with advice resolved the problem. The icon is back where it is supposed to be and life is good. Thanks again!!
    01-10-09 06:11 PM
  9. SevereDeceit's Avatar
    Thank you Severe Deceit and Rachel0179 your quick response with advice resolved the problem. The icon is back where it is supposed to be and life is good. Thanks again!!
    No problem, Rachel and I are around alot. You know where to go if you need help...
    01-10-09 06:13 PM
  10. rachel0179's Avatar
    Its been happening to Verizon customers for about 2 weeks now LOL
    01-10-09 06:14 PM
  11. SevereDeceit's Avatar
    It happened to me already...
    01-10-09 06:17 PM
  12. miatapaul's Avatar
    happened to me today, i did a battery pull and it came back(actually just ran QuickPull)
    01-10-09 06:43 PM
  13. Yammy1005's Avatar
    thank you guys... had the same problem but its solve now! thanks
    01-22-09 12:22 PM
  14. zebrajeb's Avatar
    Old thread but same problem. I've pulled the battery, resent service books and done the "register" thing. Still can't get the browser icon back on wife's curve. Any other suggestions?

    Thanks

    John
    08-04-09 07:36 PM
  15. Motorcycle Mama's Avatar
    Call Verizon and have them check to make sure that the BlackBerry Data Plan is correctly set up for the device.
    08-04-09 08:35 PM
  16. SevereDeceit's Avatar
    Agreed, Mama...
    08-04-09 08:37 PM
  17. osxdude's Avatar
    Hmmm, what if you don't have a BlackBerry plan on AT&T? Is there a way to get the browser icon then?
    08-04-09 11:29 PM
  18. Motorcycle Mama's Avatar
    Ummm ... no.

    You have to have a BlackBerry Data Plan in order to get the BlackBerry Browser.

    And without a data plan, I'm not sure how exactly you would plan to get internet access on the 8310. ??
    08-05-09 07:05 AM
LINK TO POST COPIED TO CLIPBOARD