1. Rodiah's Avatar
    Hi,
    I am going to try and be as detailed as possible and pray that someone can help me. I will bullet what is happening so that my problem doesnt get lost in excessive wording.

    The Charge port on my 8320 Curve broke and tmobile sent me a new replacement phone (same model).

    Phone worked fine for a day and a half and then in the middle of a text the screen goes black, but the phone still vibrates as my emails/ text messages come in

    Before it broke, I installed 2 applications (google sync and facebook and changed my theme to one of the pre installed themes)

    Took battery out and sim card, waited a short time and replaced them. Phone comes on and I can scroll between application icons but I cant actually CLICK on anythingeven more frustrating the phone rings and I cant answer.. it is almost as if the buttons dont work because I click them and nothing happens.

    Eventually if left alone the screen will go black again and only comes on if the phone rings or if I plug it into the computer. The time that it stays on before going black again is under a minute.

    The computer is able to detect the phone and I tried to back up and restore and I also removed the google and facebook applications but it didnt work.

    Another dilemma although unrelated is my old phone is backuped but not recently. Is there anyway to back up the phone other than using a USB plug (the charge port on old phone is broke). This is a personal and not a work phone so I dont have enterprise

    Thanks for reading!!! Please help
    03-26-09 10:54 AM
  2. jackie treehorn's Avatar
    I'm gonna say you need to call tmoblie and get the device replaced. Sounds as if they sent you a lemon
    03-26-09 11:00 AM
  3. Heresy's Avatar
    I would agree that you need to have that device replaced.
    03-26-09 11:04 AM
LINK TO POST COPIED TO CLIPBOARD