1. sofiabman's Avatar
    I bought two blackberry curves to my friends in Sweden. They are both hooked up now on Swedish carriers.
    I think that the phones are somehow programmed to be
    on a USA calling system.

    When they receive a call, the number shows up in their call log. However,
    when they push that very same number (out of the call log) they cant call
    the number back.
    A +1 automatically shows up in front of the number in
    the call log. And since theyre calling within Sweden (+46) the call doesnt
    go through.
    They now have to take the extra steps and go back to their contacts to
    call the person back.
    And on top of that, they will have to either recognize the number or search
    for the number in their contacts in order to know who have called them.

    The numbers doesnt match up with the number/name in their contacts since
    their is a country code issue.

    Is there any way to reprogram the phones? To make the +1 go away? Or, to make it +46 instead?
    01-09-10 03:10 PM
  2. Motorcycle Mama's Avatar
    In the Phone Options, what is the "Smart Dialing" country code set to?

    Is it the correct code for the country in which they are located?
    01-09-10 03:13 PM
  3. sofiabman's Avatar
    awww, make sense. checking with them right now, that could be the problem. THANKS!!!
    01-09-10 03:20 PM
LINK TO POST COPIED TO CLIPBOARD