1. charliesbopeep's Avatar
    I need help please! I contacted Appalachian Wireless to see what kind of Blackberry I could use with their services, and was told Verizon was compatabile. I purchased a Verizon from eBay because I can not afford A W prices,penalties for upgrading early, etc. Appalachian has activated the BB, but I can only use it for phone service, I have no service books. They keep telling me that it is activated for internet service locally, but not when I'm roaming. I don't even have local internet. I was at the store today and the rep told me I have local internet, but it just doesn't work. Every time I try to use my browser it tells me I need to contact my carrier. I am carrying a blackberry data plan on my account.

    Last night I searched and found a downloadable A W OS on blackberry's web site. After several tries I managed to get it downloaded to my laptop. I then proceeded to 'wipe' my BB all the way to the white screen with the '507' message, but when I tried to install the AW OS I can't get it to work. It unzips, and installs, but then my DM can't find it. Must have unzipped and installed 20 times last night. Still can't get anything but phone service on my 8330.

    can someone help me figure out how to program this BB to AW and get internet? And if it helps to realize why I use AW it's because they have better signal in the hills of eastern Ky. than any other carrier, I can get signal with them almost anywhere I travel, which I could not do with AT&T, and their phone and data plans are more economical than AT&T, Alltel, or Verizon. Can't even get T-mobile or Boost (Nextel) here!

    I am getting so frustrated being told that this phone can't work. I am planning a new business in the next 12 months which will include quite a bit of travel and I need to have an internet savvy phone with me at all times. Can't afford to buy one from AW until my business is up and running AND until Feb. 2011, when my current contract expires!
    12-31-09 04:27 PM
  2. dictoresno's Avatar
    do you have a BIS account with AW and have you logged in there to apply your new PIN into the settings? no PIN registered, no service books. no service books, no BB data.

    and downloading/installing an AW specific OS wont help you solve your issue. also, you may wanna check your APN settings to make aure you can access your internet too.
    Last edited by dictoresno; 12-31-09 at 07:47 PM.
    12-31-09 07:44 PM
  3. charliesbopeep's Avatar
    yes, I do have a BIS account with AW, no I have not logged in there; was never told to do so. Where or how do I find my PIN? and also APN
    12-31-09 10:06 PM
  4. dictoresno's Avatar
    PIN is in options > status. log into it and change the pin to the new one. then send service books. see what happens from there.
    12-31-09 11:39 PM
  5. Reed McLay's Avatar
    I then proceeded to 'wipe' my BB all the way to the white screen with the '507' message, but when I tried to install the AW OS I can't get it to work. ...
    The Curve 8330 comes in two different sub models. The original 8330 and 8330m, the software is not interchangable.

    The first issue is getting your device working agian. I does not matter which carrier OS you use, they are all identical. It is critical that you are using the correct model specific version.

    This should be the correct OS for your Curve:

    http://forums.crackberry.com/f52/new...nguage-339941/

    01-01-10 10:15 AM
LINK TO POST COPIED TO CLIPBOARD